Linux Distro's are failing to partition disk

Discussion in 'Parallels Desktop for Mac' started by tomservo291, Aug 30, 2006.

  1. tomservo291

    tomservo291

    Messages:
    90
    I'm on a MacBook Pro 15.4" 1.83Ghz 2GB RAM / 80GB HD.

    I've got a 15gb WinXP Pro SP2 virtual machine all setup that I use daily for graphic design and website design for compatibility reasons between browsers/operating systems.

    I want to install a Linux distro (It really doesn't matter to me, I just need a linux environment for CIS school project purposes, etc.) I've already tried Open SUSE 10.1 (DVD ISO.) First, I learned how to overcome the packages not showing up with the disconnect/reconnect trick, and then how supposedly to use expert mode and create my own partitions to avoid that error. Still no luck, Open SUSE 10.1 won't partition the drive.

    I tried XUbuntu (Ubuntu packaged with xfce instead of Gnome.) This would be my distro of choice as it is lighter in weight and can still run GTK 2.0 applications. This appears to partition "OK" until the install reaches 15% where it indicates "detecting filesystem," this is apparently after the partitioning, but I don't know for sure since the Ubuntu installer is pretty much absent of technical info so that lay users can easily install it.

    I tried Open SUSE 10.1 from the CD's, still no luck.

    I'm downloading regular Ubuntu right now...

    I'm using the latest beta of parallels, 1024MB RAM allocated to parallels, 768MB RAM allocated to each virtual machine. I'm trying to use a 8GB expanding partition for these linux distro installs.

    Thanks for any insight you may have.
     
  2. tomservo291

    tomservo291

    Messages:
    90
    I finally ran accross an account of someone with similar issues.

    Recently I upgraded to 2GB RAM, and i've been allocating between 512-924mb of ram to the VM's that I attempt to create.

    I tried someone's advice using the "default" VM settings and leaving it at 256mb of ram and it loads up the Ubuntu 6.06 live cd about 4x as fast as it did with 924mb of ram, and the install went through without a hitch.

    What gives?

    I have 2GB of system ram, with Parallels set to use 1024 max. Windows is using 924mb just fine...
     
  3. tomservo291

    tomservo291

    Messages:
    90
    After some trial and error, I have determined with my machine I cannot allocate more then 512MB to a linux VM.

    I even tried installing Ubuntu, XUbuntu and Open SUSE 10.1 with < 512MB ram, and upping it after. This doesn't work, as the distro's wont boot. But switching back to 512 or less and it boots and
    operates just fine.

    My system, one more time:

    15.4" MacBook Pro
    1.83GHz
    80GB hd

    2GB RAM
     
  4. majortom

    majortom

    Messages:
    98
    Installing Kubuntu 6.06 on External HD failed because it doesn't create automatically the bootstrap partition on it while it did when I installed it onto the internal HD. I think the solution is to install it wherever you like but the bootstrap partition must be MANUALLY created into the internal HD.
    You should check the solution into Linux forums, not here. I believe this is a Linux-only related problem, not a Parallels' problem.
     
    Last edited: Aug 31, 2006
  5. lightspeedbiker

    lightspeedbiker Bit Poster

    Messages:
    3
    SuSE 10.1 Failure to bootstrap partition

    I also have failed to get SuSE 10.1 working on my macbook.
    Ubuntu 6.06 installed easily on the first attempt.

    I do want to use SuSE 10.1, there are others that have it installed and working.

    Here's some info that may contribute to a solution. This fellow seems to have solved it.:)

    --cut--
    FROM http://forums.suselinuxsupport.de/index.php?showtopic=37801

    QUOTE(clindahl @ Aug 4 2006, 04:36 PM) *

    I have successfully started an install of SUSE 10.1 on Parallels Virtual Machine product on a Macbook Pro under OSX 10.4.7.

    I had to go through the steps cited on the Parallels support forum at:

    http://forum.parallels.com/thread3169.html61

    1) The "missing catalog" issue (connect/reconnect the DVD (in my case, a DVD ISO image))
    2) The 3030 format error during creation of the swap area.

    I handled #2 by going into the "expert" mode and creating my own partitions; one swap area (I set up 512M), and the other partition whatever was left for the root ("/") partition.

    If anyone else is interested in this process I'd be glad to post further info on this thread.

    Charlie
    --cut--

    John L
     
  6. LGgeek

    LGgeek

    Messages:
    6
  7. torque2k

    torque2k

    Messages:
    1
  8. sdidier

    sdidier

    Messages:
    2
    I have a 2.33 GHz 20"iMac with 2 gig of memory and I'm runn ing the latest beta of Parallels. Like other posters I have had mixed luck with Linux installs. However I installed Simply Mepis 6.0 in a VM last night. The install went off without a hitch, I did accept the default memory allocation etc. I've updated it earlier today and it runs beautifully except for the optimized feature fro Windows such as window resizing and coherence.
     

Share This Page