Linux Guest and Networking

Discussion in 'Parallels Desktop for Mac' started by sfwalter, Apr 8, 2006.

  1. sfwalter


    First of all I'm on a Macbook with airport wireless connectivity. I have tried to install both Ubuntu and Fedora Core Linux, with no success with networking.

    On either linux guest system it tries to bind networking to eth0. I guess my first question is does Parallels pass both networking (wired and wireless) to the guest operating system? So does eth0 on Linux alway point to en0 on my Mac? Or should eth0 point to either en0 or en1 based on which networking option I selected in the configuration of the virtual machine.

    Any ideas? scott.
  2. Frank Roscher

    Frank Roscher

    eth0 refers to the en0 (ethernet) or en1 (wireless) in the way you configure it in the VM config (installed Debian Sarge - works fine on en1 since beta 2)

    I did set IP Adress by hand, if your Router is try:

    ifconfig eth0 up
    route add default gw

    on the guest console
  3. jsolderitsch


    Fedora Core 4 Networking Unsuccessful

    I can also confirm that networking with Fedora Core Linux seems to be broken.

    I have a router that is handling dhcp for all of my machines. I have bridged Parallels to my wireless connection. I tried bridging to my wired connection with no better results.

    But when I bring up Firefox in the Fedora Core 4 VM, I never get a connection to an outside url.

    I can't ping a remote machine either.

    Both of the network interfaces work ok from the Mac OS X side.

    I use the network control panel in Fedora and I see that there is a DNS address apparently determined from my router -- it's the same one that I see on the Mac side.

    Interestingly if I disable dhcp, set up a manual address and router value and then set the DNS value to the one I see automatically created, I can ping the DNS machine (it's a verizon dsl machine). However, I still can't use Firefox to browse the web.

    I am restarting the VM after I make network changes to make sure they are perceived by the VM.

    But no joy.

    Any suggestions appreciated.

    Last edited: Apr 10, 2006
  4. davidee


    its not fedora but....

    I have red hat enterprise 4 working network wise outbound to the host and internet.

    can ping, can ssh...all good
  5. jsolderitsch


    Just to follow up my own message.

    Took my Macbook Pro into work (2.16 ghz/ 2 Gig RAM, running 10.4.6 -- no firmware update). Running Parallels beta2.

    Re-booted the Fedora Core 4 VM.

    Still no DNS.

    I check the Network control panel in Fedora -- looks like my local DNS addresses are populated correctly.

    As root, I run /sbin/ifconfig and it looks like I have a reasonable assigned IP address.

    But I can't ping and I can't browse the web using Firefox.

    Seems like network bridging from Parallels is not working correctly.

    If anyone has a Fedora Core VM running and is using their ordinary network dhcp setup and is able to get DNS to work, please reply to this post.

    Except for the networking part, I am mightily impressed with how fast the VM performs.
  6. scamp


    Ubuntu Networking not-working

    I just installed Ubuntu 5.10 and it does not seem to recognize the bridged network either...
  7. scamp


    also forgot to mention the cd driver doesn't seem to work...I tried to install the Ubuntu live cd, and while the cd shows on the ubunt desktop, when I try to open it I cannot see any of the files....
  8. spullara


    I have the same issue with RHE 4.3.
  9. davidwsica


    Same issue here with Ubuntu.
  10. simon


    works for me

    I manually set IP, default route and DNS though.
    DHCP does definitely not work.

    I installed Fedora Core 5 on the VM. The VM works fine with DHCP both at work and at home. At work I have a wired conection, so I start the VM bridged to the en0 network device. At home I use a wireless router, so I change the configuration there to use en1 and specifiy that it's a WiFi adapter. It's annoying to switch conections, but it works for me.
  12. Scott Willsey

    Scott Willsey

    I installed ubuntu 5.10 and it works fine if you are bridging it to en1 on the mac (airport express). You do have to go into networking administration and enable the ethernet apapter (en0) in ubuntu. By default it is disabled. Parallels bridges it then to en1 (assuming you have your VM set up to do so).

    After that simple change, my installation was online and golden. Ubuntu was the easiest OS install I've done besides OS X. :)
    Last edited: Apr 11, 2006
  13. roscoe13


    I've had no problems with both DSL 2.1b & 2.3 and Debian 3.1a net install, all managed to pick up IP addresses and are able to access the 'net without any help from me...

    Core Duo mini, wireless...

  14. roscoe13


    Oh, and parallels 2.1B2...

  15. twoblackeyes


    I just downloaded beta 3 and ubuntu networking still isn't working. I've configured and enabled eth0 in ubuntu and set it to bridge en0 in the VM config. My Vm is classified as "Other Linux." Does airport have to be disabled in OS X for it to work? Anything else I may be missing?

    Note: in the ubuntu network config, I always change "Default Gateway device" to eth0, but it's always changed back to a blank field whenever I close and re-open the panel.
  16. ehamburg

    ehamburg Bit Poster

    Just to echo the comment by Scott Willsey, I was able to get networking on Ubuntu simply by going into the networking settings and enabling the ethernet interface.
  17. keirnna


    I'm having very similar problems with Ubuntu!
  18. jj-virtual


    Ubuntu Networking

    Are there any HOW-TO's on networking a LINUX (* UBUNTU/SuSE... *) VM within a windows environment?
  19. jam


    Secured wireless network?

    Are any of the people without problems using a secured (wpa/wep) wireless network?

    Are any of the people with problems using a unsecured wireless network?

    I can get networking to work ok over an AirPort device as long as I'm using an unsecured wireless network.
  20. nhand42


    Works fine with Debian guest and WPA2

    I'm using a Macbook Pro with WPA2 wireless and beta5. Linux networking is very robust for me. The VM is configured to use the "default adaptor" though in beta4 it also worked by selecting the airport adaptor. In both cases I used bridged mode. Inside Debian (within the VM) it appears as a Realtek card (eth0) and DHCP works as expected. Both the Macbook Pro and the Debian guest OS can independently receive leases from the DHCP server. Here is a dump from /usr/sbin/arp on another machine.

    Finlandia.local ( at 00:16:CB:07:90:40 [ether] on eth0
    ironmask.local ( at 00:16:CB:07:90:40 [ether] on eth0

    Finlandia is the Macbook Pro. Ironmask is the Linux guest OS. Notice that they share the MAC address but have a different IP address. It's possible that the same MAC address is confusing to your DHCP server. If so, you'll need to use the other networking mode, not bridged mode.

    PS: bridged mode means the VM ethernet is bridged to your physical ethernet. To my mind this is the best mode because it means broadcast traffic (eg, Rendezvous, Bonjour, whatever they're calling it this week, DHCP, Samba network discovery) will all work seamlessly between the guest OS and your real machines on the physical network.

Share This Page