Lion: VM window/Parallels dialog not accessible

Discussion in 'Installation and Configuration' started by HansAST, Jul 25, 2011.

  1. HansAST

    HansAST Bit Poster

    Messages:
    9
    On my Lion based macBook Pro I have the following blocking issue:

    I started a Windows XP professional VM but it does not show itself.
    On Snow Leopard the VM list was shown on a different screen in Spaces.
    The VM was configured on a different Space and normally the screen would show there. (Both in the active or stopped/suspended state)

    On Lion the screen shows nowhere...
    Using CTRL left or right arrow to move from one screen (still called Space) to the other briefly shows the VM screen...
    In Misson Control the screen is not shown...

    A right click on the Parallels Icon in the Dock shows a context menu with the option to view all windows. There the VM screen is shown, but when you select it, it disappears...

    Actually trying to stop Parallels does not work either, because the Dialogue asking if the VM should be stopped or suspended is also in this 'twilight zone' between spaces.. (Excuse me for the pun...)
     
    Last edited: Jul 25, 2011
  2. HansAST

    HansAST Bit Poster

    Messages:
    9
    I regained control after deleting all extra screens in Mission Control...
    First I suspended the VM by clicking on the ON/OFF button in the VM list.
    Then deleted the Mission Control Screens..
    Rebooted, (just in case) and after restart with just one screen in Mission control, I was able to view the VM again...
     
  3. Steffen Dyhr

    Steffen Dyhr

    Messages:
    3
    Nice, but...

    I also had PD on another space and can't see it now after upgrading to Lion. Your solution I don't like, because I still want to have PD on another Space. And this problem seems to lie within Parallels, as I had assigned Mail, Microsoft Expression Media and Amadeus Pro for all different spaces, and I have no problems with these at all. Only with Parallels Desktop. So I want Parallels to come up with a solution. AND NOT THE USUAL ONE: PLS REINSTALL THE WHOLE THING! I'm allergic to that solution, as I have heard it so many times and I DO NOT WANT TO! (Hope the guys in Parallels read this!)

    Thanks for your post - nice to see that I'm not the only one experiencing this!
     
  4. paulmcdowall

    paulmcdowall

    Messages:
    2
    I have a similar issue on my Lion iMac. Under Snow Leopard I had Parallels assigned to space 2. In Lion I'm using the 3rd one. Booting any of my Windows VMs exhibits the exact conditions HansAST describes.

    While not a perfect fix, I found a quick workaround that doesn't require removing my Spaces in Lion. Once you've started booting the VM (and it's disappeared), simply right-click the Parallels icon in the dock. Choose Options and in the submenu assign Parallels to All Desktops.

    I instantly see the VM when I do that. I can then repeat the process but assign it to This Desktop, and that lets it work with Spaces in Lion. Until, you quit the VM and restart it. Then you have to do it all over again.

    Better than losing Spaces, but needs a permanent fix.
     
  5. John Featherstone

    John Featherstone

    Messages:
    4
    Yes, I'm having the same problem. It's like the guest OS is living in between windows of the "Mission Control" application. Can't bring it to the front. As one person suggested, I eliminated all the extra desktops in Mission Control, but that is at best a temporary solution. That neuters my best working pattern of working in one OS, and working in the other OS on another desktop.

    Also on my MacBook Air, it returns and error message and says it "can't load parallels drivers, reboot and try again."

    That loop is infinite, regardless of how many times I try to reboot. Another reader has provided a script to copy and paste into terminal, but I had no luck with that.

    Looks like the perceived full compatibility of Parallels 6 is bogus.... I haven't even had time to see if VMware Fusion is playing nice with OSXLion on the office iMac computer yet..... Guess I'll go in and get the bad news tonight too.

    At this point I'm wishing I hadn't been so greedy to do my upgrades in the first week. Should have waited a month or so.

    I am running the latest build release available on everything as of 7/29/11, and my machines meet the requirements as well.

    jf
     
  6. JGHT

    JGHT

    Messages:
    1
    Easy Solution

    Move to the "space" or desktop you want the PD to be in. Right or control click the Parallels icon in your dock and assign it to that desktop.
     
  7. Tackmac

    Tackmac

    Messages:
    1
    Had exactly same problem - interestingly it happened upon first run of P6 after upgrading to Lion - couldn't see the VM window (WinXP) unless was midway between desktops (!). Got that settled and then found the same issue with the configuration dialogue.
    Following the advice here (initially deleting other desktops then setting open in all windows etc) finally solved it. It is a bug - suspect a permanent fix is on the way in the next update .
    Thanks for the advice BTW :D
     
  8. JonDuquesne

    JonDuquesne

    Messages:
    1
    I have a possible solution or workaround!

    I too have been going nuts because P6 will start up, I will click on one of the VMs, it will show the window for a fraction of a second and then disappear into the corner, never to be seen again.

    As John Featherstone suggested above, I first tried and eliminated all extra desktops in Mission Control. I rebooted and tried starting P6 again. That at least allowed me to see things again. I then "adjusted things". Here is what I found.

    Go into System Preferences -> Mission Control
    UNCHECK Automatically rearrange spaces based upon most recent use
    UNCHECK When switching to an application, switch to a space with open windows for the application

    Reboot, just to make sure. When you have started back up, start Parallels. There is a good chance that it will start in Desktop 1. You can create additional desktops (spaces), and use Mission Control (or 4-finger gesture) and drag Parallels or the VM to that new desktop. BUT each time you start a new VM, or one that has not been run for a while, it will most likely start in Desktop 1. But once you have dragged it to the new desktop, it *should* reopen there. I have been able to create 4 different desktops, and open P6 and VMs in each one of them.

    This is still a workaround and I hope Parallels cleans things up soon.

    Oh, one other silly thing I observed. If you start two different VMs and then shut them both down, when you restart Parallels, the LAST VM might just restart. I have not been able to consistently replicate this though.

    I will monitor this thread for a while and hope that it helps you folks.
     

Share This Page