Live-Android VM networking?

Discussion in 'Linux Guest OS Discussion' started by bfindlay, Feb 9, 2012.

  1. bfindlay

    bfindlay Bit Poster

    Messages:
    25
    Have managed to install live Android .3 and it runs. Cannot access the net though. Tried to configure the ip settings in the console as per the instructions at live android, but still get nothing.

    Any suggestions? Tried configuring the vm with ethernet, and again with wifi on my mac. Don't know where to go with this.
     
  2. SakibS

    SakibS Kilo Poster

    Messages:
    104
    You can configure you network adapter three way...

    1. Host Only Network
    2. NAT
    3. Bridge mode

    If you wanna use wifi in your guest machine then you have to plague a external USB/SATA wifi network adapter.


    _______________

    Sakibs [​IMG]
     
  3. bfindlay

    bfindlay Bit Poster

    Messages:
    25
    Thanks for responding. Not sure what exactly you mean by use an external/USB wifi adaptor. I have an iMac running Lion, and it has an ethernet connection to the net. Parallels runs WinXP and connects through that connection just fine - but the Android VM doesn't. I have tried enabling WIFI (I can do both ethernet and WIFI simultaneously) and told the Android VM to use wifi. I entered the appropriate ifconfig settings in Android console, but it still doesn't connect.

    Still stumped. Sorry, I just don't see how to get the VM to use my macs internet connection successfully.

    -still frustrated.
     
  4. JyWuSomeguy

    JyWuSomeguy

    Messages:
    1
    Are you sure its possible?

    I don't think you can do that. I got Android 4.3 Jelly Bean (I suppose) and Wi-Fi is in a off state, even when I turn it on. When I turn it on (in settings), it is off in notification centre. I've tried Bridged, Host-only and shared and none works. Hope this helps!
    NOTE: I AM USING PARALLELS 9 ON A MacBook Pro WITH OS X 10.6.8, NOT AN iMac.

    Details:
    - MacBook Pro 2010
    - OS X 10.6.8 Snow Leopard
    - Parallels 9 (Android 4.3)
     
  5. Elric

    Elric Parallels Developers

    Messages:
    1,718
    Hi,
    the recommended way is to use Parallels preinstalled Android Image (menu of Parallels Desktop File -> New ->choose Download Android Free).

    Afaik, while installing Android another way, there will be no Network drivers for adapters that Parallels know how to emulate (e1000/rtl8029/virtio) :-( But I'm not sure, since I looked at this more then a year ago.
     
  6. RLHrlh

    RLHrlh Bit Poster

    Messages:
    10
    Elric,

    I'm having this exact same problem and I did use the version that is available through Parallels. Also, I typically use Parallels to run Win7. I've doubled checked-- my settings for Android are configured just as they are for Win 7. I've never had trouble with Win 7. I can't get Android to connect.

    To be clear, I am using a Bridge connection, to my default adapter. I have a MBP, plugged into a Thunderbolt display. The display is plugged directly into my router.
     
  7. spaceneedle

    spaceneedle Bit Poster

    Messages:
    1
    stop the VM
    configure
    hardware
    change NIC type to "Realtek"
    ..my android VM network works now! (works for google play, web browser, etc).
     
  8. Felipe2

    Felipe2 Bit Poster

    Messages:
    2
    I tried this but it still not work. I can find any wifi connection in the wifi menu in the VM. Please help

    Thanks
     

Share This Page