Lost Sound, dunno why

Discussion in 'Parallels Desktop for Mac' started by ccparallels, Jul 12, 2006.

  1. ccparallels

    ccparallels

    Messages:
    94
    My daughter was running Putt-Putt Travels Through Time (many such games run fine) and went to have dinner. When she returned the MBP screen was dimmed, and when she resumed play the sound was off. I tried everything, from suspending the VM to turning mac and xp and parallels sound on an off, and even rebooting the MBP. Finally gave up and shut down Windows, upon which is did play the Windows shutdown sound. I don't know if this had to do with DirectX or not.

    Also, upon rebooting and a VM power on, the game could not access the CD for some reason. I had to eject the CD and reload it.
     
  2. ppayne

    ppayne

    Messages:
    32
    Ditto

    Me, too. I am trying to test a game we're bringing out, and the sound works great for about 5 minutes, then disappears. If I reboot the VM it will start working. Can anyone suggest anything?
     
  3. ppayne

    ppayne

    Messages:
    32
    My situation

    For my own situation, restarting the game makes the sound work again. Windows sounds themselves seem to be fine (the volume sound works for example). I hope they polish this part of the system.
     
  4. ccparallels

    ccparallels

    Messages:
    94
    I'm beginning to think the missing sound is do to something with reading the CD failing. At least in one case after the machine went to sleep, the game could not locate a file either. But it's done it w/o going to sleep too. It's of course possible the game has a bug, but it's always played on other machines ok.
     
  5. sbc

    sbc

    Messages:
    6
    Same problem, not CD related

    I've experienced losing sound a couple of times now, and neither time involved the CD. In both instances I was playing streaming music via a subscription service (thanks to ||s, can't do that on OSX! ;-), and the sound just stopped.

    When this happens, sound appears to be lost across all Windows apps, not just the one you're in at the time. I spent some time mucking around in the control panel without any success. Nothing appeared amiss in Device Manager or anywhere else.

    Sound continued to work fine is OS X.

    A reboot of the VM was required to get sound working again. Suspending the VM and restarting Parallels did not work for me.

    I'm about out of ideas.
     
  6. CybrMike

    CybrMike

    Messages:
    1
    I am also experiencing instant sound loss. At around 10 minutes or so of using a skype call in windows, the sound just stops, and no sound on the windows vm will work after that (os x works fine). Then when you goto shutdown, the shutdown sound works fine.


     
  7. ccparallels

    ccparallels

    Messages:
    94
    My daughter was playing yet another game where the sound was not right. This time, the sound actually repeated itself. I don't know if they game detected a failure in outputting and retried or what.

    Anyway, I turned off hardware acceleration for the speaker and at least for the current run of this particual game, the sound seems to be normal. Does this work for anybody else having sound problems? I'm curious what might be causing this if so? And also, what is lost by turning hardware acceleration off?
     
  8. Hesiode

    Hesiode

    Messages:
    3
    I have the same problem :(

    No sound after some minutes under windows xp (i have a mac)
     
  9. Hesiode

    Hesiode

    Messages:
    3
    Someone know how resolve this problem ?

    (i play unibet poker, and sound off during that)
     
  10. unused_user_name

    unused_user_name

    Messages:
    495
    I donno if it's related but I lose sound input during dictation to Dragon every now and again.

    I can fix the problem by re-initilizing the sound "hardware" in WindowsXP through a audio editing program called Audacity.

    Maybe one can re-initilize the playback sound in the same way? I have not tried.

    Details on re-initilizing the sound input:
    http://forum.parallels.com/thread2721.html
     
  11. Hesiode

    Hesiode

    Messages:
    3
    Thx you very much but i dont want install audacity...

    But its a good idea !

    I hope parallels developpers fix that.
     
  12. ccparallels

    ccparallels

    Messages:
    94
    Just a followup that turning off hardware accelleration doesn't fix the sound problems as I previously thought :(
     

Share This Page