Mac becomes unstable, stuck on spinning circle

Discussion in 'Windows Guest OS Discussion' started by AimanT, Jun 9, 2020.

  1. AimanT

    AimanT Bit Poster

    recently I'm suffering from parallels after upgrading to 15, my mac works perfectly fine until I open paralles and load windows 10.
    it happens randomly. suddenly parallels become not responding and macOS stuck and become very slow. all other apps become not responding and take a very long time to work.

    Ends up by force closing parallel (sometimes never work and had to force shutdown mac) later on another journey of waiting windows to check disk after force shutdown and crossing fingers that this time it would work.

    I've looked up forums before posting, did everything possible, from reinstalling parallels to resetting repairing windows, SMC and NVRAM you name it, everything ends up the same.

    My device is mid-14 i7 MacBook pro with 16 GB
    The technical report took me multiple tries to generate: 342163658
  2. GowthamR@Parallels

    GowthamR@Parallels Bit Poster

    @AimanT hi, we have sent the personal message, please check and reply on there to assist you further on this issue.
  3. CKathens

    CKathens Bit Poster

    It would help if the solution us made public. I am facing similar problems repeatedly. Parallels seems to have serious issues (I am using v. 15.1.4 build 47270). After 10 years if use, I am now actively exploring VMware Fusion or using BootCamp instead.
  4. AimanT

    AimanT Bit Poster

    @GowthamR@Parallels So I reached for support on Telegram. the bot is not working or responding...
    FB messenger sent 3 days ago but still no response.
    I have shared the technical report 8 days ago and yet get any sort of feedback.

    I appreciate your support on this, I can't work like this and my biggest regret is putting everything I need on that VM that doesn't work!!!
  5. CKathens

    CKathens Bit Poster

    I had a similar problem (Windows 10 Pro update 2004, on Parallels 15.1.4) and with the help of Parallels Support it seems to have been resolved by following this procedure:

    1. Click on the Mac menu bar > Apple logo > System Preferences > Security & Privacy > unlock > on the left side, scroll down to Accessibility menu and enable Parallels Desktop.
    2. Again Scroll down to the Files and Folder menu and enable Parallels Desktop.
    3. Again Scroll down to the Full-disk menu and enable Parallels Desktop.
    4. Disable firewall and Antivirus on Mac.
    5. Follow the steps from KB article:
    6. If necessary also follow the steps in Kb article

    After chkdsk in step 5, "scanning and repairing drive" was completed but stuck at 100% and would not proceed to reboot on its own. internet search indicates this is frequently experienced with Win10. Had to Stop (Parallels Desktop Menu bar > Actions > Stop) after which Windows VM started as usual. I think it would be a good idea to shut down and start (as opposed to Restart) two or three times to give WIndows a chance to clear things up.

    My system seems to run smoothly for the time being and I hope this will continue to be the case. Otherwise my plan is to (1) do a fresh clean installation in a new VM, or (2) install in BootCamp and link it to Parallels (see

    I hope this helps.
  6. AimanT

    AimanT Bit Poster

    So Support remotely accessed my machine and found that there are too many errors on disk first aid:
    warning: xf : INO_EXT_TYPE_DSTREAM : found unexpected dstream associated with non-regular file

    Lookup everywhere and I didn't find any solution for this, and since my MacBook is out of warranty I couldn't reach Apple support.
    end up with pave and nuke way, did a manual backup and restore as time machine would be the one causing this. Now everything works fine
  7. AlanaL

    AlanaL Bit Poster

    RESOLUTION: Since, for some reason, Parallels support seem to be unwilling to assist I will post the resolution here. Go to Actions on Mac menu bar > click Reset. This may take a few minutes to fully force shutdown the Mac. When the screen is fully black it will automatically restart the Virtual Machine.
    DaveF10 and Maria@Parallels like this.
  8. DavidJ37

    DavidJ37 Bit Poster

    Thanks Alana - that worked after half an hour of looking for other solutions! Thanks!
    NeilP6 and Maria@Parallels like this.
  9. NeilP6


    Thanks from me too, Alana. A nice quick solution to this problem that has occurred twice now following a Parallels Desktop update.

Share This Page