Mac hangs and crashes when deleting or merging Windows 10 VM snapshot

Discussion in 'Windows Guest OS Discussion' started by Jan Olsen, Dec 19, 2019.

  1. Jan Olsen

    Jan Olsen Bit Poster

    Messages:
    4
    I have recently started experiencing complete Mac hangs and subsequent restarts (Kernel Panic) when SmartGuard has to delete a snapshot to create a new one. It also causes corruption of the W10 VM.
    Creating a snapshot without the need to delete an old snapshot is fine.
    Using https://kb.parallels.com/111736 produces the same problem unless I start the Mac in Safe Boot mode, which allows the merge to complete.
    I do not have this problem with my XP VM or with my W7 VM.
    I use MacOS Catalina and Parallels 14. The problem started prior to the Catalina upgrade, so it is unlikely to be a Parallels/MacOS compatibility issue.

    Whereas the above workaround is OK in the short run, I would ideally like a proper fix for this.

    Any suggestions welcome. Please.
     
  2. Jan Olsen

    Jan Olsen Bit Poster

    Messages:
    4
    OK.
    As I have had no replies, I betterI turn off SmartGuard for W10 VM.
     
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,623
    Could you collect the tech report right after crash? And also test Parallels Desktop 15 trial and check the same behavior.
     
  4. AlanH3

    AlanH3 Bit Poster

    Messages:
    3
    I have recently had numerous issues with Win 10 VMs crashing or freezing or I couldn't even restart or even reset the VM, and assumed it was just another Microsoft problem. Then my gut feeling told me to switch off SmartGuard in all three VMs - and lo' and behold, those problems ceased. There is obviously some incompatibility issue here: I am using Catalina (latest update) and Parallels 15.1.3. The Windows VMs also update automatically.
    Having disabled SmartGuard I now allow Time Machine to back the VMs up once a week and, for daily or even hourly backups, use ChronoSync to copy crucial project files to an external Synology drive. Win Backup only works when it wants to, so that's no use. Nero Backitup says it's done something but does absolutely nothing, so I'm stuck with this rather clunky arrangement, but it works. What is most essential is that the VMs work as well. A real solution from Parallels would be a help.
     

Share This Page