Mac OS X won't boot anymore after using Parallels

Discussion in 'Parallels Desktop for Mac' started by mbohnen, Dec 21, 2006.

  1. mbohnen


    I have a MacBook Pro with Mac OS X and WinXP installed (via Boot Camp).

    I tried the latest Parallels Beta, because I wanted to try to boot my WinXP install inside Parallels.

    Unfortunately, I forgot that the last time i booted WinXP, I didn't shut it down, but put it into hibernation.

    Well, booting this hibernated WinXP from inside Parallels didn't work.

    After the next reboot, Mac OS wouldn't boot anymore, it hangs forever.

    To be more precise:
    Starting Mac OS in "verbose mode" gives the following endless error:
    "SATA warning: Completing a zero block transfer"

    Starting Mac OS in "singe user mode" and performing "fsck -f" gives me the follwing:

    ** /dev/rdisk0s2
    ** Root file system
    ** Checking HFS Plus volume.
    ** Checking Extents Overflow file.
    ** Checking Catalog file.
    Incorrect block count for file mach
    (It should be 1 instead of 0)
    Incorrect block count for file mach.sym
    (It should be 151 instead of 48)
    Invalid sibling link
    (4, 5359)
    ** Volume check failed.

    Windows was somehow damaged, too, but I was able to restore it.

    Any clues??

    P.S.: I searched the forum but could not find anything on this.
  2. Olivier

    Olivier Kilo Poster

    I can't think of what you exactly did, but it looks like you set yourself for a full HD re-format and re-install of Mac OS X and then bootcamp and xp. Though before this you should boot on your Mac OS X CD/DVD to access the Disk Information and tools and proceed with a check and repair. You may recover a bootable Mac OS X.
  3. Olivier

    Olivier Kilo Poster

    Might as well be related to hardware problems with your disk, btw.
  4. joem


    It looks as if your boot disk is damaged. You might try installing OSX on an external drive, booting from it and seeing if you can mount the internal drive so that you can recover your data. You will have to reinstall Parallels since copying the app won't work. You will probably have to reinstall other apps as well. You can use the Apple upgrade assistant to transfer your user accounts and most data if the disk is readable.

    Once the external disk is set up, you can clone it back to the internal disk. My favorite app for this is SuperDuper. The free version will work for cloning the external to internal using erase and copy. I've actually done this and it's worked fine.

    After you do the copying to the external disk and before you copy the data back, you may want to run some hardware diagnostics to make sure the internal disk is not defective.
  5. mbohnen


    Thanks for the answers.

    I'll try your suggestions.
  6. mckinney


    Same problem but without parallels

    I have exactly the same problem described here. For me also, the problem came following a long period where windows (bootcamp) was hibernated. I tried to boot windows and had some strange problems with the mouse (not active), restarted and then could not boot Mac OS X any more. Windows seems to work fine.

    I have a MacBook with Mac OSX and WinXP (boot camp).

    Looks like I'll too have to reformat or at least reinstall the system. Any clue as to why this happens (or what exactly is going on)?

  7. SteveDemy


    A repair tool

    If you have valuable data on the disk and want it back, try Diskwarrior. It's good at finding and fixing volume related problems.
  8. ajwans


    Try using Techtool Deluxe which comes with the Apple Protection Plan. I suspect Parallels
    killed my volume structure somehow too and I got a kernel panic every time the root device
    was mounted read-write, i.e. early in the boot process. Running Techtool and repairing the
    volume structure fixed it up for me.

  9. Jerry

    Jerry Bit Poster

    Try the following before you re-format & re-install everything:

    - get your os disk out that came with your mac
    - insert and launch the os installer
    - after reboot from the dvd, choose your language
    - then use the 'Utility Menu' and choose disk utility.
    - run a disk repair on your startup drive
    - if DiskUtility finds errors & could fix it, it should run a second time. If not, run it again.

    Most of the time this fixes things up. If it does, just choose 'Startup Disk' from the Utilities menu, choose your Mac HD & restart.

    Another 'trick' that often fixes hard drive issues, is to run the apple hardware test. I know this is only 'suppose' to check things & report back on the condition of your mac, but it has actually fixed a drive that didn't want to startup a few times for me, on various machines.
    To run the Apple Hardware Test, AHT, reboot your Mac with your Mac OS dvd in the drive, and after the chime, hold down D (for Diagnostics). This will boot the Mac up into the hardware test mode. Then once booted up, choose the extended test and go & have a coffee. After it's done, reboot the Mac (and cross your fingers).

    Hope this helps.
  10. illovich


    A similar thing happened to me (although I 'm not sure Parallels was the cause), and when Disk Warrior failed, ALsoft tech support walked me through reading the boot record of the HD, which was filled with garbage.
  11. amper


    I just had a similar problem with my C2D MacBook. I had rebooted last night, and a wierd thing happened. The login window never entirely went away after I logged in. I still had the box with the progress bar going, with the text reading "Starting Mac OS X" (or some such). I thought, "Hmm...that's strange", and logged out (which seemed fine), closed the lid and put it back in my bag.

    I few hours later, I woke up thirsty, so I went downstairs to get a drink. While sitting on the couch, I noticed the power light of the MacBook on solid, when it's supposed to be blinking. Pulling out the MacBook, I discover it's *very* hot and it won't wake up, so I hold in the power button to shut it down.

    Powering up, I watched the white apple screen and the clock go for awhile before I realized something wasn't right. So I powered it down again. This time, I booted into Windows. Windows ran through a disk check and fixed a few things. I happen to have MacDrive installed, so I could see that there were at least files on the HFS+ volume. So I shut down, and rebooted into Mac OS X, with verbose mode.

    That's when I discovered the "SATA WARNING: Completing a zero block transfer" message flashing endlessly across the screen. So I powered it down and tried again, with the same results.

    I took the MacBook up to my C2D iMac, installed DiskWarrior 4.0 (which I hadn't bothered to do when my CD came in the mail), attached the MacBook in Target Disk Mode, and ran DiskWarrior on the HFS+ volume. A whole fscking mess of problem were repaired, including the allocation sizes of "mach" and "mach.sym".

    Here's a excerpt from the DiskWarrior Report:

    Disk: "MB1OSX"
    Repaired Item Count
    Repaired the Total File Count of the Volume Information
    Repaired the Total Folder Count of the Volume Information
    Repaired the Available Disk Space of the Volume Information
    Repaired the Attribute Bits of the critical Volume Information
    Detected More Items
    Location: "Desktop"
    Folder: " HFS+ Private Data"
    Repaired Item Count
    Location: "MB1OSX/"
    Folder: "Users"
    Repaired Item Count
    Location: "MB1OSX/"
    Folder: "Install Parallels Desktop.pkg"
    Repaired Custom Icon Flag
    Location: "MB1OSX/Library/Receipts/"
    Folder: "10"
    Recreated this Missing Folder
    Repaired Item Count
    Moved to the Rescued Items Folder
    Location: "MB1OSX/Rescued Items/
    File: "mach.sym"
    Repaired Allocated Size
    Location: "MB1OSX/"
    File: "mach"
    Repaired Allocated Size
    Location: "MB1OSX/"

    A bunch of other files had their Text Encoding repaired.

    Replaced the directory, rebooted the MacBook, and everything seems fine for the time being. Disk Utility reports the SMART status as "Verified", which is a good sign.
  12. dmeehan


    I posted elsewhere in this forum that fsck_hfs is the command to use, with the -r switch to rebuild the catalogue. Check the docs for all the switches (man fsck_hfs). fsck will not fix this sort of problem for HFS+ partitions. Apple did not even know this trick, I spent an hour on the phone with them when this happened to me. I managed to figure it out rather than take is to a service centre.

Share This Page