Mac Pro, VT-x support disabled?

Discussion in 'Parallels Desktop for Mac' started by joe12south, Sep 7, 2006.

  1. joe12south

    joe12south

    Messages:
    4
    "Your CPU supports Intel Virtualization Technology (VT-x) but it is currently disabled (locked by firmware). Virtual machine will be started without VT-x support (in software virtualization mode)."

    I tired following the lengthy threads about this problem and Mac Minis, but got a little lost. Anyone else seeing this on a Mac Pro (2GB RAM) ?
     
  2. groovyjason

    groovyjason

    Messages:
    15
    Yep, I saw it on my mac pro. :(
     
  3. awilliamsny

    awilliamsny

    Messages:
    9
    same here

    OK Parallels team, please let us know what to do?

    Mac Pro, 4gb ram (did the boot-args thing already - not very user friendly but it's done). Now I get this all the time

    Your CPU supports Intel Virtualization Technology (VT-x) but it is currently disabled (locked by firmware). Virtual machine will be started without VT-x support (in software virtualization mode).


    I (thought) i successfully completed install of Win XP.

    Help please!
     
  4. j-active

    j-active

    Messages:
    43
    To the original poster: Yes, same problem.

    Clicking About Parallels Desktop | More Info..., I see this:

    Virtual Machine Features:
    Virtualization Mode: Software mode 2

    Does anyone know if VT-x is disabled on Mac Pros by default and how to turn this on? Will the Mac Mini scripts from the previous thread work on a Mac Pro? Who wants to try first? :eek:
     
    Last edited: Sep 7, 2006
  5. jbmelby

    jbmelby

    Messages:
    80
    I don't get this message, and I have checked the option in the Preferences to restore all hidden messages.

    And when I check the About box and click "More info", it tells me that VT-x support is on.

    Interesting that some people should have this problem and not others . . .
     
    Last edited: Sep 7, 2006
  6. loughkb@yahoo.com

    loughkb@yahoo.com

    Messages:
    44
    There used to be this same problem on some of the minis. The fix was to shutdown parallels, put the machine to sleep, wake it up, and relaunch parallels. Then VTx support would work. I never had that trouble on my mini at home, but the one on my desktop at work did. There was no difference between the machines, both at the same firmware, same memory, etc.

    It's weird.

    Anyway, try the sleep thing and see if it works.

    Kevin.
     
  7. j-active

    j-active

    Messages:
    43
    Thanks a lot Kevin. The good news is that method works and Parallels reports Intel VT-x as the virtualization mode. Windows boots up in less than 10 seconds (holy cow!).

    The bad news is you have to remember to put your computer to sleep after every reboot. So, the next question is who is going to hack the kext and EFI scripts to enable VT support on the Mac Pro permanently. :)
     
  8. glberen

    glberen

    Messages:
    7
    How do you do this? I have the same config and am getting a message that I need to add a maxmem=4000 to my boot-args. I don't have a clue what it's talking about and the error message doesn't offer any help.

    Thanks.
     
  9. odin

    odin

    Messages:
    10
    Getting closer...

    I was getting the VT-x support disabled message, so decided to try resetting NVRAM using Cmd-Opt-P-R at startup. Next time I tried to launch Parallels, I got an "Unable to communicate with Hypervisor" message.

    I tried a lot of thing to fix that, what SEEMED to fix it was remove and reinstall Parallels, then sleep the machine and wake it.

    Next launch, no Hypervisor message and no VT-x message. Win XP booted MUCH faster.

    I wish I could be more definative about the fix, but it did make it work. Now maybe someone that knows what they are doing can figure out what really fixed it.

    Update: A few restarts of XP later I got a kernel panic when starting VM. Restart Mac, launch VM, VT-x message is back.
     
    Last edited: Sep 7, 2006
  10. groovyjason

    groovyjason

    Messages:
    15
    GLbren,

    in terminal type:

    sudo nvram boot-args="maxmem=4000"

    reboot your mac

    now parallels works! System profiler only shows 3.91gb of mem instead of 5, but I can always script this to turn itself off and reboot

    to remove maxmem setting type in terminal:

    sudo nvram boot-args=""

    Reboot your mac

    you should see full mem again.
     
  11. glberen

    glberen

    Messages:
    7
    Thank you!
     
  12. mcqueary

    mcqueary

    Messages:
    20
    FYI, sleeping the system appears to have solved the VT-x problem for me as well. What a pain!

    The NVRAM trick appears to be useless unless you have >= 4GB of RAM.

    Good luck!
     
  13. kshusker

    kshusker

    Messages:
    34
    My VT-x experience is the same

    Go the same VT-x error others with Mac Pros have reported.

    Quit Parallels and slept my Mac Pro

    Woke her up and ran Parallels and all is well.

    I then quit and re-launched Parallels and it still was working properly without the need to sleep my Mac for a second time, so it looks like you only have to do this workaround once and it will "stick" for as long as your Mac stays running (keeping fingers crossed)
     
  14. Pleiades

    Pleiades

    Messages:
    79
    Unfortunately as I mentioned in the other thread, probably the wrong one, the sleep trick worked to get rid of the VT-X problem but gave me the kernel panic in its place. My Mac Pro would kernel panic just as the Windows startup sound starts.
     

Share This Page