Mac Sleep Crashes RC2

Discussion in 'Parallels Desktop for Mac' started by bcjenkins, Jun 1, 2006.

  1. bcjenkins

    bcjenkins

    Messages:
    23
    The title says it all. I had PW RC2 running XP Pro SP2, MBP fell asleep. Woke up Mac, PW is hung.

    Brandon
     
  2. steve

    steve

    Messages:
    52
    Were you running in full screen mode? I've noticed that sometimes a Parallels dialog box pops up behind the VM and unless you go to console mode, you can't see the dialog. When this happens, it appears that PW is hung but actually it is not. Try alt-enter to see if you can get out of full screen mode (if in fact you are running full screen) and see if you can see a dialog box.
     
  3. bcjenkins

    bcjenkins

    Messages:
    23
    Thanks for the reply. I don't run in full screen mode. It is running in a 1280x800 window. When I attempt to quit, pw throws up a standby or poweroff dialog, I choose poweroff and the app locks up. I have to force quit it, not once but twice. I actually have to reboot to clear the VX-T process too.

    Brandon
     
  4. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    Could you wait a little after MBP wake up? It could take awhile to wake up Parallels app after MBP wak up.
     
  5. bcjenkins

    bcjenkins

    Messages:
    23
    If you could define that further.. I let it sit in its hung state for over 10 mins..

    Thanks,

    Brandon
     
  6. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    Thanks for reporting. Usually it should wake in 10-20 seconds, not more...
     
  7. leertaylor

    leertaylor

    Messages:
    2
    I also have this problem consistently on my 17" MBP Pro.

    OS X 10.4.6, 2Gb RAM
    768Mb dedicated to the VM, running Win XP. VT-x is enabled
    Problem occurrs with both RC1 and RC2 (did not try on earlier versions)

    I actually see it most often when just the display on my MBP goes to sleep because it is sitting unused for a while. I come back, and Parallels is completely locked regardless of how long I wait. A double force quit and sometimes a full machine reboot are needed to clear up the VT-x stuff.

    When I close the lid and put the machine to sleep that way, Parallels seems to wake up fine.



    Other than this, Parallels has been working beautifully for me. Thanks for all the hard work guys!
     
  8. mpatel696

    mpatel696

    Messages:
    4
    I have the same problem - have had it pretty consistently across all the betas. Was hoping that this would be resolved in RC2. Its an interesting problem b/c it doesn't seem to be tied to the MBP going to sleep anymore, seems like it has to do with inactivity? I have had fairly good results with putting it to sleep or it falling asleep and then returning. It even seemed to have survived a "hibernation" (or whatever its called when the MBP goes to sleep b/c the battery is dead). But still seems to die if I leave the MBP open and running but don't touch for over 30 min.

    I created this image (which I use primarily to run Windows based MS Office) back in B1, wondering if anyone has had luck when they recreate an image in RC2.

    MBP 1.5GB ram (768 to XP SP2, fully patched)
    Sound is Disabled
     
  9. bcjenkins

    bcjenkins

    Messages:
    23
    Hi Parallels team,

    What if anything can I do to help isolate this problem for reporting? This is a nusiance.

    Thanks!

    Brandon
     
  10. h4xwh0r3

    h4xwh0r3

    Messages:
    2
    I have had the exact same issue in all betas and also in the release candidates. I have pre-purchased a licence thinking that Parallels is going to fix the issue, but its still there. Not a happy customer. :-(
     
  11. indabox

    indabox

    Messages:
    13
    Looks like the same issue I am having

    I tried to disable the screen saver in Windows, no change.
    What we can we do to help you reproduce the issue?
    Never happened to me in RC1 or at the beginning of RC2. I cannot figure out what I changed.
    The only thing I can think of if that I installed and removed Virtue at some point.
     
  12. h4xwh0r3

    h4xwh0r3

    Messages:
    2
    I don't have Virtue Desktops installed and still get the issue. I can also confirm that I have disabled the Windows screensaver but am still getting Windows freezing up after awaking the display.

    Perhaps it has something to do with having the display go to sleep too frequently, or at all? I have my display going to sleep after 1 minute of inactivity. What do others have for this setting? In MacOS X it is under System Preferences -> Energy Saver. Note that I am talking about the display going to sleep, not the computer sleep setting.
     
  13. indabox

    indabox

    Messages:
    13
    I had it on 15 minutes. Changed it to 3 hours to avoid the issue...
     
  14. adiemask

    adiemask

    Messages:
    19
    I am also experiencing this problem with a 20" Imac
     
  15. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    We have successfully reproduced and already fixed this issue. Thank you for your reports!
     

Share This Page