Macbook / Parallels 3188 / RHEL WS-4

Discussion in 'Parallels Desktop for Mac' started by jimmyh, May 9, 2007.

  1. jimmyh

    jimmyh

    Messages:
    5
    Hi guys,

    I've been trying to install Red Hat Enterprise Linux WS-4 Update 4 (86) on my Macbook running Parallels Build 3188 for the last week and can't get it to work. The whole install seems to go well, but then when it reboots, it just hangs after uncompressing the kernel. The last line I get says "Uncompressing Linux... Ok, booting the kernel. "

    Has anyone had any luck with RHEL and Parallels WS-4?

    Cheers
    Jim
     
  2. darkone

    darkone

    Messages:
    804
    how are you partitioning the drive ?

    Ive got RHEL working fine numerous times.. Even RHEL5 worked seamlessly for me.
     
  3. jcarter

    jcarter

    Messages:
    5
    My guess is that you've hit the Parallels/Linux memory problem. Try reducing the memory for the VM to 512M and boot again. There are several posts that discuss and explain the problem.
     
  4. darkone

    darkone

    Messages:
    804
    err yes .. i dont run linus in more that 512mb ram..
     
  5. jimmyh

    jimmyh

    Messages:
    5
    Hi guys,

    Thanks for all your responses. First, I must mention that this is the first Linux installment that I have ever tried. Maybe it was a bit adventurous, I'm not sure.

    I tried reducing the memory to 512MB but that didn't seem to help unfortunately. With the RAM back at 768MB, what I did is go into the menu on startup where I was presented with two boot options. I chose the second and this seemed to boot up fine. I have attached the menu. I know in the pic that it says 512MB of RAM was used, but it also works fine for 768MB.

    When partitioning the drive, it just kinda went with all the default options and 7000MB of HDD space.

    Cheers
    Jim
     

    Attached Files:

  6. slangley42

    slangley42

    Messages:
    1
    RHEL/Centos Not Booting.

    I ran into a similar problem with Centos 4.4 (which IIRC is the same as RHEL). The problem was that RHEL/Centos by default is set up to boot the smp kernel. Parallels isn't set up to support the smp kernel yet, even on dual core processors.

    I had to edit the grub configuration file and replace my smb kernel with the non-smb kernel.
     
  7. jimmyh

    jimmyh

    Messages:
    5
    Excellent, thanks for that. I finally managed to edit my grub file. Seems like we need to login as admin to do this. Found the commands on the web that did it for me.

    su -
    [root password]
    vim /boot/grub/grub.conf
     

Share This Page