MacMini not going to sleep

Discussion in 'Parallels Desktop for Mac' started by pwith, May 23, 2006.

  1. pwith

    pwith

    Messages:
    52
    After installing RC1 my MacMini refuses to go to sleep according to the settings in System Preferences / Energy Saver.

    Not sure if this is related to the VT-x issue and the MacMini.

    Things seem to work just fine on my MacBook Pro although it runs hot when Parallels Desktop is active.

    Any suggestions appreciated.

    Thx

    Peter
     
  2. RandyS

    RandyS

    Messages:
    21
    I have the same symptom on my MacBook Pro. I can put the machine to sleep, but it will not go to sleep based on idle time.

    In fact, this is true even when Parallels is not running. I happens even if I reboot and never launch the Parallels application, so apparently something it installs or one or more of its background tasks are producing the appearance of system activity that prevents sleep.


    Randall Schulz
     
  3. tc60045

    tc60045

    Messages:
    19
    Happens irrespective of Parallels on my intel-based mini, and my intel-based imac. I keep OSXvnc running on both, so I assumed network traffic was responsible.

    Bug with 10.4.6?
     
  4. arfung

    arfung

    Messages:
    15
    Same problem with macbook pro

    I have exactly the same issue with my MacBook Pro. Even without launching the app or any VMs, the book won't sleep with idle time before sleep set to 15 mins in energy saver. I run the uninstall script, reboot, and the automatic sleep works without problems. This occured with both RC1 and RC2.
     
  5. ethar

    ethar

    Messages:
    1
    I have the same problem with iMac.
    When Paralells is not running, it affects OS X.

    Forcing sleep, scheduled sleep worked but iMac won't sleep past configure idle time.
    PRAM reset didn't help, then I uninstalled RC1 and the machine sleeps again.

    Now that I installed RC2, it won't sleep again. Even though Parallels is not running.

    Has any one figured it out?
     
  6. egilDOTnet

    egilDOTnet

    Messages:
    4
    I have the same problem here. It looks to me, from the system.log and snooping on disk activity with fs_usage, like if the /Library/Parallels/.dhcp.en2 program is causing this to happen, since it stats the filesystem all the time. This is started with the /Library/StartupItems/Parallels/prl_dhcpd program. I guess killing it will terminate normal networking though I have not tried.

    -e
     
  7. joem

    joem

    Messages:
    1,247
    If you are not using host only networking, you can safely kill prl_dhcpd, and your bridged networking will work fine (or at least mine does). It will restart if you reboot your Mac.
     
  8. arfung

    arfung

    Messages:
    15
    Did killing this process allow your machine to sleep automatically? I killed the process, and my MBP still won't auto-sleep if parallels VM is installed (but not running). I ran the uninstaller, rebooted, and the auto-sleep was restored.
     
  9. pwith

    pwith

    Messages:
    52
    This 'not going to sleep' issue was resolved in the released version - at least for me.

    Peter
     
  10. joem

    joem

    Messages:
    1,247
    Mine isn't set to sleep automatically. It sleeps just fine when I close the cover whether set to sleep mode 1(deep sleep) or 3 (save in case power fails).
     
  11. arfung

    arfung

    Messages:
    15
    pwith,

    I am running the final version, 1848, and my macbook pro definitely fails to automatically sleep. I cranked down the auto sleep time to 5 minutes. Installed parallels (app not running), and the 'book doesn't sleep. Run the uninstaller, reboot, and the autosleep works as expected.

    I realize that this is a small issue, but I am bothered by kernel extensions that take up system resources when they aren't needed - when the app isn't even running!
     
  12. joem

    joem

    Messages:
    1,247
    OK, you stimulated my curiosity. I tried it and my MBP goes to sleep just fine with the DHCP demon disabled. Normally, I don't set the MBP to sleep automatically at all. I close the cover when I want it to sleep, or use the deep sleep widget.

    I don't want it to sleep unless I tell it to. I have processes that run once in a while that I want to run.
     
  13. halfapie

    halfapie

    Messages:
    3
    I had the same issue, except my macbook would not completely go to sleep (with the blinking white LED) even when I manually entered sleep via closing the lid or the menu.

    For me, the problem was the Palm desktop software. After quitting the "transport monitor" and "palm desktop background" applications, my sleep functions are working properly. My guess is that the most current versions of the palm sync software are not universal binaries and that rosetta + palm was somehow avoiding sleep.

    Not sure if that's the problem in your case, but I thought I'd chime in. hope it helps?
     
  14. arfung

    arfung

    Messages:
    15
    I think that this was a problem with my system configuration. I deleted my system caches (in /Libary/caches and /System/Library/caches) and re-booted, and now the machine does sleep by itself according to energy saver settings with parallels installed. Thanks!
     
  15. rjtroester

    rjtroester

    Messages:
    1
    I too am experiencing the same problem with a white MacBook, 2.0GHz and I have the final release of Parallels installed. Like one of the other people here, i also have Palm Desktop installed. I have tried killing all of the processes to no avail. I also tried deleting all of the caches as someone else recommended and that also did not work. The only thing I have not yet tried is uninstalling Parallels. Does anyone know of any settings that can be changed w/in Parallels that might fix this?
     
  16. joem

    joem

    Messages:
    1,247
    Will it sleep if you explicitly tell it to?
    Have you disabled the Parallels DHCP demon (assuming you aren't using host only networking)? Note that if you kill it, it will restart when you reboot, so you will have to kill it again.
     

Share This Page