macOS Big Sur and Parallels Desktop

Discussion in 'General Questions' started by IvanD@Parallels, Jun 22, 2020.

  1. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, please add the following boot flag
    devices.smbios.board_id="default"

    and check the issue.
    Looking forward to your reply.
     
  2. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello,
    please collect the tech report once the issue reproduced and post the report's ID here.
    We will check it and investigate the issue.
    Thanks in advance.
     
  3. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Please check the issue with holding "fn" button and let us know the result.
     
  4. SureshP1

    SureshP1 Bit Poster

    Messages:
    3
    Does the Parallels team have any solution on the issue where the user enters the password in Big Sur but it returns to the login screen again? This is an issue that I am facing now and I also realize that others have the same issue.
     
    Wynter and eliotw like this.
  5. MichaelE20

    MichaelE20 Bit Poster

    Messages:
    1
    my paralells says it is nt installed when it is ran and reinstalling it makes not difference on big sur
     
  6. Brockpinder

    Brockpinder Bit Poster

    Messages:
    8
    I have the exact same issue, with the exact same keys. Lower t and y, and 1 and 2. Shift T and Y work, and my number Keypad works.
     
    BobF2 and darren3 like this.
  7. brainopera

    brainopera Bit Poster

    Messages:
    2
    FYI all, the Parallels tech support was awesome. Reviewing the missing keyboard presses for T, Y, 1, 2, they found a way to workaround neatly.

    Simply to go into Parallels app > Preferences > under your "Virtual Machine" (ie Windows 10), > Shortcuts > Add new shortcuts where you map "1" to "1", and so on. It's made life back to normal!
    Screenshot 2020-06-25 at 9.39.18 PM.png Screenshot 2020-06-25 at 9.41.05 PM.png
     
  8. MichaelM84

    MichaelM84 Bit Poster

    Messages:
    2
    Hi Maria,

    Just saw this and applied and it got me past the BIErrorDomain error 3.

    Thanks,
    Michael.
     
    Maria@Parallels likes this.
  9. JuanV4

    JuanV4 Bit Poster

    Messages:
    4
    • Big Sur login displays a black screen after login and then returns to login screen. Report ID: 343362081
    • Big Sur hangs after installing Parallels Tools. Report ID: 343360898
     
  10. AllanS1

    AllanS1 Bit Poster

    Messages:
    11
    Same problem for me. Any resolution yet?
     
  11. Roland07

    Roland07 Bit Poster

    Messages:
    18
    Does anyone know when Parallels will start selling their next version? Historically speaking Parallels usually launches the new version before the new Mac OS version and bugs that occurred with the old Parallels on the new OS version are mitigated in the new version. This way they keep the one-year subscription going.
     
  12. Tathagatac

    Tathagatac Bit Poster

    Messages:
    4
    Hi, Did anybody face this, after installing Mac OS Big Sur on a parallels VM (upgrade from 10.15.6), I am stuck at the log-in screen, it accepts the password cursor keeps circling and then screen goes dark and comes back to the log-in screen again.
     
    RobertC22 and MichaelM92 like this.
  13. Tathagatac

    Tathagatac Bit Poster

    Messages:
    4
    I have generated a Parallels report and report ID is 343370092
     
  14. RichyC

    RichyC Bit Poster

    Messages:
    3
    Pressing function works for me. What is causing this random bug?! Anything we can do to get round it? Different keyboard layout or something?
     
  15. RichyC

    RichyC Bit Poster

    Messages:
    3
    Perfect, works a treat bud. Thank you
     
  16. hyph

    hyph Bit Poster

    Messages:
    4
    1. Create a new Parallels VM by installing a fresh copy of macOS Catalina from Recovery Partition (or use existing VM) and Resize disk drive to be at least 90 GB if you have to copy the Big Sure image to the applications folder to proceed with the installation
    2. DO NOT INSTALL Parallels Tools or uninstall it if it's already installed (tools are needed to drag and drop the Big Sure image from real mac to the CatalinaVM Application folder, then uninstall them
    3. Login to Apple Developer Program with safari, always in CatalinaVM, to recognize and authorize the virtual macOS
    4. remove the user login password, which you have set in CatalinaVM, so that at the end of the installation of Big Sure it is not asked to avoid problems
    5. install Big Sure.... .after the necessary time, about 1 hour, the procedure will be completed and there will be automatic login in Big Sure ... the system seems a little bit unstable and it can happen suddenly that the login mask for entering the password is displayed (bug ...) insert it and you return to the desktop ... some icons are missing in the upper right bar (bug ...)
     

    Attached Files:

    • aaa.png
      aaa.png
      File size:
      743.8 KB
      Views:
      19
    BenJ1 likes this.
  17. MichaelM92

    MichaelM92 Bit Poster

    Messages:
    25
    I think this is where everyone is, right now..I have not seen a solution/workaround posted yet...
     
    Peter Witham and eliotw like this.
  18. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Thanks for sharing the results.
     
  19. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, could you please share a bit more details about the issue with us?
    Also could you provide us with the screenshots of the issue?
     
  20. YouongsooLim

    YouongsooLim Bit Poster

    Messages:
    4
    I have too same problem when input key 't', 'y','1','2'. I can't input 4 letters. But do work when with shift key like T, Y, !, @.
    I am looking forward to wait this solution, at least temporal method. Thanks
     

Share This Page