Make num lock "clear" sticky across launches of Windows virtual machines

Discussion in 'Windows Guest OS Discussion' started by Paul Derby, Dec 14, 2017.

Tags:
  1. Paul Derby

    Paul Derby Bit Poster

    Messages:
    19
    For those wishing to enter PINs or passwords containing numbers using the keypad, we now have to push the "clear" key to put Apple keyboards with number pads into numeric mode. Please consider making the "numlock" setting sticky across virtual machine sessions.
     
    RichardH14 likes this.
  2. alexg

    alexg Parallels Developers

    Messages:
    536
    That is strange. I just tested you scenario and Num Lock is ON on login screen with PIN. Could you login to Windows open Notepad, ensure the num keys are working then restart Windows and try to use numerical keyboard once again? By the way this setting is managed by Windows.
     
  3. Paul Derby

    Paul Derby Bit Poster

    Messages:
    19
    I use a password that starts with a long string of numbers, not a PIN. If this setting is managed by windows, can anyone share the way they have configured windows to default to numlock on? A GOOGLE search finds a number of posts to edit the registry to accomplish this simple setting. I'm running Windows 10 with the latest updates from Microsoft and state is definitely NOT saved on my machine.

    For the last 10 or so years I've had to use the "clear" key to enter my password. Would be so nice to eliminate this nuisance. Parallels allows me to avoid owning a PC just to run Quicken, the ONE and only application that I run on Windows.
     
  4. alexg

    alexg Parallels Developers

    Messages:
    536
    What version of Windows do you use? I have tested on Windows 10 and it is works as you expected. State is saved.
     
  5. alexg

    alexg Parallels Developers

    Messages:
    536
  6. Paul Derby

    Paul Derby Bit Poster

    Messages:
    19
    A BING search brings up notes from Microsoft to edit the registry to enable NUM LOCK on Windows 10. In addition to the many other postings on this nuisance default setting of NUM LOCK OFF. Alexg, is that what you did on your machine to make Windows 10 NUM LOCK default to ON? I'll go do the regedit drill, first hack I've done on my virtual image.
     
  7. Paul Derby

    Paul Derby Bit Poster

    Messages:
    19
    Here's a good writeup on enabling NumLock with a registry tweak: http://windowsreport.com/numlockstartup-windows-10/

    Seems this nuisance default setting,
    HKEY_USERS\.DEFAULT\Control Panel\Keyboard
    has been the same for many versions of Windows. On my Windows 10 install the default value for this field was 2147483648 which I changed to 80000002 and seems to work. 2147483648 decimal equals 0x8000 0000 HEX. For the first time in many years I just signed on to Windows without having to remember to push the "clear" key on my Mac keyboard with keypad.

    Here is Microsoft's technet info on "InitialKeyboardIndicators". https://technet.microsoft.com/en-us/library/cc978657.aspx
     
    Last edited: Dec 14, 2017
    alexg likes this.
  8. Paul Derby

    Paul Derby Bit Poster

    Messages:
    19
    In the test I made in the previous post I did a restart and the numlock setting held. Unfortunately when I powered down the virtual machine and quit parallels. I started up Windows 10 and the numlock didn't work even though the intialkeyboardindicators was set correctly. Searched through Microsoft's technet and found a post made earlier this year noting that if "Fast Startup" is enabled the settings are not held . The kludge that preserves NumLock on across the virtual PowerOn and PowerOff is described here:
    https://social.technet.microsoft.co...estart-will-not-reset?forum=win10itprogeneral
    Here is the NumLock ON kludge procedure copied from the posting:
    Once you achieved registry settings, shutdown computer, Boot the computer back up again. When you reach the login screen, press the Num Lock key once to enable it. Don't log into the computer. From the login screen, click the power button and select "Shut down" to shut down the computer again.
    Boot the computer back up and Num Lock will be enabled on the login screen. It seems that this puts Fast Startup into a state where it will automatically enable Num Lock at every boot.
     

Share This Page