missing hard drive space WinXP

Discussion in 'Parallels Desktop for Mac' started by koolaidman, Aug 28, 2006.

  1. koolaidman


    I'm running parallels on a 17" MBP with 2GB RAM, running beta build 1862.2.

    I seem to be missing quite a bit of hard drive space in windows. My expanding disk image is set to 7GB, and windows is reporting that I am using up 5.61GB of that, with 1.35GB remaining. Diskeeper (my defragmenting tool) also reports a similar number.

    However, when I add up the total file size of all the files in the system, it only totals 3.52GB, leaving me with just over 2GB missing. I realize that there are differences in the way different programs and tthe OS calculate disk space, but not to the tune of 2GB, that's ridiculous.

    I used a tool called iFindSpace to do the calculation of the file size of each folder & file, and it came up with the 3.52GB number. It details the size of every file on the system, and I can't see anything that looks out of place. The system is simply miscalculating.

    Let me also mention that I have expanded the disk image from its original 6GB size, because the system kept telling me I was running out of space, and resized the disk using GPartEd so that windows would see the new space. However, I was getting this missing space issue before I resized the partition; that is in fact the very reason I made it larger, so that I could actually use it.

    I don't think my problem is the *.dat files from a ImageTool resize that everyone seems to find, because I have 'show hidden items' turned on, and I or the disk space calculator would have found them.

    Does anyone have any suggestions beyond what I've already tried? This one's got me stumped.

    I've attached a snapshot of the 3 programs' output so you can see what I mean.

    Attached Files:

  2. unused_user_name


    Do you have a 2gb swap file in windows?

    Some file-finding applications get an access denied error when they stat the swap file, so they can't figure out how big it is directly from the filesystem.
  3. joem


    Have you tried checkdisk?

    Note that if you for small files, the actual file size will be less than the space used on the disk, so if you have lots of small files they may eat up more disk space that shows if you add up the sizes. You lose an average of half an allocation unit per file, and the standard NTFS allocation unit is four K (unless you changed it). So a one byte file uses 4K of disk space. (Actually, a zero byte file uses 4K because it uses a master directory entry.)
  4. koolaidman


    actually I tried a program called SpaceMonger - the greatest file utility I have ever seen. It maps out the space by file and folder on your drive dynamically; it's quite amazing.


    {note: advanced windows gibberish to follow}
    it showed me that there was 1.1GB space being taken up by the c:\system volume information\ folder. which is very odd, since system restore is supposedly off, as I set it to off in my domain's group policy. It only showed it as an unscannable folder, but told me what it was - this folder wasn't even showing up in c:\.

    I solved it by logging in as administrator, and changing permissions on all files under C:\. This way, even though still couldn't actually SEE c:\system volume information\, I was able to type in the address, and delete its contents.

    Now I have 2.4 GB free on my system instead of 1.2. It's not as much space as I was expecting to restore, but with the different calculations and accounting for the space taken by all those small files, it seems to be about right.

    This was more of an advanced windows issue than a parallels issue, hope I'm not clogging up the board too much. :)

Share This Page