Modifier keys not working in P9, KB article doesn't help

Discussion in 'Windows Guest OS Discussion' started by mculver, Oct 18, 2013.

  1. mculver

    mculver Bit Poster

    Messages:
    29
    Configuration: latest Parallels 9 build from 10/16/13, Mountain Lion 10.8.5.

    Modifier keys CTRL and SHIFT don't consistently work when the modifier key is kept pressed for more than one combination, as outlined in this thread. For example, CTRL+SHIFT+RIGHT-ARROW to highlight a word, then leaving shift pressed and pressing down arrow to highlight an entire line it is as if shift were no longer pressed and the cursor just goes down a line.

    I followed all suggestions in KB article 113932, removing any such shortcuts from Mission Control and I have Parallels system shortcuts preferences set to Always (which should mean always sent to the VM guest, never to the Mac OS host). Still doesn't work. I have tried all of the possible settings, none of them work.

    Please, this combination of P9 and Mountain Lion is ridiculous. I want Windows to work like it has worked for 20 years.

    Between this issue and the sound popping issue I have already posted about, I see these issues as problems for people going back months and I see no effort on Parallel's part to fix them. Not in the latest build, not in KB articles. Please.
     
  2. see3d

    see3d

    Messages:
    14
    I updated to the latest version 9. I had previously selected the games setting for the modifier keys. However, the shift key was not recognized unless in combination with another key or a mouse click. After a lot of fiddling around, I found that I had to deselect this games setting, restart parallels, then select it again for it to start to behave properly. This bug was also there a year ago with v8. I have tried to report it, but can not seem to find a way to do that.
     
  3. TristaJ

    TristaJ Bit Poster

    Messages:
    21
    I am having same issue with "ctrl" key. I have to press ctrl and option to get what ctrl used to do on its own. Any answers yet from anyone?
     
  4. see3d

    see3d

    Messages:
    14
    Simpler Workaround found

    I found that while the VM is running, I can:
    open VM configure... --> Hardware --> Mouse & Keyboard --> Keyboard: "Don't optimize for games" --> close configure window.
    open VM configure... --> Hardware --> Mouse & Keyboard --> Keyboard: "Optimize for games" --> close configure window.

    I have to do this every time I start up the VM. Parallels understands when it changes from Don't optimize to Optimize, and remembers the last setting, but does not start up the VM with that setting active each time.

    To be clear, you have to do the sequence to select "Don't optimize for games first", then after done, you go back and select "Optimize for games" -- every single time you start up the VM.

    I wish I knew how to formally report the bug without paying for the privilege with a support call, but don't know how. If someone else does know, then please report it or tell me how.
     
    Last edited: Dec 21, 2013
  5. TristaJ

    TristaJ Bit Poster

    Messages:
    21
    I have done that. It is optimized for games. I've done the change and still no go.
     
    Last edited: Dec 21, 2013
  6. see3d

    see3d

    Messages:
    14
    To be clear, you have to do the sequence to select "Don't optimize for games first", then after done, you go back and select "Optimize for games" -- every single time you start up the VM.
     
  7. TristaJ

    TristaJ Bit Poster

    Messages:
    21
    Well that just seems like a bunch of BS. GRRRRRR…...
     
  8. see3d

    see3d

    Messages:
    14
    It is called a BUG!!!!!!!!
    Not a feature.
     
  9. TristaJ

    TristaJ Bit Poster

    Messages:
    21
    LOL. You have a point.
     

Share This Page