Mouse and Keyboard issue with BootCamp version of XP in Parallels.

Discussion in 'Installation and Configuration' started by HakTor, Jun 18, 2007.

  1. HakTor

    HakTor

    Messages:
    3
    I have just finished installing and updating and installing everything as per the instructions. All is working perfectly fine (atleast for the past hour or so).

    I have one NAGGING issue that I need to pick everyones brains on. In a Virtual Harddisk version of XP and Parallels, the mouse and keyboard inputs would seemlesly transit from OSX to XP and vice a versa. But with BootCamp, XP and parallels solution I have to press Ctrl+Alt to release the mouse each time I want to transit from one XP to OSX.

    I know that this is a very trivial issue as compared to the other doosies on this list, but nevertheless its very inconvinient.

    Besides I want to make this BootCamp XP Parallels thingy Wife proof!

    Is that a hard ask for the solution? ;)

    TIA
     
  2. Rachel Faith

    Rachel Faith

    Messages:
    234
    This is a mouse / cursor / video bug that is well documented. Some have had success with various degrees of reinstalling tools or parallels itself... others have had no such luck. They said last week they were trying to duplicate and or solve the problem. They have not said anything so far since. You are the first to post of this conflict using bootcamp, the rest of us are using direct VMs. So it is clearly without question a driver parallels issue. Try to do through as many installs / re-installs of the whole tools, the entire program or drivers as you have time to fool with, you may get lucky. Barring that, yer stuck waiting with the rest of us.
     
  3. dkp

    dkp

    Messages:
    1,367
    In Windows, open the control panel -> Add/Remove Software tool and use it to find the version of Parallels Tools that is installed. It should be the same version as Parallels, so if you are running 3.0 build 3188 then that should the version for Parallels Tools.
     
  4. Arnd Gehrmann

    Arnd Gehrmann

    Messages:
    6
    Greetings for the first time here!

    At me, the same problem appears with Paralleles 3.0 build 4128!

    This is not a full solution but it works at me for the actual session.

    1) Open in XP the "Parrallels Tool Center"
    2) disable the "mouse synchronisation" and click "Apply"
    3) enable the "mouse synchronisation" and again, click "Apply"

    and ... :) At me, all went well like in the former version but after shut down the VM, this functionality disappears and the trick must be done again after the next start.

    Arnd

    p.s. sorry, i just read, this was told before here, too:
    http://forum.parallels.com/archive/index.php/t-13484.html
    a.
     
    Last edited: Jul 4, 2007
  5. HakTor

    HakTor

    Messages:
    3
    This is a BUG

    Thanks to Rachel, I have a solution, somewhat!!!

    But this is happening on 3 different installs now, 2 XP's and 1 Vista.

    has anyone else seen this or figured how to fix this issue?

    I have tried to re-install the Parallels tools but its a no go. Has anyone had luck in attaining a solution for this problem.
     
  6. Rachel Faith

    Rachel Faith

    Messages:
    234
    There is no solution from Parallels yet. In fact I haven't heard peep from them in weeks. I've about given up and have been too busy with real life to post here and be a pest about it.
     
  7. menace3054

    menace3054

    Messages:
    4
    i figured out a fix, thank god. i installed parallels 3.0 on my wife's macbook. i was going to surprise her, and show her how she didnt have to reboot to use windows anymore (she needs it to run her CPA review software) anyway, it broke the keyboard and mouse on bootcamp, i was ready to be killed. emailed paralles, no response. Then use Vista System Restore, restored it to 2 days ago, PRESTO its fixed! yay
     
  8. HakTor

    HakTor

    Messages:
    3
    My Biggest problem is that I cant do System Restore. I have been using Vista now for over 2 weeks... to many things get un done...

    I hope there is another cure... Parallels Support team if you are reading this, we need a fix. Please help us from our wives.... My wife is complaining that this procedure is too complicated....!
     
  9. menace3054

    menace3054

    Messages:
    4

    parallels finally emailed me back, said to use the vista dvd to do a repair install, however, thats not possible because the mouse/keyboard doesn't work to press "any key" to start from the disc. the way i got around the problem to log in was to use the ease of access control "bubble in bottom left of screen" and asked for the keyboard on screen, my BT mouse worked fine so i was able to use the virtual keyboard to click the keys i needed to log in. good luck, i guess you might just need to erase the partition and start anew. By the way, i think the cause of this problem occurs when selecting the boot camp drive to use as the virtual drive. by default, it thinks its windows XP< and so it installs the tools for that drive. if you change it to vista, it works flawlessly. Good Luck!
     
  10. menace3054

    menace3054

    Messages:
    4

    dont quote me on this, but im fairly sure that the system restore only restores system files, leaving documents/programs, etc. unaffected.
     
  11. masonjames

    masonjames

    Messages:
    19
    I have a slightly different problem in that I have installed bootcamp and parallels with windows xp and have been running xp via parallels for months with no problems or hiccups. Recently, I wanted to use an xp program and use the dual monitor feature (which is as of yet, unsupported via parallels) so I needed to use bootcamp. Upon booting up into bootcamp, I was surprised by two things: 1. I need to re-activate my install (which has already been done via parallels) before I can do anything and 2. My keyboard doesn't work! So, I call microsoft and get the phone activation code, but I can't type it in to do anything. I'm feeling pretty stuck. I've been looking all over the house for a spair USB keyboard that I wanna try, but I can't find one. Anybody have any other ideas or solutions?
     
  12. b747pete

    b747pete

    Messages:
    7
    It worked for me too, thanks.
     

Share This Page