Mouse clicks stop working in guest OS

Discussion in 'Windows Guest OS Discussion' started by billpatt, Apr 13, 2018.

  1. Carlos16

    Carlos16 Bit Poster

    Messages:
    5
    I'm having the same issue with Ubuntu 18.04. I'm not sure what's causing it, but it's very very annoying.
    Is this something that is still under investigation? At times it makes my VM unusable :/
     
    CarlosR13 likes this.
  2. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    There was a remote session on 11/16/19 for the support ticket. The issue was not resolved.
    Per support ticket request on 11/17/19, I removed the device.usb.mouse=0 boot flag. I removed all mouse device drivers from the guest device manager. I reinstalled Parallels Tools. Then I restarted the guest and observed device manager mice drivers are HID-compliant mouse and Parallels Mouse Synchronization Device. Issue still occurred.
    Per support ticket request on 11/27/19, I uninstalled Parallels Tools, reinstalled manually by loading the iso file and launching the setup file, performed a clean boot in Windows. I went additional step to use Sysinternals Autoruns to disable many not addressed in https://helpdeskgeek.com/how-to/perform-a-clean-boot-in-windows-7-8-10/. Still same issue after about an hour.
     
  3. Carlos16

    Carlos16 Bit Poster

    Messages:
    5
    Thanks Randy. I also didn't find a solution.

    There is a strange phenomenon: once the bug starts happening, even restarting the VM doesn't help.
    To fix it I need to quit Parallels and start it again- then we're back to normal (for a while only).

    This issue is very annoying- I just bought Parallels 3 days ago and I'm thinking that I may have made a mistake.
    I hope it's solved soon, or I'll have to switch completely to Linux on my side.
     
  4. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    Support ticket has been updated to Engineering, escalated to the Development team. They don't have a solution at this time. The most significant factors to me are these:
    1. Both touchpad and USB mouse exhibit same behavior at same time - all work in host, mouse left/right clicks stop working in guest but other mouse events like scroll wheel / touchpad gestures continue to work in guest.
    2. Microsoft RDP to guest mouse/touchpad clicks work in guest.
    That should give the dev team some clues.
     
  5. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    Per support ticket request, put the following flags in Hardware > Boot Order > Advanced Settings before starting the guest, then sent another technical report when the left/right click issue occurred again.
    devices.hid.log.pen=1
    devices.hid.log.mouse=1
    devices.hid.log.keyboard=0
    devices.hid.log.depth=20000
     
  6. Carlos16

    Carlos16 Bit Poster

    Messages:
    5
    I have it set up, I'll try to catch it next time it happens and send the tech report.
     
  7. Carlos16

    Carlos16 Bit Poster

    Messages:
    5
    I submitted a tech report with ID 328273474 (I'm not sure where to post this)
     
  8. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    I'm not sure what they do with unsolicited tech reports. Mine were specifically requested by them and wanted the report Id sent back to them after.
     
  9. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    I am generally impressed with the quality of Apple hardware and I like having OS X as the host but this issue has wasted much time over the past 1.5+ years and has no real promise of being resolved. I need to move forward. I am going to get a new PC-based machine and work directly on it.
     
  10. Carlos16

    Carlos16 Bit Poster

    Messages:
    5
    I am with you on that. It's a bit sad, but I may have to go the same direction.
    I'm surprised that this issue hasn't gotten much attention. Maybe we're the only ones experiencing it?
     
  11. TatianaM

    TatianaM Bit Poster

    Messages:
    1
    No, you are not the only one. I am experiencing the exact same issue starting today. In my case the guest OS (Windows 10) will only respond to one or two mouse clicks before it stops, making it completely unusable. What happened for me that started the issue was that I was working in the guest os with my macbook pro hooked up to an external HDMI monitor (a large screen TV, actually). The screen of the macbook was closed, but since the power cord was attached, it was still displaying on the HDMI monitor. But then my son walked by and tripped over the mag cord, which pulled it loose and immediately sent the computer--or at least the display--into sleep (because it will not project to HDMI when the power cord is not connected). I replugged the cord and macOS was just as I had left it, but the virtual machine had stopped running.

    I restated Windows, and from that point onward it has not worked. It was fine literally moments before and then after the power interruption it totally became non-functional. I don't know what the heck happened but I hope the team looks into this issue.
     
  12. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    Per support ticket request, I replicated the issue again yesterday, uploaded a technical report and gave them the Id. I also collected a memory dump from the virtual machine and uploaded that to the personal upload link they gave me. I would like to note the instructions they gave me at https://kb.parallels.com/9101 for files over 2GB did not work. I following them explicitly and tried multiple times. Each time I received a long error about "WARNING: POSSIBLE DNS SPOOFING DETECTED!" and "Offending ECDSA key in /Users/Randy/.ssh/known_hosts:1 ECDSA host key for http has changed and you have requested strict checking. Host key verification failed."
    I ended up using their instructions for files under 2GB and that worked although it took my DSL 13 hours to upload it and I was fortunate the connection was dropped during the process.
    I believe this is the end of my attempts to resolve this problem. I have my new PC-based machine now and will abandon working on a MacBook with Parallels. Good luck to the rest of you!
     
  13. EnricoA

    EnricoA Bit Poster

    Messages:
    8
    Same issue here more or less everyday. Any news? I have to force shut down and re-start up the VM.
     
  14. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hi, did perform the steps above:
    1. turn off/on game mode at VM configuration
    2. reinstall Parallels Tools
    3. Install Windows updates?
     
  15. samv2

    samv2 Bit Poster

    Messages:
    2
    Having problem with my ubuntu .
    Updated to its lattest version still same problem and because of that i can't use my vm ware properly .
    Do suggest something .
    sorry if any answer given before i didnt read all the comments so .
    Thank you
    sam v
     
  16. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Did you lose mouse at your Ubuntu VM?
     
  17. samv2

    samv2 Bit Poster

    Messages:
    2
    Ya but sorry bro its working properly now i just uninstall and reinstall it .

    Thanks sir.:)
     
    Maria@Parallels likes this.
  18. EnricoA

    EnricoA Bit Poster

    Messages:
    8
    Yes,
    tried everything. My mouse click is stop also right now. I can move the cursor but no click.
     
  19. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    How did you connect your mouse to VM? via Bluetooth or USB?
     
  20. EnricoA

    EnricoA Bit Poster

    Messages:
    8
    I use the Magic Mouse 2 but it is not the problem. I have a MPB 16" 2020 and the problem occurs also with the trackpad and also on my previous MBP 15 2017 that I sold one month ago.
     

Share This Page