Mouse Cursor Drag & Drop Systemic Tools Problem

Discussion in 'Parallels Desktop for Mac' started by Derekasaurus Rex, Jun 8, 2007.

  1. Derekasaurus Rex

    Derekasaurus Rex

    Messages:
    3
    Can't drag files from XP to Mac in 3.0

    I upgraded from Parallels 2.5 to 3.0 and opened an XP SP2 machine. It updated the disk format and Parallels Tools and everything seems to be working, except that I can't drag files from the XP desktop to the Mac desktop. What's odd is that it works the other way; I can drag files from my Mac to the XP desktop, just not vice versa. When I try dragging from XP to Mac I simply can't move the cursor out of the XP window until I release the file I'm trying to drag. Any idea what's going on? Needless to say this worked seamlessly in both directions in 2.5.
     
    Last edited: Jun 8, 2007
  2. Ankou

    Ankou Guest

    Hello, Derekasaurus Rex
    Thank you for response. We investigate this problem, but we need more information about your system.
     
  3. Derekasaurus Rex

    Derekasaurus Rex

    Messages:
    3
    I'm running on a 2.33GHz 15" Core 2 Duo MacBook Pro with 3GB of RAM. In Parallels I'm running Windows XP Pro with SP2 and all of the latest patches from Microsoft's Windows Update. This is one of my clean "base" virtual machines, so it has precious little installed other than Firefox and Webroot Spy Sweeper (it's Windows, after all). Let me know if there is any additional information I can provide.
     
  4. Jack Dumphy

    Jack Dumphy

    Messages:
    21
    Hi,
    I tried to drag & drop a file from XP to OSX (desktops)
    3 times without a problem in both directions.
    Then one more d&d from OSX (folder) to XP desktop and Parallels crashed/vanished. Just the report appeared. If you Parallel-Guys are interested, tell me a (the) mail address.
     
  5. Derekasaurus Rex

    Derekasaurus Rex

    Messages:
    3
    Another piece of information: if I select two items, I can drag them from the PC to the Mac side. But if I select any one item, I'm stopped at the edge of the XP Window.
     
  6. The Merovingian

    The Merovingian

    Messages:
    4
    Inability to Drag and Drop

    I'm sure i'm not alone here from looking through these forums but there were no solutions to these issues.

    I'm having failure of Dragging and Dropping files to and from the VM to OS X. I have several model renders i would wish to send to people but i can't since they're stuck in the VM.

    Also, cohearence doesn't work.

    Latest version of Parallels (4124 7th June 07)
    MacBook Pro 2.16Ghz Intel Core 2 Duo || 1Gb RAM || 15" Display || 120Gb HDD

    Is the development team working on a fix for this? If so, when is the update?

    On the plus side, 3DS Max works which is great, and i will buy this once it is fully operational.
     
  7. bgose

    bgose

    Messages:
    55
    I am unable to drag & drop as well.

    My Mac Pro has 3.0 and my Wife's MacBook has 3.0, neither one is a boot camp VM and still no drag and drop from the desktop.

    However, my coherence is working fine on both.
     
  8. iQQ

    iQQ

    Messages:
    7
    I have exactly the same problem with yours. I have upgraded to 4128.

    Actually, I have reinstalled Parallels Tools many times, no way to get out.
     
  9. Another problem installation Build 4124 on a Mac Pro 2.66 4GB RAM. OS 10.4.9. I can drag files to the Windows XP desktop but not from Windows to Mac. I hadn't discovered Derekasaurus Rex's two file drag which works! I've just assigned my desktop as a shared folder but it is less elegant than drag and drop. I'm just downloading 4128 now.
     
  10. iQQ

    iQQ

    Messages:
    7
    Upgrade to 4128 wouldn't solve the problem. I was suffering it and shift to VMware.
     
  11. Rachel Faith

    Rachel Faith

    Messages:
    234
    I seem to have this SAME problem. Neve happened on ANY of the previous versions. Now it behaves like LINUX or one of the other OS's for which they HAVE NO TOOLS.

    3.0 is buggier than a NYC public housing project.
     
  12. Rachel Faith

    Rachel Faith

    Messages:
    234
    Cursor STUCK in VM - No Drag and Drop

    The search engine on this forum sucks, so I am listing my complaint various ways such that IF a solution is revealed, it can be posted under a few different subjects and perhaps help a few other sorry suckers who upgraded too.

    The mouse or cursor will not release from the VM.

    This behavior is explained in LINUX OS VMs because there are NO TOOLS for them.

    But I am having this problem with a FORMERLY PERFECT 2.5 XP Pro SP2 OS.

    I never had a complaint until I made this HORRID ERROR in upgrading.

    Now MUCH does not work, this being just the MOST OBVIOUS BUG !
     
  13. Ankou

    Ankou Guest

    It seems, what you didn't install Parallels tools...
     
  14. AlanH

    AlanH Kilo Poster

    Messages:
    316
    ... also, there ARE now Linux tools in 3.0. And they make the Linux cursor work like the Windows cursor. No Linux<->OS X drag and drop yet, but hey, it's progress.
     
  15. Rachel Faith

    Rachel Faith

    Messages:
    234
    modified
    It "seems" you are dumber than mouse turds.... but I doubt that it's true.

    :mad:
    :mad:
    :mad:

    Not only have I installed the tools.

    I have Installed, Uninstalled, Manually reset and installed in Safe Mode at least half a dozen different ways.

    ALWAYS the same effect.

    When I first LOG IN to windows.... the blue screen with my Icon, Name and Password... the Mouse works.

    It changes color from black to white and I can go IN and OUT of the VM without issue.

    As soon as the "start up" is finished however... it reverts BACK to the LOCKED OUT click to capture and Control Alt to escape.

    WHY ???
     
    Last edited: Jun 14, 2007
  16. idanmashaal

    idanmashaal

    Messages:
    95
    Anyone has Drag and Drop issues with XP VM ?

    I can drag from my Mac to the VM but not from the VM to the Mac.

    Parallels 3.0 4128 - iMac Core Duo, 2GB, VM is 768/16MB

    Thanks,

    Idan
     
  17. idanmashaal

    idanmashaal

    Messages:
    95
    I'm a Beta Tester of parallels and tested 3.0 from the start.

    I told them about this bug since build 4072.
    I even told them how to reproduce it and how to workaround it - Simply change OS type to 2000.

    I even installed a fresh Copy of XP and then tools (only that) and it doesn't work....

    I really hope they STOP developing Parallels Server (alpha) and finish the job with 3.0

    Idan.
     
  18. idanmashaal

    idanmashaal

    Messages:
    95
    I don't have to quit parallels but the file "disappears".

    To be exact - It's really on your indows desktop - but coherence hides it.

    If you can access the Beta board - read here:
    http://forums.parallels.com/thread12182.html

    Idan.
     
  19. idanmashaal

    idanmashaal

    Messages:
    95
  20. Rachel Faith

    Rachel Faith

    Messages:
    234
    I have several VMs. Three of which are windows XP. I have reported problems with the ONE VM I upgraded on this iMac multiple times.

    I decided to take the test and downloaded a new copy of Parallels latest build to my other Mac, a MacBook Pro 17. I then attempted to upgrade it and the VM to see if this mouse cursor drag and drop lock up problem was somehow related to my VM configuration on my iMac.

    This is the case.

    The upgrade on my MBP 17 worked... but not without a VERY unusual side effect.

    During the install of Tools, it crashed and said it could NOT continue and gave me the usual choice to submit to Microsoft. I declined.

    Tools continued to install anyway... but it did NOT ask me for any of the usual "confirm this software is not tested by microsoft" CONTINUE ANYWAY boxes.

    It just suddenly finished.

    The ABOUT TOOLS shows it is the newer build and the drag and drop works fine and I seem to have no issues with it.

    The ONLY difference between the VMs is that THIS VM was created from scratch and has very little if any applications on it.

    It is my TEST and Destroy if something goes wrong. I rarely use it.

    The VM with the huge problems is a TRANSPORTED COPY of my BEST system which has all the windows apps I cannot live without.

    Perhaps the coding problem is with TRANSPORTED VMs?

    Some thoughtful and sincere replies from Parallels would be nice.
     

Share This Page