Mouse cursor is off by a couple millimeters

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by imsammyd, Feb 19, 2024.

  1. imsammyd

    imsammyd Bit poster

    Messages:
    4
    My VM recently updated to Windows 11 Insider Preview 10.0.26058.1100 (ge_release) and now my mouse is inaccurate. The pointer location, when clicked, actually clicks about half character high and to the left. I have to position my mouse below the text and to the right in order to get the text selection/click to be in the right spot. My Mac doesn't have this issue, only inside the VM. I've reinstalled parallels tools. Not sure what else to try. I'm running parallels desktop for Mac Pro Version 19.2.1 (54832)
     
  2. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    502
    Best Answer
    Hi all,
    We've just received an update from Microsoft. The issue is supposed to be fixed in the Insider Preview build 26063. If you're continuing to have issues with this after that build (or higher), please let Microsoft know by filing a new piece of feedback on Feedback Hub.
     
    Durgarnkuld. likes this.
  3. Durgarnkuld.

    Durgarnkuld. Bit poster

    Messages:
    5
    Same for me. Also my mouse courser disappears playing my usual games.
    Still works, but is invisible. I fiddled around with game mouse settings and all, to no avail.
     
    KiddieL and MarioC10 like this.
  4. Brian...

    Brian... Bit poster

    Messages:
    1
    Same issue. The caret is too big for the line and I need to use just the top of it when selecting text.

    Tried changing the resolution, "Best for retina", "Scaled", "Best for external displays" all the same issue. I can't make the cursor any smaller in windows either its on the lowest setting

    If I zoom the text in to match the cursor size then it's a bit better but now I have to deal with massive text
     
  5. Dwynfal

    Dwynfal Bit poster

    Messages:
    3
    Same problem after upgrading to Windows Feature Experience Pack 1000.26058.1100.0 earlier this week. Insertion point is offset two characters left and one line up from the I-beam. Configure > Hardware > Graphics is set to 'Best for external displays' in my case. I'm running Parallels Pro 19.2.1 (54832).
     
  6. binm

    binm Bit poster

    Messages:
    5
    same issue.
    I found a temp solution,you can set mouse cursor to a large size, must big than 4 size, you will find that it's pointing accurately, though it may be ugly.
     
    MichaelB126, TiagoC4 and Brian... like this.
  7. AndreF12

    AndreF12 Bit poster

    Messages:
    2
    Same issue!
     
  8. Brockpinder

    Brockpinder Bit poster

    Messages:
    9
    Turning on the Optimized for Games setting for both the Mouse and Keyboard is the work around I've used and seems to be solid. The only drawback is that locks the mouse in the VM and you need to use the shortcut keys to release it. I work in Excel in Windows 11 VM and was going crazy with the mouse pointer being off.
     
  9. imsammyd

    imsammyd Bit poster

    Messages:
    4
    Yup, I have the same thing. Turned on Optimized for Games and the mouse is accurate, but I can't get the mouse out of the window without manually releasing it. Major PITA.
     
  10. TiagoC4

    TiagoC4 Bit poster

    Messages:
    1
    Same issue here, after updating to the latest Windows 11 Insider Preview 26052.1000 (ge_release) yesterday.
    I work mainly with Visual Studio and I am going nuts trying to work with it :mad:

    I will try @Brockpinder 's solution for now.
     
  11. Durgarnkuld.

    Durgarnkuld. Bit poster

    Messages:
    5
    This seems to work at least for accuracy from my first tests, but my cursor is still missing in games. :/
     
  12. Nischay Gaya

    Nischay Gaya Staff Member

    Messages:
    42
    Hello,
    Thank you for reaching out to us and providing your valuable feedback.
    Once you have activated the feature "Optimize for games", you have the option to disable the cursor being locked within the virtual machine space by following the below steps:
    1. Start your Virtual Machine.
    2. Click on Actions from the top menu bar > Select Configure.
    3. Go to Hardware > Mouse and Keyboard
    4. Under the Mouse Section > Click on Advanced.. > Untick "Mouse pointer sticks at windows edges".
    This should help to rectify the situation.
    Thank you.
     

    Attached Files:

  13. imsammyd

    imsammyd Bit poster

    Messages:
    4
    This is incorrect. When you select Mouse: Optimize for games, it disables the checkbox and forces the cursor to stick to edges. There is also a note below the mouse setting "When the mouse is optimized for games, press Ctrl+Alt to release the mouse cursor". Your screen shot has "auto detect for games" which does not fix the mouse issue. Please correct your reply.
     
  14. MichaelB126

    MichaelB126 Bit poster

    Messages:
    2
    The solutions provided by @Brockpinder and @binm each work for me. The one proposed by @Nischay Gaya didn't work. I'm using the "Optimize for games" option (found via the Parallels menu: Actions | Configure | Hardware | Mouse & Keyboard, then in the dropdowns for Mouse and Keyboard), because I prefer the inconvenience of having the cursor locked in the vm to the very large cursor.
     
  15. MarioC10

    MarioC10 Bit poster

    Messages:
    5
    Same for me
     
  16. FranciscoT4

    FranciscoT4 Bit poster

    Messages:
    2
    I have the same issue and unfortunately the workarounds don't work for me, is there anything else I can try?
     
  17. MikeC39

    MikeC39 Bit poster

    Messages:
    2
    I have the same problem. Turning on "optimized for games". Thanks!
    This needs to be fixed by Microsoft, or Parallels?
     
  18. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    81
    Hello Everyone.

    We appreciate reporting of the issue, we can reproduce the behaviour and our Developers are currently investigating the possible cause for pointer position being off in current Windows Insider builds.
    Note: In stable builds, however, this issue is not present (Control Center > + > Get Windows 11 from Microsoft) so it stands to reason to recommend reporting it to Microsoft as well in the Feedback Hub: https://support.microsoft.com/en-us...-hub-app-f59187f8-8739-22d6-ba93-f66612949332
    For now, please keep using the "optimize for games" workaround.

    On a sidenote, we'd also appreciate letting us know the benefits of running Windows Insider builds, as opposed to stable channel.
     
  19. Dwynfal

    Dwynfal Bit poster

    Messages:
    3
    This is how I initially set up my VM a couple of years ago (through Control Center). If I recall, there was no stable release of Windows 11 for ARM back then, so I suppose the Parallels setup wizard used the then current preview release, which (I suppose again) automatically enrolled the machine in the Insider Preview program for updates. If we set up new VMs today through Control Center, will the wizard default to installing Windows 11 23H2 (latest stable release from Oct. 31, 2023) and not enroll the machine in Insider Preview?
     
  20. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    502
    Hello! Yes, if you install Windows from Parallels Desktop Installation wizard by clicking the 'Get Windows from Microsoft' button, you'll get the latest stable build of Windows.
     
  21. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    502
    Best Answer
    Hi all,
    We've just received an update from Microsoft. The issue is supposed to be fixed in the Insider Preview build 26063. If you're continuing to have issues with this after that build (or higher), please let Microsoft know by filing a new piece of feedback on Feedback Hub.
     
    Durgarnkuld. likes this.

Share This Page