Mouse doesn't work in Windows bootcamp VM after upgrade from v9 to v10

Discussion in 'Parallels Access and Parallels Desktop for Mac' started by NeilD2, Jun 16, 2015.

  1. NeilD2

    NeilD2 Bit Poster

    Messages:
    1
    Just upgraded from Parallels 9 to v10 as part of the 20% off offer and because I'm on Yosemite, so I thought I'd take advantage of the new features and performance upgrades.

    I have a bootcamp partition, which I use for gaming and Visual Studio, which I have setup to run as a VM in parallels too- this has always worked great for me historically.

    Upon installing Parallels 10 the parallel tools were upgraded and the vm rebooted and since then - no mouse - no pointer, no control. I tried changing the settings as per http://kb.parallels.com/en/115306, to no effect. Uninstalling parallels tools fixes the issue, but then leaves me with fewer features than I had on v9! No great for an upgrade!

    Removed Bootcamp VM and re-added to no avail.

    I'm on a 2012 MBPr with 16GB RAM and Parallels v10.2.1. Bootcamp VM is set to 4 cores and using 8GB RAM running Win 8.1 with all updates.

    Any thoughts?
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi NeilD2,

    If you want to automatically capture and release the keyboard and mouse input when working with your Mac OS X and Virtual Machine applications at the same time, you should install Parallels Tools in your Virtual Machine.
    The Parallels Tools installation enables the SmartMouse feature.
    You can configure or disable this feature in the Virtual Machine Configuration -> Hardware -> Mouse & Keyboard.

    If you select Optimize for games (Off in previous versions), you will need to click inside the virtual machine window to capture the mouse input, and press Ctrl+Alt to release it back to your Mac. It may be convenient if you want the mouse pointer to always stay inside the virtual machine window in the Window and Modality view modes (ex.: when playing some games).
     

Share This Page