Mouse movement crazy slow in games (Retina MBP, Win7)

Discussion in 'Windows Guest OS Discussion' started by redski, May 4, 2013.

  1. redski

    redski Bit Poster

    Messages:
    8
    My mouse moves very slowly in games. I tried Mirror's Edge and Portal, both had the same problem. For example, turning my character around once takes three full drags of the mouse. It's hard to dodge bullets and stuff at that speed :)

    The setup:

    • Windows 7
    • Parallels 8.0.18483
    • Retina MBP running OS X 10.8 Mountain Lion
    • Smart Mouse off
    • Windows mouse speed set to max
    • Game mouse speed set to max
    • Games installed via Steam
    This happens both when my VM is set to "Scaled" and "Best for Retina" resolution, probably because I'm running the games in full screen anyway. It happens both on my rMBP built-in display and my external monitor (1600x1200), where I'm trying to run the games. It happens both with my external mouse and trackpad. It also happened on a WinXP VM I tried briefly. I'm trying to run Mirror's Edge at 1280x1024. I do not have Pointer Shadow on.

    Note the mouse is also very slow in the general Windows interface when the VM is set to "Scaled" resolution.

    Problem report #24688020.
     
  2. mmm201

    mmm201 Bit Poster

    Messages:
    23
    Happens for me when I turn Smart Mouse off.
    When I assign my USB mouse to the guest (raw USB bypassing Parallels's mouse subsystem), my mouse's speed suddenly doubles and behaves as it does when I boot to Windows.
    This is most surely a bug in Parallels's mouse handling. It's applying some downscaling to mouse speed or mixing cocoa with device pixels.

    @Parallels staff: When Smart Mouse is off, you should send NATIVE MOUSE COORDINATES to the guest rather than doing any kind of processing. This is essential for games.
     
  3. redski

    redski Bit Poster

    Messages:
    8
    Assigning the mouse directly to Windows worked for me too. To clarify the steps:

    • In Parallels, choose Virtual Machine > Configure > Options > Advanced > SmartMouse > Off
    • Also in Advanced, turn on "Optimize modifier keys for games"
    • Get the Windows VM up with the desktop showing, ready to install new hardware
    • In Parallels, choose Devices menu > USB > Your external mouse
    This will connect your mouse directly to Windows, and your Mac will no longer be able to see it. (Note if the mouse pointer gets trapped in the VM, you can use Ctrl+Alt to release it.) Windows will install the necessary drivers to talk directly with your mouse.

    At certain points in this process you will not be able to see your pointer, so it's definitely a good idea to do this with two pointing devices (mouse/trackpad). That way you can use one to interact with your Mac while the other is dedicated solely to Windows.

    Also, pro tip: Most gamers recommend turning off Windows' mouse acceleration math, as it makes learning precise mouse control more complex for your brain. In Windows 7, this is Control Panel > Hardware & Sound > Devices & Printers > Mouse > Pointer Options tab, turn off "Enhance pointer precision."
     

Share This Page