Mouse pointer jumps to right side of screen after any keystroke when using multiple displays

Discussion in 'Linux Guest OS Discussion' started by Peter25, Feb 1, 2018.

  1. Peter25

    Peter25 Bit Poster

    Messages:
    2
    I am on a Mac running Ubuntu 14.04 through parallels, with 2 monitors.

    When I enter "Use all Displays in Full Screen" mode, so that Ubuntu takes up both screens, I get a bug with the mouse:

    After any keystroke (in Ubuntu), the mouse curser jumps to the right side of the screen. This always happens and makes the "Use all displays" mode unusable. It does not happen when I uncheck "Use all Displays in Full Screen".
     
  2. James Minnihan

    James Minnihan Bit Poster

    Messages:
    24
    Happens in Windows 10 guests too. Multiple monitor support in Parallels is awful!
     
  3. Elizabeth Anderson

    Elizabeth Anderson Bit Poster

    Messages:
    33
    Please update your Parallels Desktop to the latest build and if still the issue persists follow the below steps -
    1. Shut Down virtual machine.
    2. Open Virtual Machine configuration
    3. Go to Hardware > Boot Order > and paste in Boot Flags box:
    video.hw_pointer=0
     
  4. Peter25

    Peter25 Bit Poster

    Messages:
    2
    Tried that. It causes the pointer to be invisible in the VM. Though you can infer its position by trying to drag things around. Hard to tell if it fixed the "pointer jumping" problem, because the pointer is invisible. Also, when in single-monitor mode, you cannot just move the pointer back to the host-machine, you need to command-tab to focus on a host-machine window first.

    Also just trying that uncovered another bug: When I try to shut down the VM with sudo shutdown now, it just hangs on the shutdown screen - I'm forced to "STOP" it.
     
  5. James Minnihan

    James Minnihan Bit Poster

    Messages:
    24
    I tried that too. It just made the jumpiness a little less. Still have a jittery mouse. Started happening around 13.1.2, I believe...
     
  6. JoshS5

    JoshS5 Bit Poster

    Messages:
    1
    Just started experiencing this problem on my Windows 10 VM... is there honestly no solution for this by now? It's been 8 months...

    As a side note, I'm also having problems with coherence not working properly all of a sudden -- exiting and re-entering coherence causes any open applications to become invisible. When coherence does work, new application windows for applications that are already running open up behind the windows that are already open, instead of coming to the front.
     
    Last edited: Oct 8, 2018

Share This Page