Mouse pointer jumpy using 3rd party mouse

Discussion in 'Linux Guest OS Discussion' started by parallels_user_guy, Jan 11, 2022.

  1. parallels_user_guy

    parallels_user_guy Bit Poster

    Messages:
    4
    I'm experiencing a jumpy mouse cursor when using my Corsair Harpoon RGB Wireless Gaming Mouse with and without guest OS tools installed on Linux and macOS guest OS. The problem appears on both M1 and Intel Mac hardware. I suspect it has something to do with high DPI/external 3rd party mouse devices and the way Parallels handles mouse events from macOS.

    How to replicate issue:
    - Plug in USB high-DPI mouse, works fine with macOS desktop (in my case it is a Corsair Harpoon RGB Wireless Gaming Mouse)
    - Install guest OS: Ubuntu, macOS (strangely the issue does not appear in Windows guest OS)
    - When the mouse accelerates too quickly, it returns back to its starting point
    - If the mouse is moved slowly with minimal acceleration, the pointer behaves as expected
    - Try the same thing with Apple Magic Trackpad, it is not an issue
    - See video for an example of the behavior on Ubuntu guest vm
    https://drive.google.com/file/d/1Z16boh3KTUoP62eB7msZ1ybN99YjFkO8/view?usp=sharing

    This has been a problem since Parallels Desktop 16, and shows up regardless of whether Guest OS Tools are installed, and affects both macOS and Linux VMs, but not Windows. Can I file a bug report somewhere? It seems like it should be a trivial fix, and it is easy to replicate.
     
  2. parallels_user_guy

    parallels_user_guy Bit Poster

    Messages:
    4
    oh, i realized the problem is exhibited differently in macOS guests. but it seems to be related to fast accelerations of the mouse. in macOS guest, instead of returning to initial position, as it does in linux, it seems like the mouse events are being queued up, but the queue does not flush until the next mouse motion. so, basically, mouse events will stop when the mouse stops, but when you start the mouse movement again, it replays historical data and feels very laggy.
     
  3. SherifE

    SherifE Bit Poster

    Messages:
    1
    I'm having exactly the same problem with a wired mouse, I have parallels 17 and running mac os monterey 12.1, this is a very annoying issue
     
  4. Foosec

    Foosec Bit Poster

    Messages:
    1
    Exactly the same problem with linux guests, monterey 12.2, no problem with trackpad, no problem if in coherence mode in windows.
     
  5. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    443
    I have latent acceleration issues using the built-in trackpad on an early 2013 MBP, but only in Android and Windows VMs.

    In Fedora 35 under Gnome 4 in full screen mode I have something completely different, and a lot more erratic. If you click inside a terminal window, then move the mouse outside the terminal window, the mouse pointer disappears completely. The only way to get it back is to do a three-finger gesture to get to another desktop window, then re-enter the Linux VM.

    Sometimes other weird things happen in Linux: The left-click function suddenly disappears for no reason and switches to the right-click... by itself and without warning.

    I'm convinced that Parallels is completely broken when it comes to HID. Very frustrating. Since the trackpad (and external mice) are hooked using internal USB mechanisms, it wouldn't surprise me if the flaky USB bug is still there and just manifesting itself in different ways.
     
  6. ParallelsU886

    ParallelsU886 Bit Poster

    Messages:
    2
    Same here, contacted the support several times with several tickets about it. Response was always asking me to provide logs, which - by company rule - is not permitted. So they closed the tickets; although I provided a detailed description of the matter at hand. I will contact them again and link this discussion... maybe you can do the same.
     
  7. ParallelsU886

    ParallelsU886 Bit Poster

    Messages:
    2
    try this as a fix:
    go into config of your VM, select menu "hardware", scroll down to "boot order", on the left select "advanced", then boot flag, paste the following "devices.usb.speed.mouse=high" without quotation marks. start the VM.
    worked for me.
     
    parallels_user_guy likes this.
  8. parallels_user_guy

    parallels_user_guy Bit Poster

    Messages:
    4
    wow! that worked for me on linux! it went from totally unusable experience with my mouse, to perfect mouse tracking. how did you discover this boot flag?
     
  9. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    443
    Bumping this because I think I've found out what's going on. In the Hardware settings:
    , if the mouse is set for Optimize for Gaming, it will jump around like crazy.
    2.
     
  10. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    443
    Disregard that, was editing and hit Post in error...

    Bumping this because I think I've stumbled upon what's going on.

    In the Hardware settings:
    1. if the mouse is set for Optimize for games, it will accelerate across the screen without warning, however...
    2. If the mouse is set for Don't optimize for games, it may disappear on you without warning. The only way to get it back is to allow the VM screen to refresh. I usually can do this using a three-finger gesture to either switch desktops (sweep up) or minimize the desktop (sweep left or right), then come back into that VM.

    This was 100% reproducible on both Windows 11 and Linux VMs. Adding any boot flag such as "devices.usb.speed.mouse=high" had absolutely no effect on either of these conditions, leading me to believe that the issue is somewhere in Parallels' optimization code.

    This has been a long-standing issue and really needs looking onto by the devs.
     
  11. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    443
    Just want to reiterate my earlier post, that this issue is not just with external mice... it's with the internal trackpad as well. All of these utilize USB in the Macbook architecture. The trackpad uses an internal connection on the USB bus. Make of that what you will.
     
  12. HenrikH5

    HenrikH5 Bit Poster

    Messages:
    7
    I have the exactly same problem using a Logitech mouse since I got a problem with parallel tools earlier this year. None of the solutions I have seen har worked. The weird this is that using fast single mouse sweeps works.
    All I got from my own thread was to reinstall the Logitech software, which I don't even use..
     
  13. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    140
    Hello, Please refer to the below KB articles to fix it.
    1. Problem with Logitech keyboard and mouse.
     
  14. HenrikH5

    HenrikH5 Bit Poster

    Messages:
    7
    Please note the last line in my message. You linked me the same "solution" as in I mentioned. I do not have Logitech Control Center installed, so there is nothing to reinstall....
     
  15. HenrikH5

    HenrikH5 Bit Poster

    Messages:
    7
    I finally found the problem!
    I installed Logitech G HUB and set the "report rate" to 500 times per second, instead of 1000, and now the mouse pointer doesn't jump around anymore. So I guess Parallels can't handle the highest (default) report rate.
     
  16. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    140
    Hello Guys, We have released the Parallels Desktop's latest build 17.1.4 so we would suggest you upgrade it to the latest build and check.
     
  17. HenrikH5

    HenrikH5 Bit Poster

    Messages:
    7
    It says my 17.1.2 is the latest version.
     
  18. parallels_user_guy

    parallels_user_guy Bit Poster

    Messages:
    4
    FYI to everyone, i discovered that this is related to my using SteelSeries ExactMouse tool, which I use to turn off the acceleration to the mouse cursor which is applied by macOS. For some reason, the only place where I see issues is Parallels Desktop. When the mouse acceleration is off, I can use my mouse freely in the OS everywhere, but parallels macOS and Linux guest VMs exhibit this behavior. The workaround is to use this boot arg:
    Code:
    devices.usb.speed.mouse=high
    I hope if someone from QA at Parallels can see this, the problem can be replicated by installing the SteelSeries ExactMouse tool and turning "ExactMouse: On", which removes the macOS acceleration curve on the pointer. I think the right thing to do is for Parallels to use the mouse cursor input correctly so this is not an issue for people, especially since one of the use cases of Parallels is people who want to play PC games with a non-Apple gaming mouse.
     
  19. borari

    borari Bit Poster

    Messages:
    1
    I was having the same issue with the jumping mouse pointer in a Kali/Debian guest VM, using a Logitech G502 wired mouse. I have no Logitech software on my MacOS host, however I have loaded high-DPI settings onto the mouse directly through the Logitech software when connected to a Windows machine. Using the boot arg mentioned above completely resolved the issue for me as well.
     
  20. k__14

    k__14

    Messages:
    1
    I just installed Parallels to try it out. Fresh Windows 11 installation, installed only Windows updates - and mouse jumps all over the place.
    I tried all suggested, but what finally worked for me was to turn off the "Mouse: Optimize for games" (set it to "Mouse: Don't optimize for games").
    This seems to work (and my game works better too, ironically).
     

Share This Page