Mouse pointer offset vertically with Parallels 19.2.1 (54832)

Discussion in 'Windows Virtual Machine' started by marcantoniom, Mar 1, 2024.

  1. marcantoniom

    marcantoniom Bit poster

    Messages:
    4
    In a Windows Virtual Machine on Parallels 19.2.1 (54832), using applications (not games) the mouse pointer is offset vertically, which is maddening - by approximately one line.
    When clicking on a line, the previous line is selected.

    Switching to the "gaming" mouse mode fixes the offset, but results in laggy, non-smooth mouse pointer movements.
    Is there a way to fix the offset?
     
    AndreasL27 likes this.
  2. KasperL

    KasperL Bit poster

    Messages:
    9
    Same here for Windows Arm on M1 Max
    Some apps are ok. With other mouse is offset. Grabbing the "right" side of a windows to resize is offset by ? 10-20 pixels.
    Using Visio Pro 2021 mouse is offset both to the right and down
     
    AndreasL27 and marcantoniom like this.
  3. AndreasL27

    AndreasL27

    Messages:
    1
    Same here for Windows Arm on Apple M1! Very Annoying. Hope on a quick fix...
     
    marcantoniom likes this.
  4. Nischay Gaya

    Nischay Gaya Staff Member

    Messages:
    42
    Hello,

    Thank you for reaching out.

    Please note that this is a known issue and our team are actively working to address in the subsequent update of Parallels Desktop.

    To be informed of the new version release, we recommend subscribing to the following article(Click "Get Updates" -> "Subscribe"): https://kb.parallels.com/en/129860 to track update and release changes in Parallels Desktop 19.

    As a temporarily workout, we will advise to activate the feature to "Optimize for games":
    1. Start your Windows Virtual machine.
    2. Click on Actions from the top menu bar > click on Configure.
    3. Go to Hardware > Mouse and Keyboard, and set the Mouse option to "Optimize for games".
    Note: This setting restricts the mouse pointer within the Windows virtual machine space by default. To disable that:
    1. On the Virtual machine settings > Go to Hardware > Mouse and Keyboard.
    2. Under Mouse section> Click on Advanced and Untick the option "Mouse pointer sticks at the Windows edge".
    You may follow below KB article for more information: https://kb.parallels.com/116990

    We appreciate your understanding.
     
  5. AliP3

    AliP3 Bit poster

    Messages:
    3
    Do we have any estimation when this issue gets fixed? I don't see this fixed on 19.3.0
     
  6. KasperL

    KasperL Bit poster

    Messages:
    9
    Hi,
    I tried the "Optimize for Games" setting - and it does NOT work. Mouse pointer is still offset 45 deg down and right. (coherence mode)

    The setting disable "Mouse pointer sticks at the windows edge" does not work either - I can't click it on/off (with V machine turned on or off) - it is just gray'ed out in "unselected / not ticked " state - but still blocks mouse exit from Window. :(

    (see attached images - VM_on / VM_off)
    VM_on.png

    VM_off.png
     
  7. CortoM

    CortoM Bit poster

    Messages:
    1
    Hello, seems th bug is corrected with my Windows 11 : Pro Insider Préview Build 26085.ge_release.24035-1352. I put the settings of the mouse and the keyboard at 'Auto-Detect' and un-tick the 'Mouse pointer sticks at Window edges.
     

Share This Page