Mouse Release from Windows to Mac

Discussion in 'Installation and Configuration' started by drjamesh, Jan 21, 2008.

  1. drjamesh

    drjamesh

    Messages:
    17
    Sir or Madam:

    Currently I am running parallels 3.x build 5584. When running parallels 2.x I was able to use the mouse fluidly while moving from Windows to the Mac with the original install. I do not remember which update it was, but after that particular update I was not able to move my mouse from within the Windows screen to the Mac desk top without doing an Alt + shift. I'm using a Logitech traveler optical mouse that is recognized within the system as an USB/PS2 optical mouse. My mouse is plugged in to my Apple keyboard. Any thoughts or suggestions would be helpful.



    Model Name: Mac Pro
    Model Identifier: MacPro1,1
    Processor Name: Dual-Core Intel Xeon
    Processor Speed: 2.66 GHz
    Number Of Processors: 2
    Total Number Of Cores: 4
    L2 Cache (per processor): 4 MB
    Memory: 2 GB
    Bus Speed: 1.33 GHz
     
  2. ddeatoniv

    ddeatoniv Bit Poster

    Messages:
    5
    I have the same problem since upgrading to build 5584 and something even worse. When in Coherence mode, once the pointer goes beyond the edge of the PC app window, it snaps back to the center of the display. If what is at the center is a PC app, it stays in PC mode. If it's a Mac app or the desktop, it switched to Mac mode. In Mocha TN5250 for example, the following occurs: When I click on a menu and then try to select an item in the menu, the pointer jumps to the center of the page. Similar problem when trying to resize the window. Please help. Coherence mode is unusable now. Thanks...

    System Version: Mac OS X 10.5.1 (9B18)
    Model Name: Mac Pro
    Model Identifier: MacPro1,1
    Processor Name: Dual-Core Intel Xeon
    Processor Speed: 2.66 GHz
    Number Of Processors: 2
    Total Number Of Cores: 4
    L2 Cache (per processor): 4 MB
    Memory: 6 GB
    Bus Speed: 1.33 GHz
     
    Last edited: Jan 22, 2008
  3. drjamesh

    drjamesh

    Messages:
    17
    Interesting...the same thing happens to me in Coherence mode... the movement of the mouse to the edge of the window snaps the pointer to multiple locations, near the center of the display.
     
  4. ddeatoniv

    ddeatoniv Bit Poster

    Messages:
    5
    Interestingly enough, I restarted my computer and when I opened Parallels again, it opened in Coherence mode (even though I last had it in Single Window Mode) and it worked the way it was supposed to. Have you tried rebooting your Mac? Maybe that will fix the problem for you too...
     
  5. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Hello,

    did you try to reinstall Parallels Tools?

    Best regards,
    Stacey
     
  6. drjamesh

    drjamesh

    Messages:
    17
    Thank you for your reply,

    Yes I did reinstall Tools after every 2.x to the present 5584. The selection box to enable the mouse syncronization is greyed out. For quite some updates back. Using logitech Traveler optical usb mouse.

    Sincerely,

    Dr. H
     
  7. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Please try to uninstall Parallels Desktop then use this link to download the latest build and install it. Will the problem persists?

    Best regards,
    Stacey
     
  8. drjamesh

    drjamesh

    Messages:
    17
    Sir or Madam:

    Thank you. I did uninstall and then installed from the link that you gave (build 5584). The problem persists, only alt-shift will release the mouse. Any other suggestions?

    Sincerely,

    Dr. H
     
  9. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Hello,

    please uninstall Parallels Tools via "Start" -> "Control Panel" -> "Add or Remove Programs".
    Then please do the following:
    1. Boot Windows in Safe Mode by hitting F8 (Fn+F8) during its boot screen. Go to "My Computer" -> "C" Drive -> "Program Files" -> "Parallels" folder and delete the "Parallels Tools" folder.
    2. Click the Windows "Start" menu -> "Run" and type "regedit". Hit OK.
    3. In Registry Editor, go to "My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Parallels" and delete the "Parallels Tools" entry.
    4. Reboot Windows
    5. Install Parallels Tools from the "Actions" menu on the Parallels Desktop menubar when Windows is running .

    Best regards,
    Stacey
     
  10. drjamesh

    drjamesh

    Messages:
    17
    Thank you Stacey,

    I did the uninstall and install as you instructed in the #9 message. The enable box for mouse synchronization is still greyed out and cannot be enabled.

    Sincerely,

    Dr. H
     
  11. Stacey M

    Stacey M Parallels Team

    Messages:
    908
    Hello,

    please uninstall Parallels Tools. Then click 'Actions' -> 'Install Parallels Tools'. Choose 'Custom' installation. Then you will see 'Select Features' window with a list of tools. Please provide me with a screenshot of this window.

    Best regards,
    Stacey
     
  12. dgotchac

    dgotchac

    Messages:
    1
    Help ... Exactly the same pb for me. Any solutions ?

    I've done the complete procédure described and the result is the same.
    I'm on a MacBookAir with the last version of Parallels ..
     
  13. Steffen Dyhr

    Steffen Dyhr

    Messages:
    3
    I tried the suggestion in post 9 - and it worked for me. Thx! I were going crazy 'bout the "Ctrl+Alt to release mouse and keyboard" that suddenly appeared. Now it's like before - very nice!
     

Share This Page