Mouselook problems solved in PD7?

Discussion in 'Windows Guest OS Discussion' started by VikramP, Sep 2, 2011.

  1. OderWat

    OderWat Bit Poster

    Messages:
    8
    Dunno... my "normal" Mac USB mouse is listed at devices. I wonder that the mouse vanishes because in Sins of a Solar empire it vanishes when I switch off the Smart Mouse but not when I enable the USB Mouse in windows and leave Smart Mouse on. Actually it should not changed the mouse cursor at all IMHO... as the additional mouse is just an additional way to move the existing cursor.. :(

    Anyway... I believe that the Parallels guys should look into this problems again. Its a pitty to have everything right in the game but moving the mouse :/
     
  2. OderWat

    OderWat Bit Poster

    Messages:
    8
    I deinstalled SWTOR after playing some hours in beta.... I do not plan to buy that game :)

    But hope they find a solution for you!
     
  3. ilans333

    ilans333

    Messages:
    3
    Solution = Bootcamp

    I was able to "fix" the issue by setting up bootcamp and booting directly into Windows. Very disappointed with Parallels on this, as it seems to be a recurring issue with gaming.
     
  4. Vince C

    Vince C

    Messages:
    1
    Any updates on this issue? I had it working fine in Parallels 6, but decided to upgrade to 7 so I could bump the video memory to 1GB. That was a mistake, now I am back to the mouse problem.

    Is anyone looking in to this?
     
  5. Crimguy

    Crimguy

    Messages:
    2
    I hope so. Problem still persists in Sins of a Solar Empire.
     
  6. VikramP

    VikramP

    Messages:
    11
    Pd8?

    So, uh, any update on this for PD8? The problem still exists in the very latest version of PD7 with Guild Wars 2 (which is a shame, since other than that GW2 is quite playable).
     
  7. VikramP

    VikramP

    Messages:
    11
    I downloaded the PD8 trial, did a fresh Windows 7 installation, installed Guild Wars 2, and sadly the mouselook problem remains. Oh well.
     
  8. Pravda

    Pravda

    Messages:
    2
    I just loaded up GW2 in PD8 on my Retina MBP. At least for me, if I plug in an external mouse and turn Smart Mouse OFF, the cursor disappears and I can use the left and right mouse buttons to turn and look around, as you would expect. This is a major improvement! Performance is doable, it gets good frames, but it can kinda lagged if you're running around. Probably just some settings I need to mess with, but as far as I can see, with Smart Mouse off GW2 is playable on Parallels :)
     
  9. VikramP

    VikramP

    Messages:
    11
    Yeah, that's always been the case - for me, anyway. If you turn Smart Mouse off, then mouselook works perfectly, but you have no mouse cursor. I find it impossible to play games like these without a mouse cursor, since there's so much clicking on stuff (it's difficult to just find the button to log out!).

    If you figure out a way to make the mouse cursor appear with Smart Mouse off, please post.
     
  10. serv

    serv Parallels Developers

    Messages:
    810
    Mouse pointer with Smart Mouse Off is fixed in PD8.
     
  11. Pravda

    Pravda

    Messages:
    2
    I'm sorry, I made a typo. I meant to say that the mouse cursor does NOT DISAPPEAR. So yes, it has been fixed, as you can see from the Parallels team post above this one :)
     
  12. VikramP

    VikramP

    Messages:
    11
    Yes! I thought I had tested with Smart Mouse off in PD8, but obviously I didn't. It's working great now!

    Minor quibble - isn't setting Smart Mouse to Auto supposed to turn it off for games and on for everything else? I would have thought that I wouldn't need to manually turn it off. Not a big deal, in any event.
     
  13. Interplex

    Interplex

    Messages:
    1
    PD8 Does the Trick

    Heavenly Chorus! Angelic Trumpets!

    Guild Wars 2 WITH pointer and WITHOUT Death Spirals!

    Thank you, PD8 Team.
     
  14. Zoollander

    Zoollander

    Messages:
    2
    Working but laggy

    When I turn the auto mouse off the spiral issue is fixed but the mouse has a significant delay. Is there a way to fix this?

    I am using PD7
    Playing world of warcraft
     
    Last edited: Mar 13, 2013
  15. you can increase mouse sensitivity inside Windows guest
     
  16. Zoollander

    Zoollander

    Messages:
    2
    Thank you for the quick reply. It is not that the mouse icon does not move quickly but that it lags behind the movements of the mouse (I move right and there is a delay before the mouse icon moves right). Along with the delay it is jerky. If I set it to auto the mouse is not laggy or jerky at all but then there is the spin issue again.
     
  17. actually there is no difference in the mouse event delivery path in both modes.

    The only difference here is that the icon in smart mouse mode is drawn by guest and thus it takes some significant amount of time until the guest driver updates the position and draw the icon on the screen. In the smart mouse mode the icon is draw by MacOS itself and thus the position is updated _before_ any event delivery and only after that the mouse event is sent to guest. This difference is only increased with the increased load in the Windows.

    Most likely we can not do anything reasonable in the PD7 case.
     
  18. SteveyE

    SteveyE Bit Poster

    Messages:
    3
    I found a solution!!! After many hours, what worked for me for the Look around problem in 3D Games was:
    1. Shut Down virtual machine.

    2. Open Virtual Machine configuration.

    3. Go to Hardware > Boot Order > and paste in Boot Flags box:

      video.hw_pointer=0
    Note: The above solution will work fine when using a virtual machine for simple tasks such as document processing, but heavier usage (like games or 3D software) may work unreliably.

    This worked for me on the "Auto detect for games" setting in the configuration of parallels. The look-around left click would spin, with this code, it is normal.
    I hope this can help someone who has this issue.

    Enjoy!
     

Share This Page