Moving Files from OS X to XP Partition?

Discussion in 'Parallels Desktop for Mac' started by ScottK, Apr 6, 2006.

  1. ScottK

    ScottK Bit Poster

    Messages:
    10
    How is this done?
     
  2. anshar

    anshar

    Messages:
    81
    You can configure network inside guest XP and organize network share between host and guest.
     
  3. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    For the moment the best way to move files from your primary OS to the guest on OS X is to use network connection. Another way is to mount pre-created CD image to the guest and copy files to it. I'm sure that there will be some kind of shared folders support in future release of Parallels Workstation.
     
  4. schmidp

    schmidp

    Messages:
    49
    does this really work for you?

    i can't reach my host os from within the virtual machine and i can't reach my virtual machine from my host os.
    but both have reach the router and are in the same subnet.

    greets philipp
     
  5. badmofo

    badmofo

    Messages:
    5
    Yes, I was wondering if someone could explain in a little more detail how sharing files between OS's through networking is done. Would be much appreciated. Thank you,

    -- B --
     
  6. BillInSoBe

    BillInSoBe

    Messages:
    84
    Sharing...

    This would really depend on which Guest OS you're running.

    The easiest way to do this would be to enable sharing in Mac OSX.

    - Launch System Preferences
    - Select Sharing
    - Enable Personal File Sharing
    - Enable Windows Sharing (make note of the Windows users can access your computers at \\xxx.xxx.xxx.xxx\xxx...) REMEMBER THIS!!! **
    - From inside the Guest OS
    - Click START | RUN
    - type the \\xxx.xxx.xxx.xxx\xxx from above.

    Enter your Mac login credentials and you should have access to the drive.
    You can also MAP a drive from inside windows using the UNC path (\\xxx.xxx.xxx.xxx\xxx).
     
  7. farshad

    farshad

    Messages:
    5
    still unable to share between host Mac and guest XP

    Has someone actually gotten this going? Here's my setup.

    1) Host: MPB OS 10.4.6. I have turned on Windows Sharing for my account. It says "Windows users can connect at \\192.168.1.8\arshad"
    2) Virtual: WinXP Pro. I've even turned the firewall off. I've tried:
    -Mapping a network drive to \\192.168.1.8\arshad
    -Mapping a network drive and logging in as another user; username: 192.268.1.8\arshad
    -In a Windows Explorer window, just typing the path: \\192.168.1.8\arshad
    -In a Windows Explorer window, typing \\Mbprobotomy\arshad
    -from a cygwin window, pinging 192.168.1.8, no results
    - from cygwin, pinging the router (192.168.1.1) - DOES WORK
    - from cygwin, sshing to my host mac (does not work)
    - from cygwin, sshing to a different mac on my subnet (DOES WORK)
    None of the above connects to the host computer
    I've also tried Just browsing network places, and I do see my mac in the list (Mbprobotomy), but I get an error when I click on it (The Network Path Was Not Found).


    So, I can't ping the host, can't ssh, can't go to the webserver, can't connect via windows sharing. If I'm doing something wrong, what is it?

    Or is this just impossible with the beta.

    As soon as I can share files, this will be incredibly useful. Add me to the list of people who want to pay you money.
     
  8. badmofo

    badmofo

    Messages:
    5
    What beta version are you using?

    What beta version are you using?

    The first beta I used (Parallels-2.1.1658.24-Mac.dmg), this technique of mapping a network drive worked without a problem (except for a kernal panic if there was too much network activity it seems). I could also FTP to my Mac from within WinXP with FTP share access on in Mac OS X; and this technique seemed a lot more responsive and quick by the way.

    But when i upgraded to the beta 2 (Parallels-2.1.1658.30-Mac.dmg) it seems now I am unable to map my mac's network drive anymore. I get the same error as you, network path was not found. Kind of annoying. Hope someone will figure something out. And I'll keep fiddling around myself.

    I'm on a MacBook Pro 2.16GHz, running WinXP as the guest OS, and I'm also using a linksys router with ethernet wired internet connection.
     
  9. STim

    STim Super Moderator

    Messages:
    942
    Hi,

    Please check the VM's network configuration (Edit->Network Adapter).
    Since you're using wired connection, the wired adapter should be chosen and the "Wireless connection" checkbox should be unchecked. If not, please do. And post the results here please.
     
  10. badmofo

    badmofo

    Messages:
    5
    Same results :(

    Hi Tim,

    Thanks for the quick reply. I did as you suggested (actually I did see this selection dialogue before your post, but I went back and double checked) and I am sorry to report that I am still unable to connect either through FTP or Mapping a Network Drive.

    I'm able to connect to the internet and surf around, but for some reason I'm unable to see the Mac Host computer.

    With Beta 1 I at first was unable to connect as well, but the problem there was because the ports on my router were not being forwarded properly. So I basically just forwarded all ports to the Host system's IP address, the one I'm trying to connect to. Then it worked. However, it's still not working with Beta 2.

    I'm stumped for now. Maybe I'll try a clean restart of both Host and Guest systems and see what happens.

    Thanks for your help,
    -- B --
     
  11. phil

    phil

    Messages:
    3
    @farshad:

    Sorry if this seems a little basic, but I sometimes forget to do this on a new OSX install: On the OS X side, when you clicked "Windows File Sharing", did you click the "Accounts" button and add your account? By default (I assume for security reasons), the Mac won't enable any account -- you have to select it manually. Once I did this, I was able to access my Mac HD from the WinXP guest OS by the suggested \\<ip-address>\<user>

    HTH.
     
  12. mejacobs

    mejacobs

    Messages:
    11
    Sharing...

    Thanks BillInSoBe! Your solution worked perfectly for me.
     
  13. NoBackUp

    NoBackUp Bit Poster

    Messages:
    65
  14. jasonbuzz

    jasonbuzz

    Messages:
    6
    I am having the same problem. Windows File Sharing is ON. My account is checked. All firewalls are OFF. Both machines (imac and WinXP VM) can ping each other and connect to the internet just fine, but WinXP cannot connect to \\192.168.1.101\username. I tried the FTP function as well, but no luck there either.

    I am using DHCP on the router and static IPs in OS X and WinXP. My DNS server is the same IP as the router...wasn't sure if this is correct or not, but it got the internet working after I changed from DHCP to static IPs.
     
  15. MacUser

    MacUser

    Messages:
    43
    Hi BillInSoBe,

    This works !.
    After creating an alias of the home folder of OSX on the desktop of XP I can connect to OSX-Home with a double click. IP and password are stored so after a restart of XP or PVM it stays easy to connect.

    Thanks for posting, regards Wim.
     
  16. mattg

    mattg

    Messages:
    1
    host & guest visible on network but not each other

    would appreciate any feedback on this please:

    I have a MBP, OS X 10.4.6, with PW Beta 2.1m guest os is XP Home

    I also have a standalone machine on the network running XP Pro

    All 3 are set to the same workgroup.

    The standalone WinXP can see and read/write to the shared folders on the Mac and PWGuestXP, and both of these can access the standalone WinXP

    In Finder/Explorer network views the Mac and GuestXP are also shown as availableto each other(as icons), but there is no access

    When I click the GuestXP in Mac finder I get 'The Alias XXX cound not be found because the original item could not be found.'

    When I click the Mac in the GuestXP explorer I get //MAC is not accessiblr etc etc network path not found

    Also I have followed all the steps regarding implementing sharing in the Mac, including account enabling. The GuestXP can access the internet fine but accessing via http://192,168.1.12/myname times out

    Many thanks for any thoughts on what to try next.
     
  17. MacUser

    MacUser

    Messages:
    43
    I can only suggest to first enable as many as possible network settings (client, server, protocol) in the General tab of the Local Area Connection.

    I only really need "Client for Microsoft networks" , "Service advertising protocol" and "Internet Protocol tcp/ip) but all other protocols/services are still present (visual) but disabled. So notthing is uninstalled.

    When I uninstalled the disabled protocols/services I lost guest/host connection, and I got the same messages you see. I thought that things that are disabled could better removed to reduce boot time but that is not true. After re-installing all protocols and services again, and disabling the not needed ones (I have only the 3 protocols/services enables that I mentioned above) my connections between OSX/XP are fine as before.

    Success, Wim.
     

Share This Page