Multi Monitor Support doesn't work properly. (Version 7)

Discussion in 'Installation and Configuration' started by Craig Givant, Sep 15, 2011.

  1. serv

    serv Parallels Developers

    Messages:
    800
    Nate,

    Your virtual machine is configured with only 32Mb of video memory. Shut down your VM, open Virtual Machine menu > Configure... > Hardware, then set Video memory to at least 64Mb.
     
  2. NateL

    NateL

    Messages:
    9
    Hi serv --

    I attempted to turn off 3D acceleration and turn down the video memory as per a KB article as part of my troubleshooting. The issue was still occurring with 256MB video memory and 3D acceleration.

    I uploaded problem report 10552145 with 256MB configuration. Still shows the same issue -- ChrCannotStartReason_DisplayCfgError_Guest in the log.

    Edit: I also completely uninstalled Parallels tools, restarted, and reinstalled them. Same issue.
     
    Last edited: Oct 5, 2011
  3. serv

    serv Parallels Developers

    Messages:
    800
  4. NateL

    NateL

    Messages:
    9
    Believe it or not, I got it to work... It was a display setting in Windows. While the Display Control Panel widget showed all of my connected monitors, the "Multiple Displays:" dropdown for the secondary monitor was set to "Disconnect this display".

    The following steps have corrected Coherence for me (for all three displays):
    1) Go to Control Panel.
    2) Select Adjust Screen Resolution under Display
    3) For each additional display, ensure that "Extend desktop to this display" is selected. Press Apply.
    4) Enter Coherence and enjoy.

    For some reason, PD7 didn't automatically turn on the secondary monitors in Windows, causing the guest and host to be out of sync in terms of which monitors were active. This appears to have prevented Coherence from working. Once everyone was synced up... the rest is history.
     
    Last edited: Oct 5, 2011
  5. Craig Givant

    Craig Givant

    Messages:
    24
    Better but not fixed

    Ok, So... Coherence seems to be fixed as I can enter it successfully, however, the main request in my initial post in this thread is still not possible.

    Multi-monitor support does not work properly although strides in the right direction seem to have been made. I'm not going to repeat the details of what I'm trying to accomplish but will summarize as follows:

    I only want full screen on TWO of my four monitors. As it sits I can enable all four monitors to full screen but trying to "disable" the two that I do not want (and wish to remain in the MAC environment) results in display preferences crying that the configuration cannot be saved.

    Kudo's for the advancements but additional work needs to be done.

    Might I offer that instead of the option "Use all displays in full screen" that a selection box be added to allow the user to select which monitors to use? Currently, if this box is unchecked only one monitor is available under screen preferences in the guest OS. If it is checked all four monitors are available but unwanted displays cannot be "disabled".

    A comment on this from the Parallels Team would be greatly appreciated. Thanks in advance.
     
  6. >>> Message has been deleted by the user <<<
     
  7. YanaYana

    YanaYana

    Messages:
    1,666
    ltriebl,

    I strongly recommend you to contact Parallels tech support - they will be able to arrange a remote session and investigate the issue in place, it could be very helpful. Go to our support website and choose 'Create a support request'
     
  8. YanaYana

    YanaYana

    Messages:
    1,666
    Craig Givant,

    We will submit the feature request to our Product Maintenance team and explain your suggestion, implementation may take some time
     
  9. ssweig

    ssweig

    Messages:
    1
    Multiple monitors work perfectly in Parallels 7

    I just bought an imac 21.5" on 11/11/2011 after my third PC crashed in the past 18 months. I only use Windows, however. I purchased Parallels 7 and Windows 7 from inside of Parallels and installed both (I installed Windows 7 32 bit though). I loaded my Windows 7 programs, scanner, printers and it all works and looks perfectly.

    I had my old monitor (HP w2558hc 25.5") now laying around and about to go in the garage. I went to Best Buy and purchased a Belkin Mini DisplayPort to HDMI Adapter and crossed my fingers. I came home, plugged my old monitor into my new imac via the adapter and presto: both monitors worked perfectly. I drug the Windows 7 screen into the old monitor display and hit the green + button. That enlarged the Windows 7 screen to fill my old monitor screen. My Mac OS screen is now in the other monitor. I have two screens running perfectly. I can even open two documents in Word 2010 (Windows version) and drag one of the documents into the other screen, so I'm looking at two different Word 2010 documents (both Windows version) in two separate monitors.

    By maximizing the Windows 7 screen only via the green + button, instead of the diagonal arrows in the top right corner, I also got the added benefit of the Apple menu bar no longer dropping down everytime I try to hit the minimize, maximize or close x in the top right corner of the Windows screen. However, when I do hit the diagonal arrows in the top right as my way of maximizing the Windows screen - I get only Windows and the other monitor goes blank. Maximizing the Wondows screen using the green + in the top left corner gives me 1) a maximized Windows screen, 2) a second monitor that works perfectly and 3) the Apple menu bar doesn't drop down every time I scroll my cursor to the top of the Windows display. Works perfectly. Thank you Parallel 7.
     

Share This Page