My Mac gets incredibly slow when i run Parallels

Discussion in 'Windows Guest OS Discussion' started by LeandroF, Sep 4, 2013.

  1. LeandroF

    LeandroF

    Messages:
    3
    Hi,

    I have a Macbook Pro i7, 750GB HD, 8GB ram.

    I'm using Parallels 8 and i have 2 VMs, one with Windows 7 and other one with Windows 8.

    the problem is: when i run Parallels, no matter which VM (Win7 or Win8), both Mac and VM gets incredibly slow, making it almost impossible to use. I have no idea what's going on, but im pretty sure something is.

    I'm using 4GB ram for the VM, and 2 (of 4) cores.

    Am i doing something wrong? Do you might know how to solve it?

    Thank you very much.
     
  2. Greenwood Digital

    Greenwood Digital Bit Poster

    Messages:
    24
    More than likely you're running out of RAM on the Mac. I ran Parallels 8 with Win 7 and the VM was a 2-core, 4GB VM. I only had 8GB of RAM in my MacBook Pro and had to upgrade to 16GB in order to stop the lagging and slowing down of the entire computer.
     
  3. LeandroF

    LeandroF

    Messages:
    3
    Hi Greenwood, thanks for your help. I'll try to set only 3G to the VM and see how it goes. I'll think about upgrading my Mac to 16GB as well. Thanks again!

     
  4. LeandroF

    LeandroF

    Messages:
    3
    Hi guys,

    I've noticed one thing: when i start parallels, both my mac and the VM gets incredibly slow, for something around 10 minutes, making it almost impossible to use, since i can't see the mouse moving, alternating between windows and etc. I think the problem is more than just low memory.

    But anyway, if i wait 10 minutes, it start getting better, so i can normaly use parallels. It don't gets perfect, but it works.

    Does it make any sense? Does anyone have any clue about what's hapenning?

    It's seems to me more than a low RAM problem.

    Thanks!
     
  5. chabig

    chabig

    Messages:
    133
    Try lowering the VM RAM to 1.5GB. That's how much I gave Windows 7 on an 8GB Mac. It runs great.
     
  6. CoxWalls

    CoxWalls

    Messages:
    2
    My machine is just grinding slower and slower with Parallels on. If I close Windows, then things improve.
    How do I lower the VM RAM to 1.5GB?
     
  7. Gary Kellogg

    Gary Kellogg Bit Poster

    Messages:
    36
    My experience with every version of windows is that after you first install it, it proceeds to churn, churn, churn the disk running diagnostics, updating itself, running antimailware etc. etc. etc. The best fix is just to plan to do your installation at the end of the day so the damned machine can just churn all night. Okay, I am exaggerating but Windows really does a lot of tedious churning. A couple of days after a new Windows installation it seems to calm down. Then, every month around the second Tuesday ("Patch Tuesday" they call it) you get another dose for awhile. I agree with giving the VM as little RAM as possible--especially if you have SSD. I run a Windows 8.1 installation in 3GB of RAM.

    I see complaints all over the Parallels site about Windows hogging resources and working slowly, blaming it on Parallels. Nope. It's almost always Windows. Exceptions would be the odd bug here and there which the Parallels team seem to be relatively good at fixing. I used to ping pong between Fusion and Parallels. I stopped it. They both face the same problems (aka: the beast that is Windows) and they both work very well. I just happen to like Parallels a little bit more.
     
    Last edited: Nov 15, 2013

Share This Page