Network isn't working on 3120

Discussion in 'Parallels Desktop for Mac' started by ZeeG, Jan 13, 2007.

  1. ZeeG

    ZeeG

    Messages:
    24
    I upgraded my parallels to 3120 and after the update, the internet isn't working at all.
    My mac is connected to a wired network, and it is getting a static IP address.
    (I cannot get another IP for parallels)
    So, I used to use Host-Only networking for the internet connection, but it is not working anymore.
    I tried to use Shared Networking after I activate two adaptors from "System Preferences -> Network", and it doesn't work either. I just could see "Limited (No?) Connectivity" from Windows XP's system tray.
    By the way, in the Mac OS X side's Network panel, I can see two adaptors (en2 and en3) which I assume Parallels has installed them for shared network, and their status is not active - I mean, they have red bullet in front of them. Is it normal?

    Please help me how to resolve this...
     
  2. fenixDG

    fenixDG

    Messages:
    5
    Since installing 3120 I've also had lots of networking issues myself.

    In my case the Guest OS (WinXP) gets valid IP/DNS/etc but cannot access anything over the network. I'm currently having to force it to either reboot XP until it decides to work or keep switching the network (Bridged Ethernet) between Airport and Ethernet where it will usually start working after doing this once or twice.

    In my case en2 and en4 (there is no en3) are installed for host-only and shared networking. Though I've not used either of these modes myself.

    Don't know if it's related to your issue, but it's only noticably started with 3120.
     
  3. SkipNewarkDE

    SkipNewarkDE

    Messages:
    19
    Network issues

    I am having the same problem on 3120. I can't get ANY of the network configurations to work at all. This is frustrating. The thing will not get a DHCP address, nor resolve DNS.
     
  4. pwagener

    pwagener

    Messages:
    8
    No Networking either...

    Hi All,

    Sounds like my problem. I have a BootCamp partition that gets its networking config just fine when running through BootCamp. However, when running that installation of Windows through Parallels, I have no network.

    Interestingly enough, when looking at the Windows 'Network Connections' control panel, no network connections show up at all! No wonder I don't have any networking access: Windows doesn't appear to have any connections at all. Attempting to create a new connection doesn't help: the wizard process doesn't fail, but no new connection is created either.

    Any of this sound familiar to anyone else?


    Thanks,

    Peter
     
  5. mvcl

    mvcl

    Messages:
    3
    same problem in 3120RC - no networking - but "fixed"!

    I was seeing something like DNS not working in the guest OS. I could get Google, but little else to come up. MacOS not yet updated to 10.4.8 (it's running an earlier 10.4) I saw the same problems in IE and Firefox (current versions). I had also tried removing and recreating the network IF in Paralles - shared networking. The subject imac uses PPoE to connect directly to a DSL modem (not router). Then I rebooted. Firewalling in XP and Mac OSX were off. This didn't help!

    I "fixed" the problem finally by going into the Mac Sharing prefs, sharing network connections from imac's ethernet to en2 and en3! Basically turning the Mac into a router. Now all web sites come up in XP.

    This "hack" was never necessary with the earlier version of parallels with the same VM. I don't believe it should be necessary to share the Mac's ethernet connection in order for Parallels to give full networking to the guest XP.
     
  6. markintosh13

    markintosh13

    Messages:
    38
    I had a no-network experience with 3120.

    I rebooted my mac, opened preferences in os x, went to networking, and made sure that en2 and en3 were active (they weren't before the reboot).

    Then networking in 3120 worked fine.
     
  7. smudge

    smudge

    Messages:
    23
    I had this problem and it ended up being that the DHCP server was turned off so Windows never was assigned an IP address.
     

Share This Page