No Sound Running Windows 7 on Parallels 5

Discussion in 'Windows Virtual Machine' started by Joseph Ghammashi, Nov 5, 2009.

  1. Joseph Ghammashi

    Joseph Ghammashi Junior Member

    Here's the hardware info on the Mac:

    Hardware Overview:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro3,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 4 GB
    Bus Speed: 800 MHz
    Boot ROM Version: MBP31.0070.B07
    SMC Version (system): 1.16f11
    Serial Number (system): W87410NQXAH
    Hardware UUID: 00000000-0000-1000-8000-001B639B081D
    Sudden Motion Sensor:
    State: Enabled

    Intel High Definition Audio:

    Device ID: 0x106B00A0
    Audio ID: 44
    Available Devices:
    Connection: Internal
    Connection: Combo
    Internal Microphone:
    Connection: Internal
    Line In:
    Connection: Combo
    S/P-DIF Out:
    Connection: Combo
    S/P-DIF In:
    Connection: Combo

    NVIDIA GeForce 8600M GT:

    Chipset Model: GeForce 8600M GT
    Type: GPU
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 128 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x0407
    Revision ID: 0x00a1
    ROM Revision: 3175
    Display Connector:
    Status: No Display Connected
    HP w2207:
    Resolution: 1680 x 1050 @ 60 Hz
    Pixel Depth: 32-Bit Color (ARGB8888)
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Rotation: Supported

    I was running Parallels 4.0.3048.450204 and upgraded to 5.0.9220.531002 upon completion of the install I rebooted as directed. I launched my Windows 7 VM, Parallels automatically updated Parallels Tools and rebooted. Upon reboot there is no sound, the speaker icon has a red "X" on it, and the message "No Audio Output Device is installed" is displayed when I hover the cursor over it.

    I've tried reinstalling the tools, looking for an updated driver, trying the Realtek driver, removing and re-adding the sound hardware in the VM and still nothing.

    Any ideas?
  2. jumpingjoe

    jumpingjoe Bit poster

    No Sound Either

    I have the same exact problem. Just upgraded VM Today....everything works fine except no audio....
    windows 7 reports no drivers loaded.
    I re-installed Parallels Tools, I've tried every Sound configuration....still Windows detects no Audio Hardware at all.
  3. KonstantinO

    KonstantinO Parallels Developers

    Pease, generate and send (menu -> Help -> Report a Problem) problem report for us.
    Don't forget post ticket # here.
  4. KonstantinO

    KonstantinO Parallels Developers

    Sorry for misspelling: "Pease" -> "Please"
  5. jumpingjoe

    jumpingjoe Bit poster

    Generated Report

    OK... I generated the report. The ID is 797564.
  6. KonstantinO

    KonstantinO Parallels Developers

    Thank you for report.
    Seems like no sound driver installed in guest or sound device disabled (could be blacklisted by Vista -> Win7 upgrade).

    * Try use Windows Update to get sound driver.
    * Check sound device status in Device Manager (Start -> right button click on Computer -> Manage -> Device Manager)
  7. STim

    STim Bit poster

    Please try the following:

    1. In Windows go to Start menu
    2. Type "devmgmt.msc" without quotes in Search field and hit Enter.
    3. Right-click the "Multimedia audio device" that has yellow exclamation sign and choose "Update Driver Software".
    4. In window opened select "Search automatically..."

    After it finishes, the sound should be available.
  8. Joseph Ghammashi

    Joseph Ghammashi Junior Member

    I have also had a ticket open with support for about a week and a half now. The ticket number is 806321.

    I and the support rep have tried all the basic troubleshooting steps, including looking for an updated driver from Microsoft. My problem has never been with a missing driver. I HAVE a driver loaded for the sound controller. I'm just not getting any sound. The original VM, created and running in Parallels 4, works just fine. It isn't until Parallels 5 is installed, and the VM upgraded, that sound disappears, despite a successful install of the tools AND loading of a sound driver. I don't think it's a sound driver problem, I think it's a bug in Parallels 5.

    So far, I'm using the trial version of Parallels 5, but if this issue isn't resolved soon, I'll have no choice but to revert back to Parallels 4, rather than pay the upgrade fee, until a more stable build comes out. We run unified messaging at work and I need sound or I can't listen to my voice mail.
  9. KonstantinO

    KonstantinO Parallels Developers

    I look to support ticket (#806321) and both problem reports (#797564 and #870536).

    From #797564 I see comment about VM being upgraded from Vista to Windows 7. Could you create new VM with
    Windows 7 installed and check sound in it?. Don't try install Realtek sound drivers.

    From ticket log I see about unsuccessful try to enable hidden sound devices via tutorial. Could you repeat this try, but for _Playback_ device.
  10. brkirch

    brkirch Pro

    I have had a similar problem (no sound but the driver was installed) and it turned out that for some reason Parallels had set the VM settings for the sound device set so that the sound device would not be connected. Try going to Sound Settings and make sure that the "Connected" checkbox is checked.
  11. Joseph Ghammashi

    Joseph Ghammashi Junior Member

  12. Joseph Ghammashi

    Joseph Ghammashi Junior Member

    Thanks for the response. I've looked there already and "Connected" is checked.
  13. swissner

    swissner Bit poster

    Got it!!!

    Same thing for me, try this:
    When you try to update the driver and Windows says it can't find drivers (I'm sorry I don't remember now exactly how I did it) click on "change the way windows finds updates" or something like's a link at the bottom of the window...change setting to something like "Yes: allow windows to find drivers"

    I'm sorry again I don't have the proper steps but this worked for me...I think it had something to do with my install when windows asks how I want to receive updates...I selected only critical updates...

    hope this helps!!!
  14. Ephra

    Ephra Member

    Same prob here. Sound settings is checked/connected but the odd thing is when I uncheck it and check it back again and start my VM the red X is gone. Unfortunately I have to do this everytime I start the VM...
  15. mavsfan

    mavsfan Junior Member

    No Sound either

    I have a two-week support ticket going on this but thought I would post in case some lucky soul out there has solved this. Brand new 3.06ghz duo core imac running win 7 64 bit on parallels 5, build 9308, 2gb ram for the VM.
    Started out as a new install of parallels 5. Win 7 thinks the audio device is disabled but it is not. It also says it has the most update driver when trying to update the audio driver. Control Panel/Sounds will freeze win 7 if I try to select the third or fourth tabs, and I have to close the VM. I have uninstalled and installed parallels tools so many times I could do it in my sleep, it simply does not fix the audio.
    The audio in mac OS works fine.
  16. IlijaT

    IlijaT Bit poster

    No Plungins


    I neither have sound nor internet.. nothing..
    On OS X everything works fine, but Windows doesn't find any Plugins and says that there are none..
    If I try to update it says that everything is on newest status..
    What shall I do???
  17. mavsfan

    mavsfan Junior Member


    Since I last posted on this issue, I have been able to determine that this is not just a parallels problem, and microsoft is strangely silent on it even though win 7 has been out for awhile now. I set up another new imac with win 7 x64, but this time used a bootcamp partition instead of parallels, and got same result with no audio.
  18. Bill Palmer

    Bill Palmer Bit poster

    I just had the same problem upgrading to Parallels 7. I resolved it by disabling another audio device I had connected (in my case Audials Tunebite). So, make sure the Parallels Audio Controller is the only audio device active (Start menu, then right click Computer, select Manage, then Device Manager, then Sound, video, game controllers).
  19. EidoL

    EidoL Bit poster

    Same problem

    I submitted a report with id #10552882

Share This Page