No tilde or backtick...

Discussion in 'Mac OS X Guest OS Discussion' started by ssevennm, Jul 22, 2010.

  1. ssevennm

    ssevennm

    Messages:
    2
    Pressing tilde in guest Mac OS X, I get the character ± and backtick (grave) gets you § which is a pain. There is reference to this problem back to 2009. Can we expect a fix for this anytime soon?
     
  2. echuck

    echuck Bit Poster

    Messages:
    15
    I have the same problem. When I press backtick or tilde in my host operating system, they work as expected. But in the guest operating system, the same keys produce a section symbol (§) and a plus/minus symbol (±). I have a 3rd party PC keyboard which I've been using for years and works fine in all other respects. I just want to point out that it's not an Apple keyboard.

    Both the host and guest are configured to recognize this keyboard as a U.S. keyboard.

    Is there a fix or a workaround for this? This is a serious problem for programming and command line work.

    Parallels Desktop 6 for Mac, Build 6.0.11994
    Host OS: Mac OS X 10.6.7
    Guest OS: Mac OS X Server 10.6.7
     
  3. NathanT

    NathanT

    Messages:
    12
    I have the same issue too - it is quite annoying.

    Another annoying thing is that when you have a VM running SL server in a window, clicking to activate the VM window registers a "<return>" keypress for some reason...so, if, in the virtual machine, there is a window running (such as software update), and the "Cancel" button has focus (such as happens on software update), if you focus to another app on the host machine, and then focus back to the VM window, the "<return>" will happen (canceling the software update, in this example).

    What I've made it the habit of doing is that before I focus another app on my host machine, I click on the desktop in the guest, this makes the <return> go to the desktop instead (highlights one of the icons) which is OK, I guess...but it sure would be nice if it were fixed.

    Oddly enough, I don't see the same issue when running leopard server...just snow leopard server.
     
  4. MishaT

    MishaT

    Messages:
    1
    Fix may be coming in a Parallels 7 update

    I opened a support incident on this issue. Second level support confirmed this is an issue and that it had been forwarded to the maintenance team. I'm not sure if it will result in a fix being included in a forthcoming update or not, but it's a possibility.

    The best they could come up with as a workaround (for now) was using "keyboard and character view" in OS X:

    Please open System Preferences in your Mac server guest:
    Language and text -> input sources ->

    At the very top of the list you will find a check-box 'keyboard and character view'.
    Enable it please.

    When typing in the guest OS, click on 'show keyboard viewer' on layout settings in the system tray, hold Shift key on your keyboard and select '~` on the on-screen keyboard (or without Shift for '`' key)
    That should work.
     
  5. NathanT

    NathanT

    Messages:
    12
    This appears to be fixed (at least, it's working for me in Build 7.0.14924)
     
  6. RuiH

    RuiH Bit Poster

    Messages:
    4
    Fixed mine!
    Windows 10 under Parallels 13.
    Go to Language options settings and add the 'United States-International' keyboard layout. Mine was 'United States International (Apple) - Parallels' and that one have the tilde '~' key mapped to paragraph '§'.
     
  7. AlanV1

    AlanV1 Bit Poster

    Messages:
    2
    Very good! Worked for me too!
     

Share This Page