Not all USB ports the same..

Discussion in 'Parallels Desktop for Mac' started by Clalron, May 25, 2006.

  1. Clalron

    Clalron

    Messages:
    22
    This is interesting.

    I reported a day or so ago that I could not get my Canon IP4000 printer to work with the RC.

    Here is my set up.

    MacBook Pro 15"
    Apple 23" Cinema Display

    I have connected the USB cable from the monitor to the MacBook Pro. So now I have two ports on the monitor. The USB cable was connected on the right side of the MacBook.

    I had the Printer in the USB port on the left hand side of the laptop. OS X saw and used the printer just fine. Parallels did not.

    I moved the printer to a port on the back of the monitor--and sure enough here comes Windows XP saying hello to my nice printer.

    Further I was able to repeat this trick with my Garmin GPS which did not work in the left hand port on the side of the MacBook Pro but worked perfectly when I pulled the printer USB cable out and put the Garmin USB cable.

    So, not sure what this all means--but thought I would report it.

    -marki=
     
  2. davert

    davert Bit Poster

    Messages:
    53
    I've had similar experiences with plugging my iPod into the mac directly vs the MiniDrive bus.
     
  3. fredcast

    fredcast

    Messages:
    24
    I have seen the same problem on actual PCs. I once installed a Garmin Forerunner on my daughter's PC, but when I tried to use it again on a different USB port, it wouldn't work. I actually had to uninstall and then reinstall all of the USB drivers to get it to work.

    I am trying to get my Garmin Edge 305 to work with Parallels on my MacBook Pro, but so far no luck. I successfully installed Training Center, then connected the Edge to the computer (left side USB port). Windows recognized it and installed the drivers, but Training Center/Garmin gStart don't see the device.

    When I tried to switch ports (to the right side of the MBP), Parallels told me "USB device you are trying to connect to the virtual machine is being used by another process." When I go to the Apple System Profiler it does indeed show that there is a USB device connected, and when I disconnect the Garmin it disappears fromt he System Profiler.

    I thought your idea about switching ports was a great one. Unfortunately it didn't work for me. :(

    I guess I will keep plugging away at it.

    David

    -------------------------------------------
    The FredCast Cycling Podcast
    http://www.thefredcast.com
     
  4. fredcast

    fredcast

    Messages:
    24
    Okay, it looks like I am getting closer . . .

    I cycled the power on the Edge and then re-connected it to the USB port and the "another process" error went away. I checked in Device Manager and the PC definitely does see the Garmin GPS. The only problem is that Training Center does not see it, and I can't open Training Center until it does.

    I will keep plugging away!

    David

    -------------------------------------------
    The FredCast Cycling Podcast
    http://www.thefredcast.com
     
  5. n4khq

    n4khq

    Messages:
    81
    I have Garmin Map Source working with XP after 2 days blaming Parallels. Let me explain:
    Installed Map Source from 2 month old CD. It said it was installing USB Driver.
    Could not see etrex vista cx,
    Tried to install on Dell laptop and had same problem.
    Remember there was an update on the web.
    Down loaded update on the the VM.
    Still could not see etrex.
    Selected and right click My Computer
    Selected properties.
    Selected hardware
    Clicked Device Manager
    Found the Garmin etrex usp in the list with the yellow icon.
    Right clicked and selected properties
    Clicked drivers
    Un-Installed
    From Device Manager selected Action
    Scan for hardware changes
    Guess what plug and play found the device.
    Next I have to tell the wizard I want to point to the driver.
    I have to browse to the garmin driver folder.
    Tell xp to install the driver.
    The only reason I keep trying was I had installed on a Dell laptop a couple of months ago and had to go through the same procedure.
     
  6. fredcast

    fredcast

    Messages:
    24
    K4KHQ:

    Unfortunately I tried that exact procedure with no success. Neither MapSource nor Training Center will recognize the Garmin Edge, even though XP and the Device Manager do recognize it. I am using the latest versions of Map Source, Training Center and the Garmin USB drivers, but still no luck.

    It is entirely possible, of course, that this isn't a Parallels issue at all. It could be that the implementation of USB on the Edge or the Garmin USB drivers is just unique enough that your Windows installation needs to be just right.

    I am hopeful that someone at Parallels and/or Garmin will figure this out soon.

    On a positive note, Map Source is working great for me on Parallels. I have installed North American City Navigator, European City Select and Garmin Blue Charts. The speed is fantastic (better than on any Windows machine I've used) and I am able to create and transfer maps and waypoints to my Garmin iQue 3600! That's huge.

    I am now just one step away from being able to dump that old clunky eMachines that I've kept around for this!

    73,

    David

    ------------------------------------------
    The FredCast Cycling Podcast
    http://www.thefredcast.com
     
  7. fredcast

    fredcast

    Messages:
    24
    Just another update . . .

    I connected my Garmin GPSMap 76 using an IOGear USB-to-Serial adapter. Plug and Play found the right driver for the adapter and MapSource recognized the GPS. I was able to send maps and waypoints to the GPS and receive tracks from the GPS.

    So it looks like this isn't a general Garmin problem. It is a specific problem to the Garmin Edge.

    David

    -------------------------------------------
    The FredCast Cycling Podcast
    http://www.thefredcast.com
     
  8. joelion

    joelion

    Messages:
    1
    any updates on this situation? I have a new Garmin Forerunner 305 with the same issue. Everything installed correctly, and when I plug in the device it shows up in the Device Manager, but gStart and Training Center won't recognize it.

    i've upgraded all the way to Parallels 3092 Beta2, but no difference
     
  9. BatmanPPC

    BatmanPPC

    Messages:
    5
    I think this might be an issue with the MBP itself. I have a MBP also and the left USB port is somewhat testy about what it will work with. If something fails on the left one I try the right port and it works fine. If I use a powered hub that is connected to the left port, things work fine.

    I think it might be that the port is not providing enough power or making a good connection.
     

Share This Page