Odd Windows Update Issue

Discussion in 'Windows Guest OS Discussion' started by KPOM, Feb 6, 2011.

  1. KPOM

    KPOM Bit Poster

    I'm having an unusual issue with Windows Update. It will run while I'm running Windows from within Parallels, but not when I boot into Boot Camp.

    I use my Boot Camp partition as my VM, and am running the latest build of Parallels Desktop 6 on a late-2010 MacBook Air (2.13GHz, 4GB). I use Windows 7 Pro 64-bit. If I run Windows Update from within Parallels, it both downloads and installs all updates. However, if I run it from within Boot Camp, it appears to download, but then hangs up at the installation stage, no matter how long I let it run. Windows is properly activated on both the Boot Camp and VM (using Parallels Tools).

    Do Parallels Tools or Parallels Desktop make any changes to the Windows installation that cause this? If so, is there a way around it? When the SP1 update comes out (or any other large series of patches), I'd rather install it in Boot Camp since Windows definitely runs faster native.
  2. AdamU


    I'm having a similar issue... Windows 7 x64, parallels 6 latest updates across the board... Windows update (and Microsoft Defender Updates) *will not* run when booted to bootcamp. They work fine from Parallels.

    I get a "Windows Update cannot currently check for updates, because the service is not running" error (and yes, the service is running, and yes, I've rebooted and tried all the normal fixes. Any ideas?

    I did just migrate this install from an older MBP to a new one using winclone, (and installed the new bootcamp drivers and re-activated windows...), but it still should work!
  3. Kevin Scheid

    Kevin Scheid

    Is there a resolution to this problem?

    I have had this exact same problem from day 1 with Parallels. The only workaround I have found is to use Boot Camp to boot directly to Windows 7 and do the Windows Update there.
  4. drmike


    Found a fix

    After some googling, I found a site with an idea that was roughly similar to one solution that had been successful in the non-Boot Camp version of this problem here: http://www.sekoconcepts.net/blog/?cat=12

    I tried it, and it was successful, so posting here in case somebody else finds this question thread while googling.

    Basically, turn off Windows Update (under Control Panel > Administrative Tools > Services), then delete everything in the c:/Windows/SoftwareDistribution folder, and then Start the Windows Update Service again. This worked like a charm for me, and when I went into Windows Update after this it worked fine again.
  5. HSpangl


    That solved it for me. Thanks DrMike!

Share This Page