Older Macs can't install Parallels 17

Discussion in 'Installation and Configuration' started by GrangerFX, Jun 24, 2022.

  1. GrangerFX

    GrangerFX Bit Poster

    Messages:
    19
    On a 2009 iMac, a 2010 MacBook air and a 2010 MacMini, all running MacOS Catalina, the Parallels Installer fails to launch after the installer package completes the download.
    Possible causes:
    Catalina is not officially supported on those Macs and was installed with DosDude1's Catalina patcher. However, this OS is fully compatible with every other app I have tried including Xcode and Bootcamp.
    These older Macs simply have not been tested with the current version of Parallels. They are listed as compatible on the Parallels supported system configurations.
    No urgency here and if you want to remove these old systems from the compatibility list that would be fine. I am just having some fun restoring a few old Macs to usability and finding out what they can do.
     
  2. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, please refer to this KB article for checking the compatibility between Mac OS and Parallels Desktop for Mac.
     
  3. GrangerFX

    GrangerFX Bit Poster

    Messages:
    19
    As stated, my older computers are running Catalina which is compatible according to that chart. The thing you didn't take into account is that it is possible to upgraded older computers to newer operating systems using third party tools. Those old computers are not compatible with Parallels 17 due to their hardware, not their operating system.
     

Share This Page