opensolaris 2008.11 generates panic or hangs during install on Parallels Desktop Mac

Discussion in 'Other Guest OS Types Discussion' started by csbdeady, Feb 15, 2009.

  1. csbdeady

    csbdeady

    Messages:
    1
    When I install opensolaris 2008.11 from ISO image with the OS set in Parallels Desktop for Mac as Solaris / Other Solaris I see the following after selecting either X86 or X86 text console as the installation method:

    This message appears dozens of times (with a slightly different thread and rp value in each case) with some other error message before it (that scrolls of the screen far too fast for me to read it),

    If I change the OS to Other OS then after selecting one of the above messages I see:

    and then the installation hangs and proceeds no further (no spinning \|/ symbol, stuck showing _).

    My setup is:

    Mac OS X 10.4.11 fully patched running Parallels Desktop 4.0 for Mac Build 4.0.3810 (January 23, 2009)
    VM OS: Solaris / Other OS (see above)
    VM RAM: 1024MB
    VM HDD: 32GB expanding
    Boot order: CDROM then HDD
    other settings as default

    I've searched the internet on this and the only suggestions I can find are:
    1) remove all serial and parallel port configs for the VM (I have none);
    2) add 2 serial port configs for the VM (I tried this even though it is directly contradictory to 1);
    3) make sure the VM RAM is 1024MB (it is).

    I am really stuck now :( I can see from threads that others have opensolaris 2008.11 installed, but I just can't get into the installation proper.

    Are there any parameters I need to add to the kernel in GRUB? I found an entry about adding a CDROM line and setting and tried this but no luck either as I got the same errors.

    Any suggestions gratefully appreciated.
    -Colin
     
  2. beta_vanjab

    beta_vanjab

    Messages:
    4
    Try setting RAM to 512M, it should help with installation.
     
  3. Guy Davies

    Guy Davies

    Messages:
    20
    I see an almost identical failure but I have managed to complete the installation. This failure occurs immediately after the reboot following the completion of the installation.

    panic[cpu0]/thread=fffffffffbc2a8a0: BAD TRAP: type=1e (#- trap) rp=fffffffffbc317a0 addr=1e
    panic: entering debugger (continue to reboot)

    I have 512MB of RAM configured as suggested.

    Any ideas

    Rgds,

    Guy
     
  4. Fai Lau

    Fai Lau

    Messages:
    10
    I got the exact same error. Solaris panics at reboot after installation. All VM parameters are as recommended by Parallels for Solaris 10
     
  5. Matthew Farmer

    Matthew Farmer

    Messages:
    2
    I am also having the same errors. I have a MBP with the latest updates to Parallels 4.0. I have tried setting the VM's memory to different sizes, changing the HDD to SCSI and back to IDE, turning off 3D acceleration on the video card, setting the nic to bridge mode and the shared, enabling Adaptive Hypervisor and then turning it off. All with the same results.

    Does anyone from Parallels know or seen this issue?

    Thanks
    Matt
     
  6. Matthew Farmer

    Matthew Farmer

    Messages:
    2
    Downloaded the 08.05 release of OpenSolaris and the install completed just fine and everything is running. Still haven't figured out what is causing 08.11 not to boot after the install.
     
  7. mgl

    mgl

    Messages:
    7
    OpenSolaris 2009.6 exhibits same behavior.

    Was able to install with 512MB RAM, but freshly installed OS crashes parallels after GRUB menu.
     
  8. sethmeisterg

    sethmeisterg

    Messages:
    1
    Solaris panic on boot

    Hi,

    Seth from Sun here. I've debugged this and it appears to be an issue on the 64-bit kernel where Parallels is not properly handing the GSBASE that Solaris has set up on the boot CPU. Regardless of the value of GSBASE, Parallels loads %gs-relative memory reads as if GSBASE was set to 0. This causes a panic because the kernel's cpu structure is accessed via a %gs-relative load. This started to be an issue around build 94 of Solaris Nevada, but I'm not yet sure why that is (since the use of GSBASE has been there from the first integration of the amd64 64-bit support).

    --S
     
  9. Fai Lau

    Fai Lau

    Messages:
    10
    I am testing a Parallels 5 beta and it does load Solaris fine. I have not tested it extensively though but being able to boot is a start.
     

Share This Page