OS X 10.6.8 update - Dock thread 100% usage

Discussion in 'General Questions' started by kinneyr2, Jun 24, 2011.

  1. kinneyr2

    kinneyr2

    Messages:
    1
    Yesterday I was updating my iMAC core i5 (4 cpu core) system OS X 10.6.7 to 10.6.8. After finishing the install and rebooting, I proceeded to start Parallels 6 Desktop for MAC Build 6.0.12090. The launch from the DOCK also launches a thread dock. The dock thread was at 100% CPU (one core was completely consumed). Shutting down Parallels did not solve the problem nor did cache cleaning and rebooting, even to safe mode.

    I restored the hard drive from my external back up and reverified that OS X 10.6.7 does not have the problem.

    I updated again to OS X 10.6.8 and once again starting Parallels causes the dock thread to consume 100% cpu.

    Has anyone else experienced this? It appears to be a bug, incapability with Parallels and OS X 10.6.8.
     
  2. Viremia

    Viremia

    Messages:
    2
    Same problem.

    Solved it by deselecting "Show Windows applications folders in Dock" feature under configure, Options, Applications. Do this for each virtual machine you have installed. My macbook pro temps returned to normal and Dock was no longer eating up an entire core.
     
  3. DeShawnB

    DeShawnB

    Messages:
    116
    If you’ve installed the Apple Snow Leopard 10.6.8 update we recommend that you make a change in your Windows virtual machine to insure optimal system performance. The steps to do this can be found at http://kb.parallels.com/en/111541.
     
  4. owine

    owine

    Messages:
    3
    Does this require a restart or anything? I actually had manually dragged Windows Applications out of the Dock but now have also changed this setting and my Dock CPU is still at 100%.

    Will this feature be fixed and returned in a future update?
     
  5. STim

    STim Super Moderator

    Messages:
    942
    owine,

    Dock restart is required. If you do as suggested by KB article - Dock is restarted automatically. But since you manually removed the folder by dragging it out, it wasn't restarted.

    To restart it manually:
    1. Launch Applications->Utilities->Terminal
    2. Type
    Code:
     killall -9 Dock
    and hit Enter

    The Windows Applications Folder operation will definitely be restored in the nearest update
     
    Last edited: Jun 25, 2011
  6. Luà sG

    Luà sG

    Messages:
    6
    Loop Login after running parallels and mac OSX 10.6.8

    I used the workaround and now i can run parallelels with mac OSX 10.6.8, but after that, in the next login, I keep going to a login loop. So i have to login with another user and remove the file /Users/youruser/Library/Preferences/loginwindow.plist to be able to login again. Any solution? Here are the thread of login looping: https://discussions.apple.com/thread/3142691?start=15&tstart=0
     
  7. DeShawnB

    DeShawnB

    Messages:
    116
    That's good news BobbyR!
     
  8. Luà sG

    Luà sG

    Messages:
    6
  9. DeShawnB

    DeShawnB

    Messages:
    116
    Hey LuA SG,

    Did you try any of the suggestions people made in that Apple forum thread?
     
  10. IanDOwnie

    IanDOwnie Bit Poster

    Messages:
    3
    Partial Solution

    I found that I was unable to follow the instructions in the KB article because the virtual machine became completely unresponsive after I unchecked the show application box. I shut down but the dock icon was still there when I restarted and the whole system was responding only fitfully.

    If you have updated to 10.6.8, and can do without Parallels, do not start it up!!!!! If you do, you are in for trouble. Best to wait for an update from Parallels and/or Apple.

    Anyway, if like me you were persuaded by the KB article that there was a simple fix, here's my way out.

    I restarted in safe mode by holding down the shift key while restarting and that was enough to allow me to operate. Activity Monitor showed the dock using high 90s percent of CPU. Make sure you have the CPU tab selected in Activity Monitor, and you will see the dock hogging processor time.

    I went to my home folder/Library/Preferences and dragged two files to the desktop: com.apple.dock.db and com.apple.dock.plist. I will put these back when Parallels comes up with a fix. Meanwhile, welcome back VMWare.

    The final step is to select the dock process in Activity Monitor and click the re Quit Process button. A final thrash of activity will end with the dock process restarting, using virtually no CPU time, and two fresh preference files appearing in the Preferences folder. The dock is now in its default state as it appears when you do a fresh OS install and you can put back any application items you want (other than Parallels).

    If you don't have an alternative to Parallels, you could risk starting your VM and following the KB instructions to stop it automatically putting the application folder in the dock. Perhaps someone will do that and report back. Me, I'm going back to using VMWare.
     
    Last edited: Jul 1, 2011
  11. ChristophZ

    ChristophZ

    Messages:
    6
    In my opinion there is another problem with the 10.6.8 update. When i use the windows explorer in conjunction with a subversion the parallels vm app takes nearly 100% of cpu.
     
  12. Luà sG

    Luà sG

    Messages:
    6
    Everything returned to normal after install of parallels upgrade version 6.0.12092. Problem solved.

    Thanks
    Gustavo
     
  13. IanDOwnie

    IanDOwnie Bit Poster

    Messages:
    3
    Yes, update has done the trick but ...

    If you started up Parallels 6 Desktop for MAC Build 6.0.12090 after updating Snow Leopard to 10.6.8, you may have the problem I had with the dock consuming 100% CPU time even after restarting without starting Parallels. If you have not updated to Parallels build 6.0.12092 and still have not updated Snow Leopard, update Parallels before updating Snow Leopard.

    My fix posted yesterday for the 100% CPU usage problem is garbled so I will repeat it here, with one difference:

    1. Start up in Safe Mode by holding down the shift key while restarting. This will give you some CPU time back and allow you to fix the problem.

    2. Go to your account preferences folder ~/Library/Preferences and drag com.apple.dock.db and com.apple.dock.plist to the trash. This will (after step 3) restore your dock to the default settings. I now don't recommend restoring these files after doing the Parallels update in case the problem is in the Parallels dock icon, but if you want it back the way it was before, make sure you take a screen shot of the dock first, or make a list of its contents.

    3. Open Activity Monitor (in Applications/Utilities), select the CPU tab if not selected, select the Dock process, and click the red Quit button to force the dock to quit.

    4. The frenzied CPU activity should stop within a few seconds.

    You can now update Parallels, though I suggest you choose the direct download method rather than the in-app method: http://www.parallels.com/download/desktop, or in my case in the UK http://www.parallels.com/uk/download/desktop.

    As an aside, when I installed the Parallels update, I got the notorious 'unable to download' error every time the Parallels Tools installer tried to run. For the solution, see http://forum.parallels.com/showthread.php?t=90266 and scroll down to the post by renato_nyc on 5 March 2010. I found I had to double click setup.exe as the setup didn't start automatically.
     
  14. ThunderChop

    ThunderChop

    Messages:
    1
    Note for those newbie Mac users like myself: If you only have 1 account you will not be able to log into another user account in order to delete the file /Users/youruser/Library/Preferences/loginwindow.plist. Thus, you need to boot off your OS X Install DVD, select your language, then use the utility menu at the top to select "reset password". You will need to reset the password for the "root" account, doing this will activate the root account. Then you can restart up in Safe Boot by holding the shift key down. Finally, you will see an other option for logging in, which you can click on, type "root" for the user and enter the password. This was a real pain for me to figure out so I thought I'd share it with others just in case you are having the same difficulty.
     

Share This Page