OSX guest 10.9 goes black on suspend and won't come back when waking it up

Discussion in 'Mac OS X Guest OS Discussion' started by MarkoK, May 17, 2014.

  1. MarkoK


    I always see Parallels 9 (on OSX 10.9.3 as the host) not being able to wake up a suspended OSX guest.

    The screen goes black, but only sometimes I manage to get a login dialog on that screen.

    Most of the times the screen is simply black.

    Suspending the VM and waking it up again leaves it still black, while the mouse is captured.

    I need to shutdown the VM and restart it, which is annoying if you've left some apps open.

    How can I perhaps as a workaround assure that the VM won't ever suspend???
    Last edited: May 17, 2014
  2. Mervin@Parallels

    Mervin@Parallels Guest

    Hi MarkoK,

    Follow the steps given below:

    1) Shut down your Windows Virtual Machine.

    2) Go to VM config (http://kb.parallels.com/117287) > Hardware > Video > 3D acceleration > Disable

    3) Select Don't optimize for games and enable smooth scrolling option under:

    VM config > Hardware > Mouse and Keyboard > Smart mouse

    4) Re-install Parallels Tools as suggested at: http://kb.parallels.com/4841

  3. afjafj


    Hi Mervin,
    I have the same problem as MarkoK.

    Your reply seems to be related to Windows Guest OS, but the problem for me is with Mavericks as the Host and Guest OS.

    After wake from sleep, the VM is suspended. Click to resume results in a black screen for around 2 minutes and then the VM shuts down.
    If I suspend the VM using the menu, I can successfully resume.
    I have tried changing the Smart Mouse settins and reinstalling the Tools, as noted above (No 3D setting for Mavericks) but this has not helped.

    Have checked that Parallels is all up to date.

    Any suggestions?
    Thanks and best regards,
  4. MarkoK


    Last edited: May 22, 2014
  5. afjafj


    I've now also tried manually suspending the VM, then letting the computer go to sleep
    When it wakes up, I can manually resume the VM and it works fine.
    So the root issue seems to be to do with a suspend when the Mac is going to sleep.
  6. afjafj


    I've tried the same Energy settings as you suggested and initial indications are that this has fixed the problem. I've just woken the Mac from sleep and the VM is still running.
  7. MikeyH

    MikeyH Bit Poster

    Last edited: Aug 20, 2014
  8. SteveJohns


    Same problem

    Hi All

    I'm having the same problem - did anyone ever get a solution that worked?


  9. elementaltm

    elementaltm Bit Poster

    I too have the same problem, when running Mavericks on Parallels Desktop 10.x with Mavericks as the Guest OS.
    Support please can we have an update on this unresolved issue please.
  10. Mr. C.

    Mr. C. Bit Poster

    I suppose a +1 one is useful here. Parallels Version 10.0.2 (27712)
    Last edited: Oct 14, 2014
  11. Maheesh@Parallels

    Maheesh@Parallels Parallels Support Parallels Support

  12. Mr. C.

    Mr. C. Bit Poster

    Any love for us Parallels 10 users?
  13. FredUntu

    FredUntu Bit Poster


    Same problem here.

    You don't even seem to read the problem and just copy/paste a pre-written answer.
    Our problem applies to MacOs X Guest system (if you're a tech support, the first thing should be to check the section people are posting the thread in !!!!!).
    This problem exists SINCE THE VERY FIRST RELEASE of Parallels 10.
    And the nicest thing is : I can't reboot now. So Black screen. Cannot reboot guest OS. If I quit Parallels, and ten relaunch it, I just go back to the black screen.
    SO : erase guest Os image, and reinstall the whole thing...
    All this happens on a freshly reinstalled OsX Mavericks, so there is NO CONFLICT possible.
    MacOsX 10.9.5 used with latest Parallels version ; iMac Quad-Core 2.5Ghz ; 16GB RAM ; 500GB SSD.

    By the way : I have been forced to download OsX 10.9 and proceed with a manual install because it seems that something is broken with 10.9.5 and the automatic install just results in an "EFI command line" window.

    And of course : NO REPLIES to our posts in here...

    SO MY CONCLUSION : if you do not know how to develop a software properly, don't do it. Instead of releasing new products, just finish to stabilize the current. I'd rather stick to version 5 or 6 and have something that runs, than to have the latest version 10 loaded with useless features and firing guest OS'es that just DO NOT WORK.
    Especially as it seems you're not interested in Parallels anymore...
    Guess I go back to that free software... at least, when it's free there's no reason to complain !
    Any mass refunds plan in your pipes ? Or shall we just wait to re-open our wallets fo have the chance to get Parallels 11 at a "super redeemed price" of 50 bucks instead of 80 when it comes out ?
  14. SamDaBull

    SamDaBull Bit Poster

    I have the same/similar black screen problem except the Guest OS is Windows 7 using Parallels 10 (latest build) and the host OS is Yosemite (10.10). After booting into the guest OS I can see the desktop for a second and then the screen goes black. I can see the cursor but it's on a black screen. If I use mission control to "back out" of the full screen VM I can see the miniature preview of the desktop for the guest OS but again... after selecting Parallels the guest OS screen goes black again. The problem appears to be minimized by disabling hardware acceleration. However, I use Solidworks in Parallels and it's effectively unusable with software acceleration only because of painfully slow refresh rate of the screen when tumbling even a simple model. And of course the VM is unusable now if the hardware acceleration is turned on. So both are unusable.
    Is there a fix for this?
    I'm using a core i7 MB Air with 8GB of ram, 1.5GB of dynamic video ram and the Intel HD 5000 graphics card. (same hardware configuration as the new top of the line mini announced today)
    Last edited: Oct 16, 2014

Share This Page