P4.0 - how to swap command and control?

Discussion in 'Windows Guest OS Discussion' started by Wildnight, Nov 11, 2008.

  1. Wildnight

    Wildnight

    Messages:
    22
    In P3.0, there was a check box to swap the keys. I can't for the life of me figure out how to do it in P4.0. Can anyone help?

    Thanks

    Jeff
     
  2. John@Parallels

    John@Parallels

    Messages:
    6,343
    Parallels Desktop - Preferences - Keyboard
     
  3. Wildnight

    Wildnight

    Messages:
    22
    Thanks, but there's nothing in there to swap the keys. I've played with the "Virtual Machine Shortcuts" but that doesn't seem to be getting it . . .
     
  4. Wildnight, if you change profiles in Preferences/keyboard, it is very similar to this "old swap" - the difference being that you can still detail the "swap" of any kind of cmd/ctr pair in the list below the profiles.

    If you take a look and a little time, you will figure out and realize that how it works, I would assume.
     
    Last edited: Nov 11, 2008
  5. tbo

    tbo

    Messages:
    6
    To be more precise: Navigate to Preferences > Keyboard and Mouse. Select "Generic" and edit the CMD so that it maps to "Ctrl". Now select "Edit Profiles" on the top right and assign the Generic setting to the Windows machine. That should do. To avoid quitting parallels when pressing CMD-Q, deselect "Enable Mac OS X system shortcuts".
     
  6. BlueCrow

    BlueCrow

    Messages:
    18
    I've tried all this and it does not fully work. For me, when I tell it to swap command and control, the control key still works and using it (instead of command) is the only way to select multiple items in a list. I also have an issue where the control key now sticks and pressing keys like "e" and "s" brings up various system windows. My = key no longer works either. All these things were fine this morning prior to the quick/easy upgrade the marketing e-mail promised me. I have a very normal install of XP, no virus protection, no weird utilities, have latest service pack, etc.

    Wildnight, you should add a link to your other post here that details the issues you are having.
     
  7. BlueCrow - did you make sure that you assigned your desired profile to the specific VM, otherwise you an make any kind of changes to profiles but it does not take effect, if this profile is not assigned to your VM.

    Very confusingly, assigning a profile is done through "Edit profile". This is where you have to look in order to check that.

    Is someone from Parallels watching this thread??? In general I would like to state the following to them?
    a) The key mapping in v4 seems to be more versatile, but is has become also more confusing an in some sense limiting
    b) On confusion: how a specific profile is assigned to a VM is confusing, and I would consider this option to be "hidden" - meaning it is not obvious that is needs to be done in order for specific changes to a profile to take place
    c) On limitation: I really like Cmd+W in order to close windows or more specifically to close tabs in a browser. PRIOR to v4 this could be done congruently between guest and host: the same command was there on Mac OS and under the XP-VM - simply by default through swapping cmd/ctr. BUT NOW Cmd+W is there under Parallels to close the window of the specific VM without closing the application - by default and no way to change it. I do not like that. Simply because the usage of a browser and closing tabs is so ENORMOUSLY more frequent during the day than closing a VM window
    d) I am praying for the day when tiny-little option windows are given a normal size or are made resizable in order to give clarity to the user and not hide stuff.
     
    Last edited: Nov 12, 2008
  8. tbo

    tbo

    Messages:
    6
    Keyboard issues

    @BlueCrow: I agree, changing the basic mapping is an annoying thing in the first place, because I got used to the shortcuts. For selecting lists, I mapped the Win-key to the Ctrl-key, which works fine. I think there is a huge advantage now in mapping keystrokes to certain commands. It allows for a more specific usage. But the downside is that I have to get used to the new commands...
     
  9. BlueCrow

    BlueCrow

    Messages:
    18
    Thanks. I did make sure my virtual machine is set to the Windows profile (in the Keyboard & Mouse Prefs) and that profile is the one I have been changing. Swapping the keys does work in some instances (Command-S actually does save, etc.). It appears though that there are just some bugs since several people seem to have the same specific issues. If anyone can figure out a better place to post this so someone from Parallels chimes in, please let me know or just go ahead and post it please.
     
    Last edited: Nov 13, 2008
  10. By now I had to suffer similar: Ctr was locked down like caps-lock would be - only that it could not be unlocked.

    I could not realize why it happen - it just happened during the day at one point, and I need to shut down the VM and re-start ist. Something I really dont like during the working day.

    It has happend several times by now.
     
  11. The Ctr-lock just stroke again! Annoying!

    My suspicion now is that is has something to do with typing the "@" in the VM. The @ used to be on Cmd+Alt+Q in my XP-VM on v3. Now since the old "Cmd-Ctr-swap" is no longer there, I sometimes type the old, while I would need to type Ctr+Alt+Q. And while the latter works, the old Cmd+alt+Q leads to the Ctr-lock where I need to restart my machine!!
     
    Last edited: Nov 13, 2008
  12. And please note: this is dangerous stuff. I renders the machine impossible to work with until the restart!
     
  13. Wildnight

    Wildnight

    Messages:
    22
    More

    Anyone interested in this topic should also refer to this post: http://forum.parallels.com/showthread.php?t=31306

    I agree about the control-w thing. I use that a lot to close windows, and would prefer not to close down my entire parallels session.

    Also, while the (mystifying) new keyboard mapper may provide a lot of flexibility, it sure is a lot more difficult than just clicking a check box to swap command and control like in the prior version. I don't know how many clicks and keystrokes the new way requires to make this change, but it's a lot more than the 1 from before. I vote for a checkbox.
     
  14. I second the vote vor the checkbox and what Wildnight says.

    It is just an example where a simple and effective option is no longer there. And the "new stuff" is more complicated and sometimes less effective.

    I don't think that the new options should be discarded, but the old checkbox should be brought back in order to solve/deal with what a lot of v3-user like to have.
     
  15. Another episode to add to the ctr-lock:

    It was my previous v3 command to use Cmd+Alt+R in order to screen capture a region with Hypersnap. In v4 it no longer works. When I determine the key combination on the Hypersnap options, Cmd+Alt+R is registered as Ctr+Alt+R - just as it is intended to. But what if I press Cmd+Alt+R in the XP-VM?? Exactly, the terrible Ctrl-lock strikes and I need to restart my machine!
     
  16. Wildnight

    Wildnight

    Messages:
    22
    I will add that I use Dreamweaver all day long. Now, control-U (which is used to put your changes to the production server) no longer works. Even though command-U is mapped to windows ctrl-U, when pressed, it just makes a 'U' key press, not recognizing the control. I am sure it thinks I pressed windowskey-U. Now, for every file I change, I have to find it in the Dreamweaver explorer, right click it, and choose "put". This takes **SO** much longer than Control-U.

    Parallels, what's the deal?? Is there a fix coming?
     
  17. Flagg

    Flagg

    Messages:
    218
    Possible workaround.

    As a possible workaround, try setting keyboard shortcuts in Windows profile to default, change "Release input" shortcut to something untrivial, like Ctrl+Alt+I, disable all virtual machine shortcuts and then add the following:

    Cmd -> Ctrl
    Ctrl -> Win
    Cmd + Shift -> Ctrl + Shift
    Ctrl + Shift -> Win + Shift
    Cmd + Alt -> Ctrl + Alt
    Ctrl + Alt -> Win + Alt
    Cmd + Alt + Shift -> Ctrl + Alt + Shift
    Ctrl + Alt + Shift -> Win + Alt + Shift

    After doing so, I was able to switch Ctrl and Cmd keys to some degree. Combinations like Cmd + <some_key> worked like Ctrl + <some_key>, and viceversa. Combinations like Cmd + Shift let me switch input languages, while having it binded to Ctrl + Shift in Windows, Ctrl + Shift did nothing. Cmd + Shift + Esc called the Task Manager, that is set up in Windows to Ctrl + Shift + Esc, while Ctrl + Shift + Esc did nothing. The only thing that did not work properly of which I tested was Cmd + Alt + Del: although it did work as Ctrl + Alt + Del, Ctrl + Alt + Del was not disabled and worked as usually.

    If that does not help, you can always reset the defaults.
     
  18. universo

    universo

    Messages:
    1
    Complete agree with earlier posters, I was happy with just 'Swap cmd and ctrl'. Now if I turn 'Enable Mac OSX System shortcuts' on, then I cannot do things like use the Ctrl key with my arrow keys to do fine editing in powerpoint.

    Ctrl is for more things then just copy/paste people.

    And if I turn it off then expose is also off so I can not use my mouse to quickly switch desktops to a non-parallels space. Aaaargh! This is so annoying. I might be able to do some keyboard mapping voodoo to get this to work, but the default is just broken this way!

    Please, please, please just go back to the way this stuff worked in v3!
     
  19. BlueCrow

    BlueCrow

    Messages:
    18
    The Parallels team needs to realize that this is not a matter of users not kowing how to use the new functions. It is that the new functions are not working properly. It happens to me once a day at least now, right in the middle of working, that the Windows key gets stuck and starts opening various system windows when I type. Only restarting stops it.

    One other thing I cannot explain is that the equal = key on my number pad does not work in version 4. Works fine on the Mac side and and the equal key along the top of the keyboard works fine in both Mac and Windows. It is really a pain when doing Excel work. Anyone else have an equal = key that does not work on their number pad?
     
  20. I completely agree with BlueCrow and it happens to me as well that the keys get lock. In their case it is Windows key, in my case CTR.

    There is the matter of ill-design where there once was a simple solution like the swap and where now you have to go through something tedious as a workaround.

    And there is the matter of malfunction as BlueCrow and others pointed out.

    I have submitted this as well over "reporting a problem", but also no answer or acknowledgement that this is something Parallels needs to resolve.
     
    Last edited: Dec 4, 2008

Share This Page