Palm sync via USB under Windows XP - anyone got this working satisfactorily?

Discussion in 'Windows Guest OS Discussion' started by Luther Blissett, Jun 27, 2007.

  1. Luther Blissett

    Luther Blissett

    Being able to sync my Palm handheld with various programs that are only available under Windows is one of the main reasons I use Parallels Desktop. After much fiddling, I've gotten it to work, but it's still quirky. I have a Palm Tungsten C and need to sync it via USB (no Bluetooth). When I hit the sync button on the Palm cradle, I hear the USB connect sound in Windows, but HotSync doesn't start. If I cancel sync, then hit the sync button again, same thing. The third time I hit the cradle's sync button, HotSync starts up and runs just fine (I learned this trick from another thread in this forum) - and this works every time I sync (always on the third try, that is). So it works, but it's kind of a pain to have to start and cancel sync twice before it eventually works.

    If you're also doing a Palm USB sync under Windows XP, is this also your experience? If not, is it working better for you, and how did you get it to work? :)

    Nova Development support - what's up with this, and is there a fix for this coming soon? I found this quirk on all of the 2.x builds this spring (it worked fine for me when I first bought your product last fall) and it continues to be the case on 3.0 (build 4128), which I've been using for a couple of weeks. I'm experiencing this same problem on both my home computer (MacBook with XP Home virtual machine) and my work computer (MacBook Pro with XP Pro virtual machine) - same build 4128 on both.

    Thanks for any tips or help you can provide.
  2. Lobo59


    Same for me!

    I am experencing the same thing, ie I have to start and cancel sync three times before it will start syncing. Parallels 3.0 also messed up Missing Sync, it no longer works via USB but does via Bluetooth. I believe that Smartstart is what's messing that up and I'm looking forward to the update that will allow me to turn Startsmart off. Let me know if you find a fix!
  3. dkp


    This worked for me. Disable any Palm software in OS X because it will try to grab the device. In Parallels's VM config editor turn off auto-connect USB devices. Start Windows. Plug in your Palm device. Press the sync button. Open the Parallels Devices -> USB menu and select your Palm device. The sync should start.

    Back to the Mac Palm software - use your system monitor to explore running processes and see if there are any Palm-related applications running. The one that causes problems is the USB listener. If you find it in the process table use the system monitor to terminate it.
  4. musk


    I've been successful getting my Palm Treo to sync to a WinXP Pro SP2 virtual machine. The VM almost always recognizes when I initiate a hotsync from the Treo (occasionally I have to initiate a second time). The only problem I have is that the Hotsync connection frequently drops during larger file transfers. A dialog box with the following message gets displayed:

    "The HotSync operation was interrupted. Some of your data was NOT backed up."

    The HotSync log reports "HotSync Error: Connection is lost (6410)".

    Usually this happens while backing up the Phone Call database, as that's the largest file on my Treo and takes several minutes to transfer during the Hotsync (although it has happened at other times). I have found that the Hotsync process seems more likely to finish successfully after a fresh boot of Windows. Also, if I do nothing on the host Desktop while the process is running, it seems more likely to succeed as well. (Hard to say for certain, but it seems that way.)

    I am running Parallels Desktop 3.0 Build 4128.

    Edit: This disconnect behavior also happens when running PDAnet, an app that turns the Treo into a wireless modem. Since the USB connection to the Treo is constantly established during use of this app, the connection is eventually lost after a few minutes. It seems the setup just can't handle sustained USB transfers with the Treo.
    Last edited: Jun 28, 2007
  5. Eru Ithildur

    Eru Ithildur

  6. FlaSheridn


    Palm sync via USB: HotSync Error: Connection is lost (6410)

    I solved this by upgrading to VMWare Fusion. The problem happened consistently on both my home (both XP and Vista) and work (XP only) MacBook Pro. Doing a slow sync almost always took several tries before completing, generally only if I disabled the Backup conduit. After a week with VMWare Fusion, I've only seen the problem twice, both times during the Backup conduit, which I usually didn't even attempt with Parallels.
  7. Xenos

    Xenos Parallels Team

    Hello all,

    Thank you for your reports.
    Please check Palm sync working under Windows XP in RC 5580.
    We recommend testing betas and RC on clean VMs.

    Best regards,
  8. musk


    I used Fusion during the beta period and found I was able to consistently sync as well. However, I had already purchased Parallels 3.0 and prefer it's integration between Windows and Mac, so I'm still here.

    I'm not able to test this anymore because I moved to native syncing of the Treo with Mac OS X. Something running on the Mac now grabs the Treo as soon as it sees it appear on the USB port. I could probably kill iSync and get it to work, but I don't have much time right now to deal with the potential clean-up if something gets messed up from syncing to two hosts. Hopefully someone else can give it a shot.
  9. Eru Ithildur

    Eru Ithildur

    If one were to unload the .kext file relevant to the Treo it should connect in fine. What Parallels is missing, that it appears Fusion has, is something that will unload the .kext files accessing the USB device when the user selects for it to connect to the USB Device. It would also need to re-load those files when Parallels is done with the device.

    musk, try setting things to auto-connect USB, restart and see how it works.

Share This Page