Parallel Policies - problem with saving password

Discussion in 'Parallels Client for Windows' started by Ivan53, May 16, 2024.

  1. Ivan53

    Ivan53 Bit poster

    I'd like to ask a question about this weird setting that I can't understand how it works.
    What I need to do is with Parallel RAS, in Windows 10/11, through the client to:
    Connect and being asked username and password, having the ability to choose to save the password or not.

    Starting here (new first-time connection):
    choosing to tick 'Save Password'
    Once logged in, I logout.
    I re-establish the same connection, however, thats what I get:
    Even though I decided to save the password, through the first-time connection, reconnecting, as shown, it still asks me to insert the password, and the possibility to check 'Save Password' is greyed out. So something isnt working...

    Here's my Parallel RAS server policies:
    1. Primary Connection
    'Save Password' here, is disabled, because since reading this:
    I did this test:
    If I login the first time connection without checking the save password option and right after I check this 'Save Password' option, doing the step logout-reconnect, it will automatically login without asking the password (I guess thats what it means by forced, in the article)
    2. Control Settings > Credentials
    reading this article,
    If I do not check the 'Prohibit saving password', I should be able to see the checkbox at the connection that asks me to save. I dont have that checkbox option to save the password in the second following reconnection.

    What I am expecting is:
    Primary connection > Save Password OFF (because even the people that decided to not save the password, will have it saved forced)
    Control settings > Credentials > Prohibit saving username AND password OFF

    I am able to connect, choose to save the password or not. And if I do, I expect that in the next logins I wont be asked to insert it.
    However, if I don't choose to save, I will have to do the default route, inserting the password manually, but it will still asks me to save or not, in case in future I do decide eventually to save it.

    However in this scenario with these settings (OFF, OFF): When I choose to save the password in the first-time connection, the following ones will still asks me to insert it, and the option to save is greyed out (which should be when the option Prohibit saving password is ON, which is not my case)
    Can someone take a look into this or help?


    Attached Files:

  2. Christian Aquilina

    Christian Aquilina Parallels Team


    Policies are applied after a successful connection. If the aim is to allow user to choose to save password or not then the policies highlighted above are not required. If user chooses to save password then next consecutive update user will not be asked to save or to input credentials. If the aim is for users to always be asked for credentials then save password should be unchecked and pushed through policy. Not sure if this addresses your question, let me know if otherwise.
  3. Ivan53

    Ivan53 Bit poster

    Hi thanks for the reply.
    What I am trying to understand is: both policies OFF, I still have the 'Save Password' checkbox greyed out. Without the possibilty to check it, when in theory with the policies both off, I should be able to. Correct? In that case, there's a problem with the settings not working properly, I assume.
    Both policies are correctly 'updated' since I managed to connect without problems and check the #vers. are the same of the Parallel RAS Server.
  4. Ivan53

    Ivan53 Bit poster

    is there any updated on this?
  5. Ivan53

    Ivan53 Bit poster

    Bump if possible. Thanks
  6. Ivan53

    Ivan53 Bit poster

  7. MixailP

    MixailP Bit poster

    The policies are applied from the Connection Broker once the connection is established. So if you made any changes you need to connect first for them to be applied.

Share This Page