Parallels 10 NumLock Problem

Discussion in 'Windows Guest OS Discussion' started by Ray Konopka, Sep 11, 2014.

  1. Ray Konopka

    Ray Konopka Bit Poster

    Messages:
    26
    Just upgraded to Parallels 10. I am now experiencing a consistent problem with the NumLock Key in my VMs. I use an attached Microsoft keyboard to my MacBook Pro and I am old-school and I use the number key pad for cursor navigation, etc. As a result, I have NumLock turned off. Up until Parallels 10, this has worked just fine.

    However, with Parallels 10, every time I start a VM (Windows 7 64-bit), and I go to use the number key pad for moving the cursor, I get Numbers instead. However, the NumLock light on the keyboard is NOT on. I then have to press the NumLock key, which turns ON the NumLock light on the keyboard, but pressing any of the number key pad keys still results in numbers being entered. I then have to press the NumLock key a second time, which turns OFF the NumLock light on the keyboard, and then the number key pad keys start working correctly.

    I have to do this little step each time I start a VM. Fortunately, once I do this, the key pad keys do work correctly, but I never had to do this in previous versions of Parallels Desktop for Mac.

    Ray
     
  2. Digdug

    Digdug Bit Poster

    Messages:
    18
    I am having the same problem. Probably because Mac doesn't really have a "Num-Lock", so on Mac the numeric keypad is always numbers. I have searched in-vain for a solution and even opened a support ticket with parallels. They suggested some stuff which didn't work then closed the ticket. This worked just fine on v9. It is so annoying, I have resorted to putting a sticky note over my numeric keypad to prevent myself from using it. Totally ghetto.

    Parallels people, you broke something here...
     
  3. Ray Konopka

    Ray Konopka Bit Poster

    Messages:
    26
    Good to know I'm not the only one experiencing it. Looks like I'm going to have to open a ticket as well. Especially since the same issue affects the Ctrl+Alt key combination. I've not had any problems with the keyboard until PD 10, and I've been using PD since version 5. Clearly they broke something.
     
  4. SerMont

    SerMont Bit Poster

    Messages:
    32
    I have absolutely same issue with numlock!!! I was waiting that someone wrore about that. Thank you Ray! Please keep me informed about this...
     
  5. Ray Konopka

    Ray Konopka Bit Poster

    Messages:
    26
    As I posted in a related thread (turns out the issues were related), I setup a support chat session with PD tech staff and after trying lots of things, the tech escalated the issue. Today I was informed that PD has been able to duplicate the issue in their labs and is moving on to the next steps. The issue should be fixed in a future update.
     
  6. SerMont

    SerMont Bit Poster

    Messages:
    32
    OK. Thank you Ray!
     
  7. MahmoodP

    MahmoodP Bit Poster

    Messages:
    3
    I'm having the same issue as well. I hope they release an update soon as it is driving me crazy.
     

Share This Page