Parallels 11 activation on OSX 10.13.6 fails (Check your Internet connection)

Discussion in 'Installation and Configuration of Parallels Desktop' started by MichaelP88, Mar 12, 2023.

  1. MichaelP88

    MichaelP88 Bit poster

    Dear all,
    there are already at least 2 similar threads with the same topic but without any solution so far.
    I just completely reinstalled my iMac mid2011 from scratch (after reformatting the drives).
    I used the latest OSX supported for that model which is 10.13.6 High Sierra (where Parallels 11 was running fine before I formatted the drives).
    During the Parallels 11 installation process I was asked to enter my account data for activation.
    It failed with the following error message: "Check your Internet connection". My internet connection is fine! I am just logged in in my Parallels account and downloaded my P11 copy from there (plus the license key).
    I think Parallels has changed something with the activation servers (I faced the same issue with Adobe Lightroom 6, but Adobe provided a workaround for this).
    Can you please support and tell me how to activate my copy of Parallels 11 on OSX 10.13.6.? I payed for it and legally own it (without any expiration date)! I think I should be able to install and use it.
    To make things clear. Product is "Parallels Desktop 11 for Mac". I entered correct mail-address and password for my parallels account. After confirmation - the error message "Check your Internet connection" appears.
    From my experience with Adobe Lightroom 6 activation I think there it was related to an update of the Adobe activation servers to TLS 1.2.
    Please Parallels Support - help the users with this activation issue. I am not alone.
    I already tried and But after executing all the steps the problem still exists.
    Thank you and best regards!
  2. ParallelsU130

    ParallelsU130 Member

    I run OS X 10.9 but I have the same problem after upgrading my iMac with a new SSD drive where the optical drive used to be. Parallels 11 used to run fine but when I was asked to activate it after cloning the system to the SSD, I got "Unable to perform the operation - please check your internet connection". Like you, my connection is fine.

    I can't criticise the support I finally got, but they couldn't resolve the problem. However, through trial and error I've discovered the cause:
    - due to poor programming, Parallels only recognises /dev/disk0 (which is my old HDD, still in place) as the internal boot drive, and thinks /dev/disk1 (the new SSD) is an external drive and so refuses to activate.

    If you launch Terminal and type diskutil list you will see all your drives - if your main boot system drive is not /dev/disk0 then I believe that's your problem. If it is though, then you have a different problem, and I wish you luck.
  3. Tharun@P

    Tharun@P Moderator

    Hello Michael088, Please open the terminal on your Mac and then type this code: prlsrvctl install-license -k. After -k, give a single space, and then type the licence key and press enter to activate your key. Thanks.
  4. MichaelP88

    MichaelP88 Bit poster

    Hello Tharun,
    I tired and got the following error: Failed to install the license: PRL_ERR_LICENSE_UPGRADE_NO_PERMANENT_LICENSE
    My P11 license is an upgrade license. I bought full license for Parallels 8, then upgraded to 9, then upgraded to 11. So i have a total of 3 license keys (1 full + 2 upgrade).
    How to enter this cascade of license keys to activate P11?
    Thank you very much!!!
  5. ParallelsU130

    ParallelsU130 Member

    That solution didn't cure the problem for me, but I hope it does for you, Michael.
  6. MichaelP88

    MichaelP88 Bit poster

    It really makes me very sad that I don't get any support here and I don't get any help in solving my problem.
    I have the impression that Parallels is only interested in me when they want to sell something.
    Again, I paid for the product and I just want to use the licenses that are mine.
    In my opinion, Parallels is responsible for making this work.
  7. JamesB15

    JamesB15 Bit poster


    Like MichaelP88, I also reinstalled my mac OS (Sierra) from scratch and cannot connect to Parallels' server to activate my license. I am trying to install Parallels version 11. I've followed the directions in KB 113744 but was unable to connect. My OS is a "clean install". By "clean install", I mean that SSD was formatted, Sierra was installed, and only Parallels 11 was installed and no other software was installed.

    Tharun@P instructions to type the code via a terminal window resulted in a statement that my license was activated. HOWEVER, the Parallels software still prompts to log into their server. When I launch Parallels, it goes to the login screen. I enter my credentials and then I receive the error "Check your internet connection and try again. If the problem persists, follow "this link" to register your copy of Parallels Desktop".

    My internet connection works. There is no proxy, firewall is off (both mac and router), and there are no Parallels listings when executing cat etc hosts. If I log into my Parallels account via a web browser, I can verify that my Parallels license is valid. Please help.
  8. Avinash Bundhoo

    Avinash Bundhoo Staff Member


    Please check your personal message inbox, and reply to us at your convenience.

    Thank you!
  9. JimH19

    JimH19 Bit poster

    It would be helpful to others having the same issues if the response/solution wasn't sent via pmail. I am now having this exact issue, with identical conditions regarding install/proxy/firewall/terminal license install, etc.

    Does anyone have a concrete solution at this point that they can post?
  10. Chris72

    Chris72 Bit poster

    I'm not the original poster, but have the same problem.
    These kb's 124073 124225 113624 113744 are all useless.
    I've been waiting to find a real and working solution to be able to use my Parallels Desktop again! It's been more than a year!

    Does it have to do with trust chain DST Root CA X3 being expired? But it seems others with latter MacOS still have this problem.

Share This Page