Parallels 11 Copy and Paste speed

Discussion in 'General Questions' started by AdamN2, Apr 7, 2016.

  1. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    Hello,

    Recently upgraded from Parallels 10 to 11, and the copy and paste functionality from Mac to Windows is noticeably slower. It sometimes pastes the last copied item, with a 4-5 second delay. Please advise if there is a fix to this issue or what I can do to speed it up.

    Thanks,
    A
     
  2. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    Anybody? So I just paid for a slower product?
     
  3. kat

    kat Product Expert

    Messages:
    823
  4. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    Already did that. Didn't do anything.
     
  5. kat

    kat Product Expert

    Messages:
    823
    Hi Adam,
    A few question:
    • What is your mac os?
    • What Windows VM are you running?
    • How are your preferences set in your vm under Optimization. Ie Faster Virtual Machine > Tune Windows for speed?
    • Under More Options Do you have Share Mac Clipboard checked?
    • Under Hardware what is you cpu & memory configuration?
    • How much RAM does your mac have? How big is your hard drive?
    I will not be available until tomorrow, but if you answer the above questions someone else may be able to assist you before then.
     
  6. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    - OSX EL Capitan 10.11.4 (15E65)
    - Windows 8
    - Faster virtual machine. Checked both options, Hypervisor + Tune windows for speed
    - Yes
    - Processors: 1, Memory: 1024MB
    - 8 GB 1600 MHz DDR3, 2.3 GHz Intel Core i7, 250GB, NVIDIA GeForce GT 650M 1024 MB
     
  7. dvonroeder

    dvonroeder Bit Poster

    Messages:
    8
    I hit the same thing and the fix was to uncheck "Preserve text formatting" under Options/More Options.
     
  8. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    Thanks for the reply! I saw that option, unchecked it and ran into the same issue. It may be for certain programs that this problem persists, but will try again and reboot the VM.
     
  9. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    Yes, unfortunately the problem persists on my end. I am using appraisal software called CRAL. It is made for Windows, however, I did not have this issue in Parallels 10 which is what bothers me. Hopefully they take this serious and come up with a patch, or I will not shell out any more money to this company.
     
  10. kat

    kat Product Expert

    Messages:
    823
    Hi Adam, the copy paste issue is only with the one program?

    There is a knowledgeable article referring to Windows 8 and copy paste: http://kb.parallels.com/en/117984
    it may or may not help if it is only the one program. But it is worth a review.
     
    Last edited: Apr 12, 2016
  11. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    It's the only one I use, and wouldn't have a reason to use Windows otherwise. But I didn't have this issue in the previous version, so it has to be on the Parallels end.
     
  12. marcel1

    marcel1 Bit Poster

    Messages:
    7
    I have the same issue. I'm using Alfred(https://www.alfredapp.com/) and therefore its clipboard and now textexpanding.
    Sadly Parallels doesn't keep up with updating the clipboard. Sometimes it works, but most of the time i get the old copied value.
    I'm on OS X 10.11.5 and Parallels Desktop 11.2.0(32581)
    This has been around for quite a while now. Would be awesome if this would get fixed as this is stopping real productivity....
     
  13. AdamN2

    AdamN2 Bit Poster

    Messages:
    9
    Spent 2 hours with support, thought it was fixed, it wasn't. Ended up allocating more resources, then my laptop crashed, so I don't advise doing that. Best workaround I'm using is to only copy/paste from Windows to Windows, and not Mac to Windows. Used VMWare, was completely unsatisfied, so Parallels does have many benefits, but this should really be fixed.
     
  14. marcel1

    marcel1 Bit Poster

    Messages:
    7
    Well windows to windows has no benefit for me. I need mac to windows :/ A clipboard history and textexpands are so useful if parallels would work with them.
    I can't believe that this is hard to fix.
     
    Last edited: May 30, 2016
  15. William Fulmer

    William Fulmer Bit Poster

    Messages:
    14
    Same issue here with Parallels 11.2.0 (32581) and copy/paste issue. Sometimes have to copy/paste two times for the appropriate text to paste.
     
  16. kat

    kat Product Expert

    Messages:
    823
    Have you tried updating or reinstalling Parallels Tools?
     
  17. Ajith1

    Ajith1 Parallels Support

    Messages:
    2,719
    Hello William Fulmer,

    Try uninstall and reinstall Parallels Tools then check. You can refer this article.

    Thanks,
    Ajith M.
     
  18. marcel1

    marcel1 Bit Poster

    Messages:
    7
    I just tested it and it doesn't work. Something has to be changed on Paralles side, code wise. Like a refresh trigger, better and faster reaction etc.
     
  19. Arunn

    Arunn Parallels Support

    Messages:
    300
    Hi, follow the steps mentioned below:
    1. Take a snapshot of Windows virtual machine.
    2. Clean temp files by performing Disk Cleanup.
    3. Shut down Windows and quit Parallels Desktop for Mac.
    4. Go to Mac > Disk Utility > choose Mac HD and run First Aid.
    Restart Mac and launch Windows virtual machine. Try copy paste between Windows and Mac.
     
  20. marcel1

    marcel1 Bit Poster

    Messages:
    7
    I guess you don't understand what everyone is meaning here. I'm getting pretty pissed about the ignorance the Parallels Team is showing here.
    The whole issue is not one of crumbled up temp files or any other problem with the Parallels Tools having to be reinstalled. It is an issue of Parallels
    Tools itself. If it wouldn't be, then there wouldn't be so many people having this issue.

    In fact, the issue is that Parallels is syncing/updating the Clipboard too slow. When you copy things slowly then there's no problem to copy
    things from mac to windows. However, I'm not 90 yet and therefore faster. Besides that, I'm using an App called Alfred which has a clipboard history and snippets. Neither of that can be used in Parallels due to the slow clipboard syncing. It doesn't matter if it's a fresh install, Parallels Tools are fresh installed or anything else is activated, deactivated etc....I've tried anything I could find in the Forums or what I could come up with myself.
    I'm not the only one having this issue and if this would be something to be fixed easily by reinstalling Parallels Tools or cleaning the Temp files etc., then not that many people would have this issue. So once again, please fix this on your side and don't refer to anything to "fix" something that is broken anyway. I don't think that you have even tried it yourself if I get such a reply. It's like when my Bike tire is broken(has a hole) and someone tells me "Why don't you inflate your Bike tires again".

    Here is an example(cannot embed gifs): http://i.imgur.com/YYH0bwb.gifv
    In my example is simply Copy pasta around from apps to windows and from Alfred. It works like once or twice, but most of the time is too slow.
     

Share This Page