Parallels 11 = No More Auto-Pausing

Discussion in 'Windows Guest OS Discussion' started by magikmanpro, Aug 21, 2015.

  1. magikmanpro

    magikmanpro Bit Poster

    Messages:
    20
    Since upgrading to Parallels 11, my Windows VMs (7 and 10) will not longer auto-pause themselves when all apps are closed. I've tried reinstalling Parallels Tools, and things seem to work for a bit. But, within a day, the VMs stay active and will not pause unless I manually trigger a pause.

    Anyone else seeing this? Any recommendations?
     
  2. JohnNash

    JohnNash Bit Poster

    Messages:
    42
    Having this problem as well.
     
  3. AlekseyM

    AlekseyM Product Expert

    Messages:
    210
    The pause only happens when you are in coherence mode. Another alternative that I use, is in windows power settings, set your VM to go to sleep after a set time. When it goes to sleep, it actually pauses the VM.
     
  4. magikmanpro

    magikmanpro Bit Poster

    Messages:
    20
    There is no relationship between auto-pause and coherence, though I generally prefer to work in that mode. I have often worked in a windowed mode and view the same auto-pause behavior. This still continues to work in Parallels 10 and even in Parallels 11 right after reinstalling Parallels Tools. But, after a period, it stops doing it.

    I have found that this may be more prevalent in Win10 VMs. I recently had both Win7 and Win10 up in windowed mode, and Win7 did eventually pause itself. Not nearly as quickly as before (usually it's 30 seconds after all apps closed; this time was at least 10 minutes). But, it worked. Win10 VM will stay awake forever.

    Thanks for the tip on the sleep settings for the VM, that may be a great workaround. I'll give it a try right away.
     
  5. marat_t

    marat_t Kilo Poster

    Messages:
    288
    auto-pause behavior has been improved in version 11:
    - VM does not go paused if Windows updates are being installed
    - Some fixes for erroneous switch to auto-pause (apps background activity, like torrents)
    - Copy/Paste operations between host and VM keep VM awake as they should
    So, check that there are no activities in the background
     
  6. magikmanpro

    magikmanpro Bit Poster

    Messages:
    20
    Thanks for the input. I've been playing around more and even been able to make auto-pause work. In my opinion, Parallels 11 is WAY too sensitive about what's considered an open/running app. I've basically had to disable a lot of services that didn't previously register as activity to stop pausing.

    The GoToMeeting app allows for quick launching of a meeting. It's not a full app, does need to be launched, and doesn't appear as a running app. However, it prevents Parallels from pausing. Also, I use NetExtender for VPN access. When a connection is active, Parallels 11 will not pause (10 had no issue here). I used to like having the VPN connection there to always come back when needed, but now I have to either manually pause or disconnect for auto-pause to occur. These kinds of things shouldn't be considered "open apps" and should allow pausing.
     

Share This Page