Parallels 16 extremely slow on MBP

Discussion in 'Installation and Configuration' started by PatrickP9, Oct 6, 2020.

  1. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    17
    Same problem as previously described throughout the thread. Occasionally we have seconds-long delays between clicking UI elements in the VM and it being responsive. For instance closing a window, clicking a folder in Explorer, clicking start menu. Basic things that should always be snappy.
     
  2. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Hello, did you get the same issue before?
    Could you check this KB article and try to perform the instructions please?
     
  3. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    17
    Hi, yes it's been this issue for over a year now throughout v16 and still (to a lesser extent) with v17, I've reviewed the document again and no change.
     
  4. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,693
    Hello, could you collect the technical report once the issue reproduced and post the report's ID here please?
     
  5. ChrisW46

    ChrisW46 Bit Poster

    Messages:
    1
    V17 solved the problem for me, and I had it bad in V16. I'm on a late 2015 27in iMac with 16gb ram and 512 ssd. So $50 to create the problem (upgrading to v16) and another $50 to solve it (upgrading to v17), but I'm still ecstatic!
     
  6. BenMc

    BenMc Bit Poster

    Messages:
    3
    I had this issue, in particular with the CPU usage jammed at '100%' and everything taking ages to run. Turned out I have a big monitor and I had 'scaled' mode on. Setting 'Best for External Display' fixed the issue.

    Parallels staff, I tried many things over the lost half a day this cost me, and was on the verge of purchasing VMWare. It would be great if there was a separate indicator for graphics CPU usage so that this problem could be easily diagnosed. If there had been, I would have immediately seen the issue. The age of big screens is upon us.
     
  7. MissyT

    MissyT Bit Poster

    Messages:
    11
    I have been experiencing the same issue. But I am noticing the problem only occurs with my Windows 10 guest. But I was expecting better result with Big azar Sur but all useless. and Changing omegle video RAM made no difference to me.
    I began my Parallels Toolbox update and its still not done yet. Something is very wrong.
    My system:
    Model Name: iMac
    Model Identifier: iMac19,2
    Operating System: macOS 10.15.7 (Build 19H15)
    Model: iMac19,2
    Model ID : iMac19,2
    Motherboard : Acidanthera Mac-63001698E7A34814 iMac19,2
    Processor Name: 6-Core Intel Core i5
    Processor Speed: 3.1 GHz
    Number of Processors: 1
    Total Number of Cores: 6
    Memory: 32 GB
    System Firmware Version: 1555.50.2.0.0
    SMC Version (system): 2.46f12
     
  8. BenMc

    BenMc Bit Poster

    Messages:
    3
    I've been meaning to post that above did not work. It's back to unusable again. The frustrating part is trying to work out where the issues lies. It could be OSX, but I've had the same setup for 18 months and simply nothing has changed - it just started happening one day: no Win 10 Update, no Parallels update. There may have been an OSX update, since I generally apply those without thinking.
    Weirdly the issue seems to be time-of-day related. I can use the VM all morning, and then about 1:30pm it starts to run really slowly, and then by about 7pm it's back to normal. This is perhaps why I thought it was fixed.
    I develop websites on Visual Studio, and in the mornings they work fine, but in the afternoons I can't even view a lot of pages because the database request times out before it returns a result.
    I've gone and bought VMWare now, which is running generally more slowly than Parallels (when it's running well), but at least doesn't seem to have the slow-down issue. I'd prefer to use Parallels, but this is just ridiculous. I'm considering going and buying Windows hardware or just running under boot camp (unfortunately not an option on the new M1's). It's a sad day, but reliability is the number 1 concern. This issue has probably cost me about $2000 in lost time so far.

    Parallels 17, Bug Sur 11.6
     
  9. ThanhD3

    ThanhD3 Bit Poster

    Messages:
    2
  10. ThanhD3

    ThanhD3 Bit Poster

    Messages:
    2
    I followed the instructions, and it fixed it.
    https://kb.parallels.com/123069
    i think because parallels tool error, reinstall parallels Tool to fixed.
     
  11. ONURY1

    ONURY1 Bit Poster

    Messages:
    8
    I don't think you are running smoothly and properly in version 17. Although the system configuration is quite good, I am having a lot of trouble. Sometimes not even a mouse click.
     
  12. MichaelM125

    MichaelM125

    Messages:
    1
    This has been an issue for two years. I have a 2019 Mac Mini with 32gb of ram and have allocated the max amount of cpu and ram and still excel is sluggish. Scrolling is choppy and lines jump. There are multiple threads on the forums about this topic and the Parallels team doesn't seem to care about this. I have spent good money on Parallels every year and the last two years have been a huge waste.
     
  13. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hi, kindly update to the build version of Parallels Desktop 16 and update us.
     
  14. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hi, we are sorry to hear that. We will try our best to resolve this issue as soon as possible. Please let us know which version of Parallels Desktop you are using.
     
  15. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    176
    Hello Michael,
    A technical report will help us to sort it out - probably, there are some applications inside the virtual machine consuming a significant amount of resources, misconfiguration, etc. So, reproduce the issue and collect a technical report at the moment of reproduction as per https://kb.parallels.com/9058 . Once done, provide us with a 9-digit code of the report, we'll try to find the root cause and help you.
     
  16. DineshS3

    DineshS3

    Messages:
    1
    Hello, I am using Parallel 18.0 in my Macbook Pro M2 Sillicon chip, but while playing games it is extremely slow, unplayable. Please help.
     
  17. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    176
    Hello!
    Kindly collect a fresh technical report at the moment of reproduction (click Parallels icon (||) > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in your reply.
    Does the issue persist for all games or some specific games? What are those games?
    If you don't play games, is the performance better?
     
  18. lalits

    lalits

    Messages:
    1
    Hi all,
    I have a MBP16, 8 core i9, 64gb memory, 8gb AMD Radeon and for some reason Parallels is unbearably slow.
    Parallels is configured on "Games only" mode with 4 processors and 8gb of memory, running on Windows 10.

    I can barely move the mouse across across the screen when on Parallels as there is a 15 sec response lag.

    Any ideas why this could be the case?

    ps: Bootcamp is running very smoothly and without any problems.

    Thanks
















































    TutuApp
     
  19. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    176
     

Share This Page