Parallels 18 guest/VM shutdown issue...?

Discussion in 'General Questions' started by MikeL6, Aug 16, 2022.

  1. MikeL6

    MikeL6 Bit Poster

    Messages:
    4
    Before I reinstall, anyone seeing any issues with guest shutdown in v18 ?
    This is on an Intel iMac, seen so far on 2 different Win 10 VMs...if you issue a Windows shutdown within the guest, it does shut down and the guest window closes but it leaves the VM "hanging" in the top menu bar, like there's a process still running?
    I can work around it (eg force quit Parallels) but it's an annoyance. If no replies to this will assume its me (!) and try reinstalling tonight...
    TVM
     
  2. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    437
    Hello MikeL6, To shut down Windows, do one of the following. Click the Parallels icon in the menu bar, press and hold the Option (Alt) key and choose Actions > Shut Down. If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Shut Down. Thanks.
     
  3. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    479
    Geez. That's not what he's talking about at all. Please learn to read.

    @MikeL6 - I've actually closed down VMs and noticed the menu never changes from the closed VM to the Parallels menu. I don't think the VM is hung, just that the menu's not been updated. You should be able to kick off another VM from the Control Center. Alternatively you should be able to shut down Parallels from the Parallels icon in the menu bar if you have that enabled. You shouldn't need to force quit.
     
  4. MikeL6

    MikeL6 Bit Poster

    Messages:
    4
    Thanks Mark ! See screenshot (attached) - the guest named Windows 10 QB has been shut down cleanly, yet it appears in the top menu still.
     

    Attached Files:

  5. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    479
    I understand. It happens to me as well sometimes. It might happen more often to you as it looks like you have Windows on an external disk, so it may be a little slower to react in certain instances and the menu gets stuck on whatever you ran last.
    Again, in this case, the best way to exit Parallels is from the small icon towards the left of the menu bar (monitor icon with two vertical lines in it). Click on that and there's a Quit menu item in the pull-down menu "Quit Parallels Desktop"). If you can't see the icon because the right side of the menu bar is chock-full of icons and things (like iStatMenu indicators), try clicking on a blank area of the desktop. That will usually show the full menu bar.
     
  6. Aries@PF

    Aries@PF Kilo Poster

    Messages:
    217
    This has been happening to me lately with the v18 of parallels I've noticed. I've had to go so far as to force quit the whole app to get it to go away as sometimes toggling to the list of VMs won't do it.
     
  7. Aries@PF

    Aries@PF Kilo Poster

    Messages:
    217
    To clarify, I Always use the Parallels menu command to shutdown the VMs, but I still get this behavior. Monterey host, v18, intel.
     
  8. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    479
    If you're not seeing the icon in the menu bar, check this item Parallels' main preferences per the attached image: Preferences.jpg
     
  9. Nazeemabanu@Parallels

    Nazeemabanu@Parallels Staff Member

    Messages:
    139
    Hello, Please reinstall the Parallels Desktop version 18 and try to shut down the virtual machine. If you have an issue, then go to activity monitor, locate any windows virtual machine thread that is running or only Parallels Application. Once you spot any windows VM running, please share a screenshot along with the technical report ID as mentioned in this link - https://kb.parallels.com/en/9058. Also, let us know in which mode you start and shut down the windows VM, have you also tested the issue in different view modes 'windows/full screen/coherence' mode? Thanks.
     

Share This Page