Parallels 18 install stuck at "Initializing parallels desktop" on macOS Ventura

Discussion in 'Installation and Configuration' started by VictorE, Nov 15, 2022.

  1. VictorE

    VictorE Bit Poster

    I have a MacMini 2018 running macOS BigSur and Parallels 17. Yesterday I updated to macOS Ventura, downloaded the evaluation version of Parallels 18 and tried to installed. It uninstalled my previous Parallels 17 but then got stuck on "Initializing parallels desktop". I tried rebooting the computer, removing any trace of the previous version but so far nothing has worked.

    Any ideas about how to get the installer complete it task ?

    Honestly I feel like each version of Parallels is less and less "it just work" than the previous.
  2. VictorE

    VictorE Bit Poster

    I performed a new test by doing this:

    1) Installed AppCleaner app and granted full disk access
    2) Installed a try version of Parallels in another MacMini (running Catalina)
    3) Copied Parallels App to my MacMini 2018 and dropped it on AppCleaner, to make sure I had no trace of any previous installation attempts.
    4) Downloaded the last Parallels installer from Parallel's site
    5) Started the install process and waited 15 min on the "Initializing Parallels Desktop" window
    6) Killed the install process
    7) Went to /Library/Logs/parallles.log to check what I could find there

    And this is the full content of parallels.log:

    11-17 18:32:45.450 F /inittool-wrap:34584:100d84/ INIT_STATE: STATE_UNINSTALL
    11-17 18:32:45.451 F /inittool-wrap:34584:100d84/ INIT_PROGRESS: 0
    11-17 18:32:45.480 F /inittool-wrap:34584:100d84/ INIT_PROGRESS: 15
    11-17 18:32:46.753 F /inittool-wrap:34584:100d84/ INIT_PROGRESS: 32
    11-17 18:32:46.756 F /inittool-wrap:34584:100d84/ INIT_PROGRESS: 47
  3. VictorE

    VictorE Bit Poster

    Well, I decided to start over and installed macOS Catalina; then installed Parallels 18 (that now worked without issue) and then upgraded to macOS everything is working as it should has been from the beginning. Between the bug in Parallels 16 with the virtualizer setting, the bug in Parallels 17 with attaching USB devices to the MV and the install issue in PArallels 18 & macOS Ventura, the Parallels's experience is faaaaar from Apple's "it just work", I have to say.

Share This Page