Parallels 4.0 hangs at startup

Discussion in 'Installation and Configuration of Parallels Desktop' started by Pleiades, Nov 11, 2008.

  1. Pleiades

    Pleiades Member

    I upgraded directly from 3.0 to 4.0 but when I try to run PD, it hangs on startup. The icon bounces for a long time before settling down and doing nothing. Checking the Activity Monitor, both Parallels Desktop and Parallels Starter are hung and are not responding. The application name never appears in the title bar and no windows ever show up.

    I tried uninstalling it, reinstalling it, uninstalling it, deleting all traces I could find including preference files, and reinstalling it, all with restarts or shutdowns in between.

    It still behaves in exactly the same way. It hangs on startup and refuses to proceed.
  2. kwgrooms

    kwgrooms Member

    Same here and this topic has been covered extensively. They have given "fixes" and none of them have worked for anyone yet. I am awaiting a reply both in e-mail and private message. Will post if I hear anything.
  3. summitscout

    summitscout Hunter

    You might try repairing disk permissions with Disk Utility and/or restarting your machine. Do either of these work for you?
  4. gdoerrhoefer

    gdoerrhoefer Bit poster

    Same Problem here

    Repairing disk permissions does not solve this problem either. I hope that future installers try to keep the previous version. I know now that using versions with a zero at the end is not a good idea.

    My System:
    Model: MacBookPro1,1, BootROM MBP11.0055.B08, 2 processors, Intel Core Duo, 1.83 GHz, 2 GB
    Graphics: kHW_ATIr520Item, ATY,RadeonX1600, spdisplays_pcie_device, 128 MB
    Memory Module: BANK 0/DIMM0, 1 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x86),
    Bluetooth: Version 2.1.0f17, 2 service, 1 devices, 1 incoming serial ports
    Network Service: Ethernet (integriert), Ethernet, en0
    Network Service: USB-Ethernet (en5), Ethernet, en5
    Network Service: Parallels Shared Networking Adapter, Ethernet, en6
    Network Service: Parallels Host-Only Networking Adapter, Ethernet, en7
    Serial ATA Device: ST9160823AS, 149,05 GB
    Parallel ATA Device: MATSHITADVD-R UJ-857
    USB Device: Built-in iSight, Micron, high_speed, 500 mA
    USB Device: hub_device, high_speed, 500 mA
    USB Device: Hub in Apple Extended USB Keyboard, Mitsumi Electric, full_speed, 500 mA
    USB Device: Apple Optical USB Mouse, Mitsumi Electric, low_speed, 100 mA
    USB Device: Apple Extended USB Keyboard, Mitsumi Electric, full_speed, 250 mA
    USB Device: hub_device, high_speed, 500 mA
    USB Device: CanoScan, Canon, high_speed, 500 mA
    USB Device: USB 7-in-1 Card Reader, OTi, high_speed, 500 mA
    USB Device: Cinergy T USB XS, TerraTec Electronic GmbH, high_speed, 500 mA
    USB Device: Apple Cinema Display, Apple Computer, Inc., full_speed, 500 mA
    USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, full_speed, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., full_speed, 500 mA
    USB Device: Bluetooth USB Host Controller, Apple, Inc., full_speed, 500 mA
    FireWire Device: unknown_device, unknown_value, unknown_speed

    Start of the Crash-report (after aborting PD):

    Date/Time: 2008-11-12 15:12:56 +0100
    OS Version: 10.5.5 (Build 9F33)
    Architecture: i386
    Report Version: 4

    Command: Parallels Desktop
    Path: /Applications/Parallels
    Version: 4.0 (3522.205912)
    Build Version: 4.0.3522.205912
    Project Name: Parallels
    Source Version: 3522.205912
    Parent: launchd [107]

    PID: 2082
    Event: hang
    Time: 6.66s
    Steps: 36

    Process: prl_client_app [2082]
    Path: /Applications/Parallels

    00001000 /Applications/Parallels
    00e67000 /usr/lib/libpam.1.dylib
    00e76000 /Library/Parallels/Parallels
    00ef3000 /Library/Parallels/Parallels
    00f73000 /Library/Parallels/Parallels
    018a3000 /Library/Parallels/Parallels
    01972000 /Library/Parallels/Parallels

    Thread id: 7fcb5d0
    User stack:
    Last edited: Nov 12, 2008
  5. Pleiades

    Pleiades Member

    After a couple of days of trying, I still cannot get the program to launch successfully on my MBP. The icon bounces many times and then finally stops. No windows appear, nothing. Activity Monitor shows that PD and Parallels Starter are not responding. Fixing permissions, repairing disk (no issues), reinstalling numerous times, have not helped at all.

    I've gone in and deleted almost everything in my startup account, leaving only iTunes Helper and Airport Base Station Agent. I can't think of any program that's running that PD could possibly be conflicting with.

    Any idea why this program simply won't start up?
  6. MattieG

    MattieG Bit poster

    I too have this issue, although it does not happen when using any other user other than my original admin (501) user. See if this happens with you too. If this is the case, there must be something up with a file somewhere in my admin's home folder that is causing the hang.
  7. bi11

    bi11 Hunter

    Have you looked at your system logs to see if anything is printed there when you try and start parallels?
  8. superjet1990

    superjet1990 Bit poster

    I am having the same problem. I did find a way to make it work by making a new admin user and i installed it under that new user and it worked fine. When i switch to my main user and try to open parallels i just the same freezing again but if i switch to my other user it works fine? I can't figure this one out?. It must have a conflict with something in my main user account.
  9. superjet1990

    superjet1990 Bit poster

    Has anyone found a solution?
  10. superjet1990

    superjet1990 Bit poster

    Someone Please Help
  11. wa6vvv

    wa6vvv Bit poster

    Slightly different hang

    I upgraded to 4.0 and Parallels Desktop will not even start up. It doesn't crash, but it quits before really starting. There is the following message in system.log:[129] ([0x0-0x26026].com.parallels.desktop.console[326]): Exited with exit code: 9

    Starting Parallels Explorer yields a dialog box that says: Unable to find Parallels SDK library, and a system log entry of:

    om.parallels.server.explorer[358]: Failed to load Parallels SDK library: 80000010, from file: /../../Contents/Resources/libprl_sdk.dylib

    That dylib is there and has proper permissions. I have attached the system.log from the installation.

    Attached Files:

  12. summitscout

    summitscout Hunter

    Check Console for clues

    Bi11 made the best suggestion for the first step of troubleshooting non-starting apps: check your console for error messages.


    View all messages and also check:
    ~/Library/Logs/Parallels and
  13. wa6vvv

    wa6vvv Bit poster

    Log Contents

    Console log wa shown above. /Library/Logs/Parallels/parallels.log contains a lot of stuff that does not appear to identify itself as errors, although its difficutl to tell. It does contain a large number of:

    01:57:50.830 F /gui:325/ Failed to load SDK library
    01:57:50.831 F /gui:325/ Error while initializing SDK. Return code: [-2147483639]

    I suspect the libprl_sdk.dylib is somehow corrupted as I can find it using each of the various references it has. I have installed from the CD and also from the updated download with exactly the same results.
  14. wa6vvv

    wa6vvv Bit poster

    Making Progress

    After many hours of digging around I have found tha Parallels does not use that name in the startup processes. The actual process name used is prl_client_app. You have to use that name with dtruss to trace what is happening. Doing that I find that it make the following attenots to find the SDK:

    stat("/Library/Frameworks/ParallelsVirtualizationSDK.framework/Libraries/libprl_sdk.dylib\0", 0xBFFFE488, 0xBFFFF2AC) = -1 Err#2
    11814/0x81b67d8: stat("/Users/doug/lib/libprl_sdk.dylib\0", 0xBFFFED08, 0xBFFFF2AC) = -1 Err#2
    11814/0x81b67d8: stat("/usr/local/lib/libprl_sdk.dylib\0", 0xBFFFED08, 0xBFFFF2AC) = -1 Err#2

    As you can see none of them work. None of those files exist. Somehow I suspect the first one should have been installed by the installer but was not.
  15. wa6vvv

    wa6vvv Bit poster


    I have found the installation problem. If you have the directory /usr/local/lib defined on your system, then Parallels places links to the SDK there. However, they use relative links of the form: ../../../.... Since MacOS has a tendency to remove and recreate /usr/local leaving it in its normal place tends to cause problems. I have it sym linked off to an location in my home directory so that at worst only the link gets removed. That can easily be recreated. However, then the Parallels sym links no longer work. They are making presumptions about the directory structure that are not always valid. They should be using full file references. Once I changed the link for the SDK to the real location where it is stored in the app, then Parallels started up properly.
  16. eric59

    eric59 Bit poster

    same problem

    reported it.

    here's the id:

  17. Menudo

    Menudo Bit poster


    Do you have a step-by-step procedure on how to make this change? I'm relatively new to Macs, having mine for about a year. I was able to find out that the change has to made in Terminal which looks like the DOS screen in Windows. I don't know what commands to type.

    Also, doesn't the Parallels developers know about this bug? According to this thread, it's been around for about a month. I e-mailed their tech support and they linked me to here. Do they plan a bug fix?

    I appreciate any help.
  18. wa6vvv

    wa6vvv Bit poster

    The approach depends on how your system (in particular /usr/local/lib) is setup. The developers certainly know about this situation so there should be a more permanent fix sometime fairly soon. To figure out what needs to be done go to terminal (in utilities) and enter:

    cd /usr/local/lib
    pwd -P
    ls -l libprl_sdk*
    ls -l '/Library/Parallels/Parallels'

    Watch out for the last one. It has a space in it not a return. Post the results of all that.
  19. Menudo

    Menudo Bit poster

    Posting Results

    Here's what I get:

    Last login: Tue Dec 16 21:21:00 on console
    ricardo-rosarios-imac:~ RicardoRosario$ cd /usr/local/lib
    ricardo-rosarios-imac:lib RicardoRosario$ pwd -P
    ricardo-rosarios-imac:lib RicardoRosario$ ls -l libprl_sdk*
    ls: libprl_sdk*: No such file or directory
    ricardo-rosarios-imac:lib RicardoRosario$ ls -l '/Library/Parallels/Parallels'
    ls: /Library/Parallels/Parallels No such file or directory
    ricardo-rosarios-imac:lib RicardoRosario$

    Will wait to hear from you.
  20. wa6vvv

    wa6vvv Bit poster

    That is a different problem than I encountered. Parallels is not completely installed. I would suggest re-installing it. Make sure you are installing it as an admin user.

Share This Page